]> sipb.mit.edu Git - ikiwiki.git/blob - debian/NEWS
1.12 is not released yet
[ikiwiki.git] / debian / NEWS
1 ikiwiki (1.11) unstable; urgency=low
2
3   Some changes to tags in this release, due to a new tag plugin. If you have
4   been using the meta plugin to tag pages, you'll want to enable the tag
5   plugin too, and change things like this:
6
7   [[meta link="foobar"]]
8
9   To this:
10
11   [[tag foobar]]
12
13   The new tags will appear at page footers, and are also easier to type.
14
15   There have also been some changes to the plugin interface, particularly the
16   interface of pagetemplate hooks has changed. See the changelog for details.
17
18  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
19
20 ikiwiki (1.8) unstable; urgency=low
21
22   If your wiki is configured with a setup file, you should modify it to
23   stop setting the "plugin" list directly, and instead add or remove plugins
24   via the add_plugins and disable_plugins lines. For example, if you had:
25
26         plugin => [qw{inline smiley search}],
27
28   Change it to these lines, which disables the default htmlscrubber plugin
29   and adds the two additional plugins:
30
31         add_plugins => [qw{smiley search}],
32         disable_plugins => [qw{htmlscrubber}],
33
34   Making this change makes your ikiwiki setup file more future-proof since
35   new default plugins will be automatically used.
36   
37   You will need to rebuild your ikiwiki wrappers when upgrading to this
38   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
39   done automatically when the Debian package is upgraded. Or use
40   ikiiki-mass-rebuild --refresh to force a refresh.
41
42  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
43
44 ikiwiki (1.1) unstable; urgency=low
45
46   There have been several configuration changes in this release of ikiwiki:
47
48   The --svn and --no-svn switches are removed, instead you should use
49    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
50   be changed to set rcs => "svn"; if your setup file sets svn => 0
51   then change it to use rcs => "" to disable svn.
52
53   The --hyperestraier switch is gone too. To enable searching, turn on the
54   search plugin, by passing --plugin=search or through the plugin setting in
55   the setup file.
56
57   The --sanitize and --no-sanitize switches are also gone, replaced with the
58   htmlscrubber plugin. This plugin is enabled by default, to disable it,
59   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
60   setup file.
61
62   Discussion pages are enabled by default, but if your wiki is configured
63   with a setup file, you need to edit it to keep them enabled on upgrade
64   to this version. Add a line reading:
65   discussion => 1,
66
67   You will need to rebuild your wiki when upgrading to this version.
68   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
69   automatically when the Debian package is upgraded. Or use
70   ikiiki-mass-rebuild to force a rebuild.
71
72  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400