]> sipb.mit.edu Git - ikiwiki.git/blob - debian/NEWS
* Finally implemented a simple per-page data storage mechanism for plugins,
[ikiwiki.git] / debian / NEWS
1 ikiwiki (2.16) UNRELEASED; urgency=low
2
3   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
4   release, to avoid the basewiki including pages with names like "blog".
5   Redirection pages have been left behind for these moved pages temporarily,
6   and will be removed later.
7
8  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
9
10 ikiwiki (2.14) unstable; urgency=low
11
12   This version of ikiwiki is more picky about symlinks in the path leading
13   to the srcdir, and will refuse to use a srcdir specified by such a path.
14   This  was necessary to avoid some potential exploits, but could potentially
15   break (semi-)working wikis. If your wiki has a srcdir path containing a
16   symlink, you should change it to use a path that does not.
17
18  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
19
20 ikiwiki (2.9) unstable; urgency=low
21
22   Since ikiwiki 2.0 was released, some limitiations have been added to what
23   ikiwiki considers a WikiLink. In short, if there are any spaces in between
24   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
25   contains things meant to be WikiLinks that contain spaces, you will need to
26   fix them, by replacing the spaces with underscores.
27   
28   WikiLink have always been documented to not contain spaces, but bugs in
29   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
30   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
31   release. These fixes are necessary to avoid ambiguity between
32   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
33   these bugs (and their fixes) may have caused.
34
35  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
36
37 ikiwiki (2.6) unstable; urgency=low
38
39   In this version the rst plugin allows raw html to be embedded in rst files.
40   As long as the htmlscrubber is enabled, this should be safe. If you are
41   using the rst plugin without the htmlscrubber in a publically writable wiki,
42   you should turn on the htmlscrubber.
43
44  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
45
46 ikiwiki (2.5) unstable; urgency=low
47
48   Due to some config changes in this version, wrappers need to be rebuilt on
49   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
50   one automatically when the Debian package is upgraded.
51
52  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
53
54 ikiwiki (2.1) unstable; urgency=low
55
56   Some wikis need to be rebuilt on upgrade to this version, due to changes to
57   page templates and the style sheet. If you listed your wiki in
58   /etc/ikiwiki/wikilist this will be done automatically when the Debian
59   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
60
61  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
62
63 ikiwiki (2.00) unstable; urgency=low
64
65   With the 2.0 release of ikiwiki, some major changes have been made to the
66   default configuration:
67
68   * The 'usedirs' setting is enabled by default. This *will* break all URLs
69     to wikis that did not have 'usedirs' turned on before, unless you follow
70     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
71     or edit your setup file to turn usedirs off:
72        usedirs => 0,
73
74   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
75     perl module is available. Password logins are also still enabled
76     by default. If you like, you can turn either OpenID or password logins
77     off via the 'disable_plugins' setting.
78
79  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
80
81 ikiwiki (1.51) unstable; urgency=low
82
83   Some wikis need to be rebuilt on upgrade to this version, due to changes to
84   page layout and the style sheet. If you listed your wiki in
85   /etc/ikiwiki/wikilist this will be done automatically when the Debian
86   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
87
88  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
89
90 ikiwiki (1.50) unstable; urgency=low
91
92   Permalinks and guids in rss and atom feeds for wikis using the usedirs
93   options will change in this release. If you have already enabled usedirs,
94   you may need to take steps to avoid flooding aggregators.
95
96  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
97
98 ikiwiki (1.49) unstable; urgency=low
99
100   Third-party plugins that use htmlpage() or abs2rel() to generate links
101   may need changes to support the new "usedirs" option.
102
103  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
104
105 ikiwiki (1.47) unstable; urgency=low
106  
107   Due to a security fix, wikis that have the htmlscrubber enabled can no
108   longer use the meta plugin to insert html link and meta tags.
109
110   Some special case methods have been added for safely including stylesheets,
111   and for doing openid delegation. See the meta plugin docs for details.
112  
113  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
114
115 ikiwiki (1.45) unstable; urgency=low
116
117   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
118   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
119   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
120
121  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
122
123 ikiwiki (1.44) unstable; urgency=low
124
125   The htmllink() function has changed slightly and plugins that use it may
126   need to change how they call it. This function's first three parameters
127   are unchanged, but additional options are now passed using named
128   parameters. If you used htmllink with more than 3 parameters, you will
129   need to change it. The plugin interface version has been increased to 1.02
130   to reflect this change.
131
132  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
133
134 ikiwiki (1.42) unstable; urgency=low
135
136   The anonok setting in config files has been removed. To enable
137   httpauth support on your wiki, you should now enable the anonok plugin,
138   instead.
139
140   Third-party plugins that use pagespec_match() should be updated to pass
141   the new third parameter (from) to that function. This is needed for the
142   new relative glob matching to work.
143
144  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
145
146 ikiwiki (1.34) unstable; urgency=low
147
148   The httpauth setting in config files has been removed. To enable
149   httpauth support on your wiki, you should now enable the httpauth plugin,
150   instead.
151
152   This release includes OpenID support that is enabled through the openid
153   plugin. I recommend turning this on to make it easier for users to sign
154   in to your wiki.
155
156  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
157
158 ikiwiki (1.32) unstable; urgency=low
159
160   There is a change to the plugin interface in this version. Any plugins that
161   modify data in %links should pass scan => 1 when registering the hook that
162   does so.
163
164  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
165
166 ikiwiki (1.29) unstable; urgency=low
167
168   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
169   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
170   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
171
172   There is a change to the plugin interface in this version. Plugins that use
173   %renderedfiles will need to be updated, as the hash's values are now arrays
174   of rendered files. Plugins that cause a page to render additional files
175   should use the new will_render function to register the files.
176
177  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
178
179 ikiwiki (1.22) unstable; urgency=low
180   
181   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
182   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
183   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
184   to force a rebuild.
185
186   If you have modified versions of ikiwiki's html templates, you will need
187   to update your templates to link to the stylesheet file using
188   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
189   STYLEURL.
190
191   There have also been some changes to the plugin interface:
192   Any plugins that use santize, htmlize, or format hooks will need to be
193   updated for this version of ikiwiki since these hooks have been changed
194   to use named parameters.
195
196  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
197
198 ikiwiki (1.13) unstable; urgency=low
199
200   The GlobList format which was used for specifiying sets of pages, has been
201   replaced with a new, more expressive PageSpec format. While GlobLists will
202   continue to work, that format is deprecated, and you are encouraged to use
203   PageSpecs from now on, and also to change any GlobLists in your wiki to
204   PageSpecs. See the new PageSpec page for details.
205   
206   You will need to rebuild your wiki when upgrading to this version. If you
207   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
208   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
209   rebuild.
210
211  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
212
213 ikiwiki (1.11) unstable; urgency=low
214
215   Some changes to tags in this release, due to a new tag plugin. If you have
216   been using the meta plugin to tag pages, you'll want to enable the tag
217   plugin too, and change things like this:
218
219   [[meta link="foobar"]]
220
221   To this:
222
223   [[tag foobar]]
224
225   The new tags will appear at page footers, and are also easier to type.
226
227   There have also been some changes to the plugin interface, particularly the
228   interface of pagetemplate hooks has changed. See the changelog for details.
229
230  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
231
232 ikiwiki (1.8) unstable; urgency=low
233
234   If your wiki is configured with a setup file, you should modify it to
235   stop setting the "plugin" list directly, and instead add or remove plugins
236   via the add_plugins and disable_plugins lines. For example, if you had:
237
238         plugin => [qw{inline smiley search}],
239
240   Change it to these lines, which disables the default htmlscrubber plugin
241   and adds the two additional plugins:
242
243         add_plugins => [qw{smiley search}],
244         disable_plugins => [qw{htmlscrubber}],
245
246   Making this change makes your ikiwiki setup file more future-proof since
247   new default plugins will be automatically used.
248   
249   You will need to rebuild your ikiwiki wrappers when upgrading to this
250   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
251   done automatically when the Debian package is upgraded. Or use
252   ikiiki-mass-rebuild --refresh to force a refresh.
253
254  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
255
256 ikiwiki (1.1) unstable; urgency=low
257
258   There have been several configuration changes in this release of ikiwiki:
259
260   The --svn and --no-svn switches are removed, instead you should use
261    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
262   be changed to set rcs => "svn"; if your setup file sets svn => 0
263   then change it to use rcs => "" to disable svn.
264
265   The --hyperestraier switch is gone too. To enable searching, turn on the
266   search plugin, by passing --plugin=search or through the plugin setting in
267   the setup file.
268
269   The --sanitize and --no-sanitize switches are also gone, replaced with the
270   htmlscrubber plugin. This plugin is enabled by default, to disable it,
271   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
272   setup file.
273
274   Discussion pages are enabled by default, but if your wiki is configured
275   with a setup file, you need to edit it to keep them enabled on upgrade
276   to this version. Add a line reading:
277   discussion => 1,
278
279   You will need to rebuild your wiki when upgrading to this version.
280   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
281   automatically when the Debian package is upgraded. Or use
282   ikiiki-mass-rebuild to force a rebuild.
283
284  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400