add description_html
[ikiwiki.git] / debian / NEWS
1 ikiwiki (2.60) unstable; urgency=low
2
3   Admin preferences are moving from the web interface to the setup file.
4   There are three new options in the setup file: locked_pages, banned_users,
5   and allowed_attachments. The admin prefs page can still be used, but
6   that's deprecated, and the prefs will be hidden if a value is not already
7   set. If a value is set in the web interface, you're encouraged to move that
8   setting to your setup file now, since version 3.0 will remove the deprecated
9   web interface.
10
11  -- Joey Hess <joeyh@debian.org>  Fri, 01 Aug 2008 17:02:14 -0400
12
13 ikiwiki (2.52) unstable; urgency=low
14
15   All wikis need to be rebuilt on upgrade to this version. If you listed your
16   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
17   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
18
19  -- Joey Hess <joeyh@debian.org>  Sun, 06 Jul 2008 15:10:05 -0400
20
21 ikiwiki (2.49) unstable; urgency=low
22
23   The search plugin no longer uses hyperestraier. Instead, to use it you
24   will now need to install xapian-omega, and the Search::Xapian,
25   HTML::Scrubber, and Digest::SHA1 perl modules. Ie,
26   `apt-get install xapian-omega libsearch-xapian-perl libhtml-scrubber-perl libdigest-sha1-perl`
27
28   Also, wikis that use the search plugin will need to be rebuilt,
29   since the search form has changed. This will not be done automatically,
30   but can be done by running `ikiwiki-mass-upgrade` as root, or
31   running `ikiwiki -setup` on individual setup files.
32
33  -- Joey Hess <joeyh@debian.org>  Wed, 04 Jun 2008 00:29:28 -0400
34
35 ikiwiki (2.48) unstable; urgency=high
36
37   If you allowed password based logins to your wiki, those passwords were
38   stored in cleartext in the userdb. To guard against exposing users'
39   passwords, I recommend you install the Authen::Passphrase perl module, and
40   then run `ikiwiki-transition hashpassword /path/to/srcdir` to replace all
41   existing cleartext passwords with strong (blowfish) hashes.
42
43  -- Joey Hess <joeyh@debian.org>  Thu, 29 May 2008 14:39:34 -0400
44
45 ikiwiki (2.46) unstable; urgency=low
46  
47   There were some significant template changes in ikiwiki 2.42 (and 1.33.5).
48   If you have locally modified versions of the templates, they need to be
49   updated. Most notably, the editpage.tmpl has a new FIELD-SID added to it,
50   without which web editing will fail.
51  
52  -- Joey Hess <joeyh@debian.org>  Tue, 06 May 2008 14:30:14 -0400
53
54 ikiwiki (2.40) unstable; urgency=low
55
56   ikiwiki now has an new syntax for preprocessor directives, using the
57   prefix '!':
58
59   [[!directive ...]]
60
61   This new syntax no longer relies on spaces to distinguish between
62   wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
63   in their link text, and preprocessor directives without arguments (such
64   as "toc") need not use a trailing space.
65
66   To enable the new syntax, set prefix_directives to true in your ikiwiki
67   config.  For backward compatibility with existing wikis,
68   prefix_directives currently defaults to false.  In ikiwiki 3.0,
69   prefix_directives will default to true, and wikis which have not yet
70   converted to the new syntax will need to set prefix_directives to false
71   in their setup files.
72
73   To convert your wiki to the new syntax, ikiwiki provides a new script
74   ikiwiki-transition.  It will convert preprocessor directives in
75   all files given on the command line.  To convert an entire wiki:
76
77   find wikidir/ -type f -name '*.mdwn' -print0 | xargs -0 ikiwiki-transition prefix_directives
78
79   Even with prefix_directives disabled, ikiwiki now allows an optional '!'
80   prefix on preprocessor directives (but still requires a space).  Thus, a
81   directive which uses a '!' prefix and contains a space will work with
82   ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
83   This allows the underlay to work with all ikiwikis.
84
85  -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
86
87 ikiwiki (2.30) unstable; urgency=low
88
89   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
90   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
91   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
92   Custom RecentChanges pages can be easily set up that display only changes
93   to a subset of pages, or only changes by a subset of users.
94   
95   All wikis need to be rebuilt on upgrade to this version. If you listed your
96   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
97   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
98
99   With this excellent new RecentChanges support, the mail notification system
100   is its age (and known to be variously buggy and underimplemented for
101   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
102   from this version. If you were subscribed to commit mails, you should be
103   able to accomplish the same thing by subscribing to a RecentChanges feed.
104
105   The "notify" field in setup files is no longer used, and
106   silently ignored. You may want to remove it from your setup file.
107
108  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
109
110 ikiwiki (2.20) unstable; urgency=low
111
112   The template plugin has begin to htmlize the variables passed to templates.
113   This is normally what you want, but to get the old behavior and get at the
114   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
115  
116  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
117
118 ikiwiki (2.16) unstable; urgency=low
119
120   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
121   release, to avoid the basewiki including pages with names like "blog".
122   Redirection pages have been left behind for these moved pages temporarily,
123   and will be removed later.
124
125   If you use the calendar plugin, ikiwiki is now smarter and your nightly
126   cron job to update the wiki doesn't need to rebuild everything. Just pass
127   --refresh to ikiwiki in the cron job and it will update only pages that
128   contain out of date calendars.
129
130  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
131
132 ikiwiki (2.14) unstable; urgency=low
133
134   This version of ikiwiki is more picky about symlinks in the path leading
135   to the srcdir, and will refuse to use a srcdir specified by such a path.
136   This was necessary to avoid some potential exploits, but could potentially
137   break (semi-)working wikis. If your wiki has a srcdir path containing a
138   symlink, you should change it to use a path that does not.
139
140  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
141
142 ikiwiki (2.9) unstable; urgency=low
143
144   Since ikiwiki 2.0 was released, some limitiations have been added to what
145   ikiwiki considers a WikiLink. In short, if there are any spaces in between
146   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
147   contains things meant to be WikiLinks that contain spaces, you will need to
148   fix them, by replacing the spaces with underscores.
149   
150   WikiLink have always been documented to not contain spaces, but bugs in
151   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
152   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
153   release. These fixes are necessary to avoid ambiguity between
154   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
155   these bugs (and their fixes) may have caused.
156
157  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
158
159 ikiwiki (2.6) unstable; urgency=low
160
161   In this version the rst plugin allows raw html to be embedded in rst files.
162   As long as the htmlscrubber is enabled, this should be safe. If you are
163   using the rst plugin without the htmlscrubber in a publically writable wiki,
164   you should turn on the htmlscrubber.
165
166  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
167
168 ikiwiki (2.5) unstable; urgency=low
169
170   Due to some config changes in this version, wrappers need to be rebuilt on
171   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
172   one automatically when the Debian package is upgraded.
173
174  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
175
176 ikiwiki (2.1) unstable; urgency=low
177
178   Some wikis need to be rebuilt on upgrade to this version, due to changes to
179   page templates and the style sheet. If you listed your wiki in
180   /etc/ikiwiki/wikilist this will be done automatically when the Debian
181   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
182
183  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
184
185 ikiwiki (2.00) unstable; urgency=low
186
187   With the 2.0 release of ikiwiki, some major changes have been made to the
188   default configuration:
189
190   * The 'usedirs' setting is enabled by default. This *will* break all URLs
191     to wikis that did not have 'usedirs' turned on before, unless you follow
192     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
193     or edit your setup file to turn usedirs off:
194        usedirs => 0,
195
196   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
197     perl module is available. Password logins are also still enabled
198     by default. If you like, you can turn either OpenID or password logins
199     off via the 'disable_plugins' setting.
200
201  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
202
203 ikiwiki (1.51) unstable; urgency=low
204
205   Some wikis need to be rebuilt on upgrade to this version, due to changes to
206   page layout and the style sheet. If you listed your wiki in
207   /etc/ikiwiki/wikilist this will be done automatically when the Debian
208   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
209
210  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
211
212 ikiwiki (1.50) unstable; urgency=low
213
214   Permalinks and guids in rss and atom feeds for wikis using the usedirs
215   options will change in this release. If you have already enabled usedirs,
216   you may need to take steps to avoid flooding aggregators.
217
218  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
219
220 ikiwiki (1.49) unstable; urgency=low
221
222   Third-party plugins that use htmlpage() or abs2rel() to generate links
223   may need changes to support the new "usedirs" option.
224
225  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
226
227 ikiwiki (1.47) unstable; urgency=low
228  
229   Due to a security fix, wikis that have the htmlscrubber enabled can no
230   longer use the meta plugin to insert html link and meta tags.
231
232   Some special case methods have been added for safely including stylesheets,
233   and for doing openid delegation. See the meta plugin docs for details.
234  
235  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
236
237 ikiwiki (1.45) unstable; urgency=low
238
239   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
240   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
241   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
242
243  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
244
245 ikiwiki (1.44) unstable; urgency=low
246
247   The htmllink() function has changed slightly and plugins that use it may
248   need to change how they call it. This function's first three parameters
249   are unchanged, but additional options are now passed using named
250   parameters. If you used htmllink with more than 3 parameters, you will
251   need to change it. The plugin interface version has been increased to 1.02
252   to reflect this change.
253
254  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
255
256 ikiwiki (1.42) unstable; urgency=low
257
258   The anonok setting in config files has been removed. To enable
259   httpauth support on your wiki, you should now enable the anonok plugin,
260   instead.
261
262   Third-party plugins that use pagespec_match() should be updated to pass
263   the new third parameter (from) to that function. This is needed for the
264   new relative glob matching to work.
265
266  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
267
268 ikiwiki (1.34) unstable; urgency=low
269
270   The httpauth setting in config files has been removed. To enable
271   httpauth support on your wiki, you should now enable the httpauth plugin,
272   instead.
273
274   This release includes OpenID support that is enabled through the openid
275   plugin. I recommend turning this on to make it easier for users to sign
276   in to your wiki.
277
278  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
279
280 ikiwiki (1.32) unstable; urgency=low
281
282   There is a change to the plugin interface in this version. Any plugins that
283   modify data in %links should pass scan => 1 when registering the hook that
284   does so.
285
286  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
287
288 ikiwiki (1.29) unstable; urgency=low
289
290   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
291   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
292   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
293
294   There is a change to the plugin interface in this version. Plugins that use
295   %renderedfiles will need to be updated, as the hash's values are now arrays
296   of rendered files. Plugins that cause a page to render additional files
297   should use the new will_render function to register the files.
298
299  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
300
301 ikiwiki (1.22) unstable; urgency=low
302   
303   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
304   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
305   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
306   to force a rebuild.
307
308   If you have modified versions of ikiwiki's html templates, you will need
309   to update your templates to link to the stylesheet file using
310   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
311   STYLEURL.
312
313   There have also been some changes to the plugin interface:
314   Any plugins that use santize, htmlize, or format hooks will need to be
315   updated for this version of ikiwiki since these hooks have been changed
316   to use named parameters.
317
318  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
319
320 ikiwiki (1.13) unstable; urgency=low
321
322   The GlobList format which was used for specifiying sets of pages, has been
323   replaced with a new, more expressive PageSpec format. While GlobLists will
324   continue to work, that format is deprecated, and you are encouraged to use
325   PageSpecs from now on, and also to change any GlobLists in your wiki to
326   PageSpecs. See the new PageSpec page for details.
327   
328   You will need to rebuild your wiki when upgrading to this version. If you
329   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
330   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
331   rebuild.
332
333  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
334
335 ikiwiki (1.11) unstable; urgency=low
336
337   Some changes to tags in this release, due to a new tag plugin. If you have
338   been using the meta plugin to tag pages, you'll want to enable the tag
339   plugin too, and change things like this:
340
341   [[meta link="foobar"]]
342
343   To this:
344
345   [[tag foobar]]
346
347   The new tags will appear at page footers, and are also easier to type.
348
349   There have also been some changes to the plugin interface, particularly the
350   interface of pagetemplate hooks has changed. See the changelog for details.
351
352  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
353
354 ikiwiki (1.8) unstable; urgency=low
355
356   If your wiki is configured with a setup file, you should modify it to
357   stop setting the "plugin" list directly, and instead add or remove plugins
358   via the add_plugins and disable_plugins lines. For example, if you had:
359
360         plugin => [qw{inline smiley search}],
361
362   Change it to these lines, which disables the default htmlscrubber plugin
363   and adds the two additional plugins:
364
365         add_plugins => [qw{smiley search}],
366         disable_plugins => [qw{htmlscrubber}],
367
368   Making this change makes your ikiwiki setup file more future-proof since
369   new default plugins will be automatically used.
370   
371   You will need to rebuild your ikiwiki wrappers when upgrading to this
372   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
373   done automatically when the Debian package is upgraded. Or use
374   ikiiki-mass-rebuild --refresh to force a refresh.
375
376  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
377
378 ikiwiki (1.1) unstable; urgency=low
379
380   There have been several configuration changes in this release of ikiwiki:
381
382   The --svn and --no-svn switches are removed, instead you should use
383    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
384   be changed to set rcs => "svn"; if your setup file sets svn => 0
385   then change it to use rcs => "" to disable svn.
386
387   The --hyperestraier switch is gone too. To enable searching, turn on the
388   search plugin, by passing --plugin=search or through the plugin setting in
389   the setup file.
390
391   The --sanitize and --no-sanitize switches are also gone, replaced with the
392   htmlscrubber plugin. This plugin is enabled by default, to disable it,
393   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
394   setup file.
395
396   Discussion pages are enabled by default, but if your wiki is configured
397   with a setup file, you need to edit it to keep them enabled on upgrade
398   to this version. Add a line reading:
399   discussion => 1,
400
401   You will need to rebuild your wiki when upgrading to this version.
402   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
403   automatically when the Debian package is upgraded. Or use
404   ikiiki-mass-rebuild to force a rebuild.
405
406  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400