]> sipb.mit.edu Git - ikiwiki.git/blob - debian/NEWS
doc updates, add NEWS item
[ikiwiki.git] / debian / NEWS
1 ikiwiki (2.30) unstable; urgency=low
2
3   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
4   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
5   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
6   Custom RecentChanges pages can be easily set up that display only changes
7   to a subset of pages, or only changes by a subset of users.
8
9   With this excellent new RecentChanges support, the mail notification system
10   is showing its age (and known to be variously buggy and underimplemented for
11   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
12   from this version. If you were subscribed to commit mails, you should be
13   able to accomplish the same thing by subscribing to a RecentChanges feed.
14
15  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
16
17 ikiwiki (2.20) unstable; urgency=low
18
19   The template plugin has begin to htmlize the variables passed to templates.
20   This is normally what you want, but to get the old behavior and get at the
21   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
22  
23  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
24
25 ikiwiki (2.16) unstable; urgency=low
26
27   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
28   release, to avoid the basewiki including pages with names like "blog".
29   Redirection pages have been left behind for these moved pages temporarily,
30   and will be removed later.
31
32   If you use the calendar plugin, ikiwiki is now smarter and your nightly
33   cron job to update the wiki doesn't need to rebuild everything. Just pass
34   --refresh to ikiwiki in the cron job and it will update only pages that
35   contain out of date calendars.
36
37  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
38
39 ikiwiki (2.14) unstable; urgency=low
40
41   This version of ikiwiki is more picky about symlinks in the path leading
42   to the srcdir, and will refuse to use a srcdir specified by such a path.
43   This  was necessary to avoid some potential exploits, but could potentially
44   break (semi-)working wikis. If your wiki has a srcdir path containing a
45   symlink, you should change it to use a path that does not.
46
47  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
48
49 ikiwiki (2.9) unstable; urgency=low
50
51   Since ikiwiki 2.0 was released, some limitiations have been added to what
52   ikiwiki considers a WikiLink. In short, if there are any spaces in between
53   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
54   contains things meant to be WikiLinks that contain spaces, you will need to
55   fix them, by replacing the spaces with underscores.
56   
57   WikiLink have always been documented to not contain spaces, but bugs in
58   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
59   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
60   release. These fixes are necessary to avoid ambiguity between
61   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
62   these bugs (and their fixes) may have caused.
63
64  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
65
66 ikiwiki (2.6) unstable; urgency=low
67
68   In this version the rst plugin allows raw html to be embedded in rst files.
69   As long as the htmlscrubber is enabled, this should be safe. If you are
70   using the rst plugin without the htmlscrubber in a publically writable wiki,
71   you should turn on the htmlscrubber.
72
73  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
74
75 ikiwiki (2.5) unstable; urgency=low
76
77   Due to some config changes in this version, wrappers need to be rebuilt on
78   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
79   one automatically when the Debian package is upgraded.
80
81  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
82
83 ikiwiki (2.1) unstable; urgency=low
84
85   Some wikis need to be rebuilt on upgrade to this version, due to changes to
86   page templates and the style sheet. If you listed your wiki in
87   /etc/ikiwiki/wikilist this will be done automatically when the Debian
88   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
89
90  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
91
92 ikiwiki (2.00) unstable; urgency=low
93
94   With the 2.0 release of ikiwiki, some major changes have been made to the
95   default configuration:
96
97   * The 'usedirs' setting is enabled by default. This *will* break all URLs
98     to wikis that did not have 'usedirs' turned on before, unless you follow
99     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
100     or edit your setup file to turn usedirs off:
101        usedirs => 0,
102
103   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
104     perl module is available. Password logins are also still enabled
105     by default. If you like, you can turn either OpenID or password logins
106     off via the 'disable_plugins' setting.
107
108  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
109
110 ikiwiki (1.51) unstable; urgency=low
111
112   Some wikis need to be rebuilt on upgrade to this version, due to changes to
113   page layout and the style sheet. If you listed your wiki in
114   /etc/ikiwiki/wikilist this will be done automatically when the Debian
115   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
116
117  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
118
119 ikiwiki (1.50) unstable; urgency=low
120
121   Permalinks and guids in rss and atom feeds for wikis using the usedirs
122   options will change in this release. If you have already enabled usedirs,
123   you may need to take steps to avoid flooding aggregators.
124
125  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
126
127 ikiwiki (1.49) unstable; urgency=low
128
129   Third-party plugins that use htmlpage() or abs2rel() to generate links
130   may need changes to support the new "usedirs" option.
131
132  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
133
134 ikiwiki (1.47) unstable; urgency=low
135  
136   Due to a security fix, wikis that have the htmlscrubber enabled can no
137   longer use the meta plugin to insert html link and meta tags.
138
139   Some special case methods have been added for safely including stylesheets,
140   and for doing openid delegation. See the meta plugin docs for details.
141  
142  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
143
144 ikiwiki (1.45) unstable; urgency=low
145
146   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
147   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
148   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
149
150  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
151
152 ikiwiki (1.44) unstable; urgency=low
153
154   The htmllink() function has changed slightly and plugins that use it may
155   need to change how they call it. This function's first three parameters
156   are unchanged, but additional options are now passed using named
157   parameters. If you used htmllink with more than 3 parameters, you will
158   need to change it. The plugin interface version has been increased to 1.02
159   to reflect this change.
160
161  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
162
163 ikiwiki (1.42) unstable; urgency=low
164
165   The anonok setting in config files has been removed. To enable
166   httpauth support on your wiki, you should now enable the anonok plugin,
167   instead.
168
169   Third-party plugins that use pagespec_match() should be updated to pass
170   the new third parameter (from) to that function. This is needed for the
171   new relative glob matching to work.
172
173  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
174
175 ikiwiki (1.34) unstable; urgency=low
176
177   The httpauth setting in config files has been removed. To enable
178   httpauth support on your wiki, you should now enable the httpauth plugin,
179   instead.
180
181   This release includes OpenID support that is enabled through the openid
182   plugin. I recommend turning this on to make it easier for users to sign
183   in to your wiki.
184
185  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
186
187 ikiwiki (1.32) unstable; urgency=low
188
189   There is a change to the plugin interface in this version. Any plugins that
190   modify data in %links should pass scan => 1 when registering the hook that
191   does so.
192
193  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
194
195 ikiwiki (1.29) unstable; urgency=low
196
197   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
198   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
199   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
200
201   There is a change to the plugin interface in this version. Plugins that use
202   %renderedfiles will need to be updated, as the hash's values are now arrays
203   of rendered files. Plugins that cause a page to render additional files
204   should use the new will_render function to register the files.
205
206  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
207
208 ikiwiki (1.22) unstable; urgency=low
209   
210   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
211   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
212   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
213   to force a rebuild.
214
215   If you have modified versions of ikiwiki's html templates, you will need
216   to update your templates to link to the stylesheet file using
217   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
218   STYLEURL.
219
220   There have also been some changes to the plugin interface:
221   Any plugins that use santize, htmlize, or format hooks will need to be
222   updated for this version of ikiwiki since these hooks have been changed
223   to use named parameters.
224
225  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
226
227 ikiwiki (1.13) unstable; urgency=low
228
229   The GlobList format which was used for specifiying sets of pages, has been
230   replaced with a new, more expressive PageSpec format. While GlobLists will
231   continue to work, that format is deprecated, and you are encouraged to use
232   PageSpecs from now on, and also to change any GlobLists in your wiki to
233   PageSpecs. See the new PageSpec page for details.
234   
235   You will need to rebuild your wiki when upgrading to this version. If you
236   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
237   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
238   rebuild.
239
240  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
241
242 ikiwiki (1.11) unstable; urgency=low
243
244   Some changes to tags in this release, due to a new tag plugin. If you have
245   been using the meta plugin to tag pages, you'll want to enable the tag
246   plugin too, and change things like this:
247
248   [[meta link="foobar"]]
249
250   To this:
251
252   [[tag foobar]]
253
254   The new tags will appear at page footers, and are also easier to type.
255
256   There have also been some changes to the plugin interface, particularly the
257   interface of pagetemplate hooks has changed. See the changelog for details.
258
259  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
260
261 ikiwiki (1.8) unstable; urgency=low
262
263   If your wiki is configured with a setup file, you should modify it to
264   stop setting the "plugin" list directly, and instead add or remove plugins
265   via the add_plugins and disable_plugins lines. For example, if you had:
266
267         plugin => [qw{inline smiley search}],
268
269   Change it to these lines, which disables the default htmlscrubber plugin
270   and adds the two additional plugins:
271
272         add_plugins => [qw{smiley search}],
273         disable_plugins => [qw{htmlscrubber}],
274
275   Making this change makes your ikiwiki setup file more future-proof since
276   new default plugins will be automatically used.
277   
278   You will need to rebuild your ikiwiki wrappers when upgrading to this
279   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
280   done automatically when the Debian package is upgraded. Or use
281   ikiiki-mass-rebuild --refresh to force a refresh.
282
283  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
284
285 ikiwiki (1.1) unstable; urgency=low
286
287   There have been several configuration changes in this release of ikiwiki:
288
289   The --svn and --no-svn switches are removed, instead you should use
290    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
291   be changed to set rcs => "svn"; if your setup file sets svn => 0
292   then change it to use rcs => "" to disable svn.
293
294   The --hyperestraier switch is gone too. To enable searching, turn on the
295   search plugin, by passing --plugin=search or through the plugin setting in
296   the setup file.
297
298   The --sanitize and --no-sanitize switches are also gone, replaced with the
299   htmlscrubber plugin. This plugin is enabled by default, to disable it,
300   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
301   setup file.
302
303   Discussion pages are enabled by default, but if your wiki is configured
304   with a setup file, you need to edit it to keep them enabled on upgrade
305   to this version. Add a line reading:
306   discussion => 1,
307
308   You will need to rebuild your wiki when upgrading to this version.
309   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
310   automatically when the Debian package is upgraded. Or use
311   ikiiki-mass-rebuild to force a rebuild.
312
313  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400