1ec3e32bceb5f2cd064ff25e5d4553878b221759
[ikiwiki.git] / doc / bugs / Problems_with_graphviz.pm_plug-in.mdwn
1 The graphviz.pm plug-in currently attempts to read PNG data in UTF-8 mode, which sometimes fail with a message similar to the following (depending on the input):
2
3     utf8 "\x89" does not map to Unicode at /usr/local/lib/perl5/site_perl/5.8.8/IkiWiki/Plugin/graphviz.pm line 53, <IN> chunk 1.
4     Wide character in subroutine entry at /usr/local/lib/perl5/site_perl/5.8.8/IkiWiki/Plugin/graphviz.pm line 68.
5
6 > Ok, will remove the binmode IN then. done --[[Joey]]
7
8 >> Thanks --[[HenrikBrixAndersen]]
9
10 It also generates image URLs relative to the page being rendered, which means the URLs wont work when previewing a graph from the CGI script.
11
12 > You seem to be using an old version of ikiwiki, these preview isues have
13 > been fixed for some time, and the code doesn't look like what you patch
14 > in your second hunk. --[[Joey]]
15
16 >> I have just tested ikiwiki-2.5. The code in question still looks
17 >> the same, and the patch is still needed for making the graphviz
18 >> plug-in work in preview mode here.
19
20 >>> No, the relevant code is just above the bit you patched. Notice that in
21 >>> preview mode, it returns an img tag with the graphviz drawing embedded
22 >>> in it, using base64 encoding. Unless you can show me why that doesn't
23 >>> work, I still think this bug is done. --[[Joey]]
24
25 >> Here is an updated patch againt ikiwiki-2.5:
26
27
28     --- IkiWiki/Plugin/graphviz.pm.orig 2007-07-27 11:35:05.000000000 +0200
29     +++ IkiWiki/Plugin/graphviz.pm      2007-07-27 11:36:02.000000000 +0200
30     @@ -69,7 +69,12 @@ sub render_graph (\%) { #{{{
31                 }
32         }
33      
34     -   return "<img src=\"".urlto($dest, $params{page})."\" />\n";
35     +   if ($params{preview}) {
36     +           return "<img src=\"".urlto($dest, "")."\" />\n";
37     +   }
38     +   else {
39     +           return "<img src=\"".urlto($dest, $params{page})."\" />\n";
40     +   }
41      } #}}}
42      
43      sub graph (@) { #{{{
44
45
46 >> --[[HenrikBrixAndersen]]
47
48
49 The patch below fixes these two issues.
50
51     --- graphviz.pm.orig        Thu Jun  7 15:45:16 2007
52     +++ graphviz.pm     Fri Jun  8 12:03:38 2007
53     @@ -41,7 +41,6 @@ sub render_graph (\%) { #{{{
54                 $pid=open2(*IN, *OUT, "$params{prog} -Tpng");
55      
56                 # open2 doesn't respect "use open ':utf8'"
57     -           binmode (IN, ':utf8');
58                 binmode (OUT, ':utf8');
59      
60                 print OUT $src;
61     @@ -70,7 +69,12 @@ sub render_graph (\%) { #{{{
62                 }
63         }
64      
65     -   return "<img src=\"".urlto($dest, $params{page})."\" />\n";
66     +   if ($params{preview}) {
67     +           return "<img src=\"".urlto($dest, "")."\" />\n";
68     +   }
69     +   else {
70     +           return "<img src=\"".urlto($dest, $params{page})."\" />\n";
71     +   }
72      } #}}}
73      
74      sub graph (@) { #{{{