ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / bugs / Can__39__t_build_2.49__63__.mdwn
1 <strong>Solved - see Buo's suggestion below</strong>
2
3 I'm using ikiwiki on a shell account/hosting site where I can build but have no root privileges. I went to build 2.49 last night, but make fails with the following error:
4
5 <pre><code>/home/telemachus/bin/perl -Iblib/lib   ikiwiki.out -libdir . -setup docwiki.setup -refresh
6 docwiki.setup: Failed to load plugin IkiWiki::Plugin::inline: Too many arguments for IkiWiki::htmlize at IkiWiki/Plugin/inline.pm line 359, near "))"
7 Compilation failed in require at (eval 14) line 2.
8 BEGIN failed--compilation aborted at (eval 14) line 2.
9
10 BEGIN failed--compilation aborted at (eval 10) line 21.
11
12 make: *** [extra_build] Error 255</code></pre>
13
14 I looked at that patch of inline.pm, but nothing obvious jumped out at me, and I'm reluctant to tinker with it on my own. Other details that may be useful:
15
16 * perl is 5.10.0 (built myself on the account, rather than the system perl)
17 * The host system is Debian Etch
18 * Kernel is a custom 2.6.16-xen kernel
19 * Gcc 4.1.2
20
21 Any thoughts or suggestions are appreciated. Thanks.
22
23 > See this report: [[2.45_Compilation_error]]
24
25 > I don't know if this is the same problem you're seeing, but it looks similar.
26 > The issue is unresolved AFAICT, but I haven't had a chance to try 2.49 yet.
27
28 > The only workaround I've found is to completely remove any previous ikiwiki
29 > installation that might be present on the system. --Buo
30
31 Thanks, Buo. I removed the traces of the previous ikiwiki, and I was able to install. No luck getting the new search plugin to work, but we'll leave that for another day. Thanks again.
32
33 Quick follow-up: 2.50 compiled and installed without a hitch. Just thought I would mention it...
34
35 > [[closing|done]] as a duplicate of [[2.45_Compilation_error]]