ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / bugs / Missing_constant_domain_at_IkiWiki.pm_line_842.mdwn
1 I can't build my ikiwiki 1.40 backport for Debian 'sarge':
2
3     $ LANG=C dpkg-buildpackage -us -uc -rfakeroot
4     [...]
5     ./pm_filter /usr 1.40 /usr/share/perl5 <IkiWiki/Plugin/favicon.pm >blib/lib/IkiWiki/Plugin/favicon.pm
6     ./pm_filter /usr 1.40 /usr/share/perl5 <IkiWiki/Plugin/shortcut.pm >blib/lib/IkiWiki/Plugin/shortcut.pm
7     ./pm_filter /usr 1.40 /usr/share/perl5 <IkiWiki/Plugin/aggregate.pm >blib/lib/IkiWiki/Plugin/aggregate.pm
8     ./ikiwiki.in doc html --templatedir=templates --underlaydir=basewiki \
9     --wikiname="ikiwiki" --verbose --no-rcs \
10             --exclude=/discussion --no-discussion --userdir=users \
11             --plugin=goodstuff \
12             --plugin=haiku --plugin=polygen --plugin=fortune
13     Missing constant domain at IkiWiki.pm line 842
14     make[1]: *** [extra_build] Error 22
15     make[1]: Leaving directory `/home/ptecza/svn/ikiwiki'
16     make: *** [build-stamp] Error 2
17
18 --[[Paweł|ptecza]]
19
20 This is because of an old version of Locale::gettext which doesn't
21 include the OO interface. I had this problem too, but installing a
22 new version of Locale::gettext fixed it. --Ethan
23
24 > I suppose I should document it needing a new enough version. Or find a
25 > way to use the non-OO version while still getting proper UTF-8 strings,
26 > which is why I began to use the OO version in the first place..
27
28 > Looks like the OO interface was added in version 1.04
29
30 > And there's no good way to get utf-8 strings w/o the OO interface, that I
31 > can see.
32
33 > So, what I've done is documented that it needs Locale::gettext 1.04, and
34 > made it not crash if run with an older version, though it also won't
35 > gettext anything in that case. Might be a bit confusing if someone misses
36 > the docs about it needing the newer version and wonders why gettext
37 > doesn't work, but I consider it good enough to mark this [[bugs/done]]. 
38 > --[[Joey]]
39
40 >> Thanks for the hint, guys! :) I've just backported liblocale-gettext-perl
41 >> 1.05 package and it seems that now I can build my ikiwiki successfully
42 >> and it even works :) --[[Paweł|ptecza]]
43
44 Thanks for the note on this, made it very easy to figure out what was going on.  Just pointing out though that the Debian package doesn't require a new version of liblocale-gettext-perl.  I just got bit by this bug setting up a dev ikiwiki box on a mixed stable/testing box.  -- [[Adam]]
45
46 > The Debian package has this:
47 >
48 >     Suggests: [...], liblocale-gettext-perl (>= 1.05-1), [...]
49 >
50 > --[[JoshTriplett]]