ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / bugs / Not_all_comments_are_listed_by___33__map_or___33__inline.mdwn
1 While working on our forum I was surprised to see that some of the comments were not appearing in the RSS feed created by `!inline pages="forum/* or comment(forum/*)" feedonly="yes" show="25"`.
2
3 > I'm seeing some comments in the rss feed. The feed is limited to the 25
4 > most recent items, you can increase that with feedshow. --[[Joey]]
5
6 >> Of course, but in the feed, some of the new comments don't show up.
7 >> Most does but not all. For example, none of the comments of this thread
8 >> appears in the RSS, even though they should according to the « 25 most
9 >> recent items » criteria:
10 >> <https://tails.boum.org/forum/Security_Updates:_apt-get_Sufficient__63__/> --sajolida
11
12 >>> Of course this is a moving target, so I checked out 
13 >>> 4a787aecb142f346190ddaef59938799818c964b, which is from the same day
14 >>> the above was written.. The comments in question appeared in
15 >>> the rss feed when I ran `ikiwiki -setup ikiwiki.setup -gettime`
16 >>> (after configuring the setup file to use git and rss and setting
17 >>> `gitorigin_branch: ''`)
18 >>>
19 >>> So I suppose I'd need a testcase in a tarball to reproduce 
20 >>> any problem. --[[Joey]]
21
22 >>>> Once I set `rcs: git` and `gitorigin_branch: ''`, I also get a
23 >>>> perfect RSS feed that contains the items git log makes me expect,
24 >>>> in the correct order. So this is not a ikiwiki bug after all,
25 >>>> sorry for the annoyance. (For the record, I think we have two
26 >>>> problems: first, our ikiwiki.setup does not enable a RCS, mainly
27 >>>> to avoid local refresh to create ugly "updated PO files" Git
28 >>>> commits; this explains the issue sajolida noticed while locally
29 >>>> building the wiki. Second, the RSS feed on our online ikiwiki is
30 >>>> correct right now, was probably cured by a rebuild at some point.
31 >>>> --[[intrigeri]]
32
33 Then I found out that a map directive such as `!map pages="forum/* or
34 comment(forum/*)"` was bringing a weird result too. The output is a map
35 with quite a few broken links.
36
37 > This is the same as if you tried to link to a comment page or other 
38 > internal page with a [[ikiwiki/WikiLink]] -- you'd get a broken link
39 > or a create link because these are not true wiki pages. --[[Joey]]
40
41 >> So I don't understand why 90 % of the comments are linked well and 10 %
42 >> are broken links. Why does this map behave differently for only a few comments? --sajolida
43
44 >>> I checked the first 50% or so of the comments, and every one was a
45 >>> broken link. --[[Joey]]
46
47 >>>> I now observe the same behaviour as Joey, which seems totally
48 >>>> logical to me after all given that `forum/*/comment_*.html` are
49 >>>> not generated. I wonder how we could have observed map generating
50 >>>> working links to comments in the first place; sajolida, can you
51 >>>> please try reproducing it? If you cannot reproduce it, I think we
52 >>>> can close this bug. --[[intrigeri]]
53
54 >>>>> Closing as apparently operator error (and while it's a bit confiusing
55 >>>>> that map generates broken links for internal pages, it is *sorta* was
56 >>>>> was requested by the pagespec, so I don't see a real reason to change
57 >>>>> it). Please reopen if new data emerges. [[done]] --[[Joey]] 
58
59 Plus, some broken links in the map do match the comments missing on the RSS feed but some others do not.
60
61 Unfortunately, I couldn't find an obvious pattern for this failure.
62
63 We think it's a bug in ikiwiki. Our git repo is publicly available at
64 `git://git.immerda.ch/amnesia.git` (the ikiwiki source is in `/wiki/src`)
65 and the corresponding online version is available at
66 <https://tails.boum.org/forum/>. The buggy `!inline` is already included in
67 the original `forum.mdwn`. The buggy `!map` is not but the bug can be
68 reproduced by just including it in the source of the forum.