ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / bugs / Problems_with_graphviz.pm_plug-in.mdwn
1 The graphviz.pm plug-in currently attempts to read PNG data in UTF-8 mode, which sometimes fail with a message similar to the following (depending on the input):
2
3     utf8 "\x89" does not map to Unicode at /usr/local/lib/perl5/site_perl/5.8.8/IkiWiki/Plugin/graphviz.pm line 53, <IN> chunk 1.
4     Wide character in subroutine entry at /usr/local/lib/perl5/site_perl/5.8.8/IkiWiki/Plugin/graphviz.pm line 68.
5
6 > Ok, will remove the binmode IN then. done --[[Joey]]
7
8 >> Thanks --[[HenrikBrixAndersen]]
9
10 It also generates image URLs relative to the page being rendered, which means the URLs wont work when previewing a graph from the CGI script.
11
12 (preview bug split to [[Problems_with_graphviz.pm_plug-in_previews]])
13
14 >> Here is an updated patch againt ikiwiki-2.5:
15
16 >>> [[Applied|done]], thanks. --[[Joey]]
17
18 The patch below fixes these two issues.
19
20     --- graphviz.pm.orig        Thu Jun  7 15:45:16 2007
21     +++ graphviz.pm     Fri Jun  8 12:03:38 2007
22     @@ -41,7 +41,6 @@ sub render_graph (\%) {
23                 $pid=open2(*IN, *OUT, "$params{prog} -Tpng");
24      
25                 # open2 doesn't respect "use open ':utf8'"
26     -           binmode (IN, ':utf8');
27                 binmode (OUT, ':utf8');
28      
29                 print OUT $src;
30     @@ -70,7 +69,12 @@ sub render_graph (\%) {
31                 }
32         }
33      
34     -   return "<img src=\"".urlto($dest, $params{page})."\" />\n";
35     +   if ($params{preview}) {
36     +           return "<img src=\"".urlto($dest, "")."\" />\n";
37     +   }
38     +   else {
39     +           return "<img src=\"".urlto($dest, $params{page})."\" />\n";
40     +   }
41      }
42      
43      sub graph (@) {