ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / bugs / wikilink_in_table.mdwn
1 I try to create wikilink in table. But it does not work. Here is example:
2
3         \[[!table class=table1 data="""
4         \[[wikilink_test|index]]
5         \[[wikilink_test\|index]]
6         [wikilink test](/servers/webmail1)
7         """]]
8
9 First two wikilink entries do not work.
10
11 The last one is url link and it works but it is not a wikilink. Or maybe it does not matter if I use URL links in stead of wikilinks for local wiki content?
12
13 > [[fixed|done]] --[[Joey]]
14
15 >> works !! Great!
16
17 What exactly is a difference between wikilink and URL reference to the same page ?
18
19 > ikiwiki will not be able to track pages linked using urls as having a
20 > link.
21
22 Trying to report this I found something weird. I changed in the example [[ with || because wiki renders something wrongly. You can see what I tried originally here:
23
24         \[[!table class=table1 data="""
25         \[[wikilink_test|servers/webmail1]]
26         \[[wikilink_test|servers/webmail1]]
27         [wikilink test](/servers/webmail1)
28         """]]
29
30 Please  click edit to see unrendered text. First, it is not monospace-d (I have 4 spaces) and second, some wierd html is shown...
31 Am I doing something wrong ?
32
33 > See above for the right way to do it. Note that I also fixed a minor bug
34 > in ikiwiki to allow this. --[[Joey]]
35
36 >> Just curious ... if I wanted to have that block in monospace (four spaces in front of each line), how can I do that ?