ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / forum / 404_-_not_found / comment_2_948e4678be6f82d9b541132405351a2c._comment
1 [[!comment format=mdwn
2  username="https://www.google.com/accounts/o8/id?id=AItOawllEHb4oGNaUrl7vyziQGrxAlQFri_BfaE"
3  nickname="Geert"
4  subject="comment 2"
5  date="2010-09-12T06:45:27Z"
6  content="""
7 After a re-installation of ikiwiki (first removed all old files), I get the following feedback:
8
9     Successfully set up gwiki:
10             url:         http://ubuntu1004/~geertvc/gwiki
11             srcdir:      ~/gwiki
12             destdir:     ~/public_html/gwiki
13             repository:  ~/gwiki.git
14     To modify settings, edit ~/gwiki.setup and then run:
15             ikiwiki -setup ~/gwiki.setup
16
17
18 In the lighttpd config file (/etc/lighttpd/lighttpd.conf), I've now changed the item \"server.document-root\" from the default \"/var/www\" to (in my case) \"/home/geertvc/public_html/gwiki\".  I've taken the destdir location (see above) as document root for lighttpd.
19
20 When doing this, I can see the \"index.html\" page of ikiwiki (by typing the following URL in the address box of the browser: \"ubuntu1004/index.html\").  So, that seems to be the right modification, right?  Or isn't it?
21
22 Note: when I take the directory \"/home/geertvc/gwiki\" (= the URL given above), then things do not work.  I can't see the content of \"index.html\", I get the error message I mentioned in my initial post (404 - not found).
23
24 But when clicking, for instance, the \"Edit\" button, the link brings me to the following location:
25
26     http://ubuntu1004/~geertvc/gwiki/ikiwiki.cgi?page=index&do=edit
27
28 However, there's not at all a file called \"ikiwiki.cgi\" at that location.  The location of the file \"ikiwiki.cgi\" is \"/home/geertvc/public_html/gwiki\", so why is the link \"Edit\" leading me to that (wrong?) location?
29
30 Apparently, something is still wrong with my settings.  Hope, with the above information, someone can put me on the right track...
31 """]]