ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / forum / Xapian_search:_empty_postlist_table.mdwn
1 Hi,
2
3 I'm trying to set up a personal wiki and I'm having trouble getting
4 search to work.  All my searches give zero results.  I eventually
5 figured out that the Xapian database that's being created has an empty
6 postlist table.  The position and termlist tables are all fine, and
7 when I add new content to the wiki I can see the database is updated
8 and the search terms are in the position table in plaintext.  But I
9 can't query for them, even using Xapian's command line tools.
10
11 <pre>
12 mexon:~/Test/.ikiwiki/xapian/default$ ls -l
13 total 76
14 -rw-rw-r-- 1 mexon mexon     0 Dec 16 15:56 flintlock
15 -rw-rw-r-- 1 mexon mexon    28 Dec 16 15:55 iamchert
16 -rw-rw-r-- 1 mexon mexon    13 Dec 16 15:55 position.baseA
17 -rw-rw-r-- 1 mexon mexon 49152 Dec 16 15:55 position.DB
18 -rw-rw-r-- 1 mexon mexon    13 Dec 16 15:55 postlist.baseA
19 -rw-rw-r-- 1 mexon mexon     0 Dec 16 15:55 postlist.DB
20 -rw-rw-r-- 1 mexon mexon    13 Dec 16 15:55 record.baseA
21 -rw-rw-r-- 1 mexon mexon     0 Dec 16 15:55 record.DB
22 -rw-rw-r-- 1 mexon mexon    13 Dec 16 15:55 termlist.baseA
23 -rw-rw-r-- 1 mexon mexon 16384 Dec 16 15:55 termlist.DB
24 mexon:~/Test/.ikiwiki/xapian/default$ delve -a .
25 All terms in database:
26 mexon:~/Test/.ikiwiki/xapian/default$ 
27 </pre>
28
29 I don't know how to debug from here.  Clearly ikiwiki is doing
30 something right when it's building the database, but one of the tables
31 is missing.  Can anyone guess what's wrong, or tell me where to start
32 troubleshooting?
33
34 I'm using Centos 5.  Xapian is version 1.2.5.  Ikiwiki version 3.20111107.