ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / forum / Xapian_search:_empty_postlist_table / comment_3_0bd424a89c3a52ff393a1e7e00c806be._comment
1 [[!comment format=mdwn
2  username="https://me.yahoo.com/a/2d7oNP9wlop3PaHlGlGS1J2ppVqXf4zQAw--#17b9b"
3  nickname="Matthew"
4  subject="comment 3"
5  date="2011-12-19T06:18:56Z"
6  content="""
7 I had another go, this time with Xapian 1.2.8.0, and I finally got it working.  The errors I was seeing earlier were because Xapian installs itself in /usr/local, but the default CentOS environment doesn't have /usr/local/lib in the LD_LIBRARY_PATH.  As usual, the problem and solution are very duh, it's the error messages that make everything hard.  It's a lot more clear if you do a \"make test\" while building Search::Xapian:
8
9 <pre>
10 mexon:~/ikiwiki-temp/Search-Xapian-1.2.8.0$ make test
11 PERL_DL_NONLAZY=1 /usr/bin/perl \"-MExtUtils::Command::MM\" \"-e\" \"test_harness(0, 'blib/lib', 'blib/arch')\" t/*.t
12 t/01use...............
13 #   Failed test 'use Search::Xapian;'
14 #   in t/01use.t at line 3.
15 #     Tried to use 'Search::Xapian'.
16 #     Error:  Can't load '/home/mexon/ikiwiki-temp/Search-Xapian-1.2.8.0/blib/arch/auto/Search/Xapian/Xapian.so' for module Search::Xapian: libxapian.so.22: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.
17 #  at (eval 3) line 2
18 # Compilation failed in require at (eval 3) line 2.
19 # BEGIN failed--compilation aborted at t/01use.t line 3.
20 # Looks like you failed 1 test of 3.
21 </pre>
22
23 So yeah.  Worth noting that Xapian 1.2.5 is apparently broken with ikiwiki.  Maybe some kind of warning?
24 """]]