ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / forum / teximg_not_working.mdwn
1 I following installation and configuration instructions at [[plugins/teximg/]]
2
3 But I get
4
5     [[!teximg Error: missing tex code]]
6
7 for code
8
9     [[!teximg $$\sin (x)$$]]
10
11 On server I do have `texlive`, `dvips`, `convert` installed ready. My configuration looks like
12
13         # teximg_dvipng => 1,   # use dvipng                                                                                                                
14         teximg_dvipng => 0, # use dvips and convert                                                                                                         
15         # LaTeX prefix for teximg plugin                                                                                                                    
16         teximg_prefix => '\\documentclass{article}                                                                                                          
17         \\usepackage{amsmath}                                                                                                                               
18         \\usepackage{amsfonts}                                                                                                                              
19         \\usepackage{amssymb}                                                                                                                               
20         \\pagestyle{empty}                                                                                                                                  
21         \\begin{document}                                                                                                                                   
22         ',
23         # LaTeX postfix for teximg plugin                                                                                                                   
24         teximg_postfix => '\\end{document}',
25
26 Any ideas why it's not working?