ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / todo / Split_plugins_with_external_dependencies_into_separate_Debian_packages.mdwn
1 The Debian ikiwiki package has a pile of recommends and suggests for packages needed by various plugins and other optional functionality.  To make it easier for people to figure out what to install, and to make it easier for automatic dependency tracking to remove packages ikiwiki no longer needs, we could split the plugins with additional dependencies into their own packages.
2
3 Notable plugin dependencies:
4
5 - [[plugins/img]] depends on [[!debpkg perlmagick]]
6 - [[plugins/graphviz]] depends on [[!debpkg graphviz]]
7   - [[plugins/linkmap]] depends on the graphviz plugin, so it should probably go in the same package.
8 - [[plugins/polygen]] depends on [[!debpkg polygen]]
9 - [[plugins/teximg]] depends on [[!debpkg dvipng]] and [[!debpkg texlive]]
10 - [[plugins/htmltidy]] depends on [[!debpkg tidy]]
11 - [[plugins/table]] depends on [[!debpkg libtext-csv-perl]]
12 - [[plugins/textile]] depends on [[!debpkg libtext-textile-perl]]
13 - [[plugins/txt]] should probably just depend on [[!debpkg liburi-find-perl]]
14 - [[plugins/sparkline]] depends on [[!debpkg libsparkline-php]], which pulls in the whole PHP stack.
15   - [[plugins/postsparkline]] depends on the sparkline plugin, so it should probably go in the same package.
16 - [[plugins/search]] depends on [[!debpkg xapian-omega]] and [[!debpkg libsearch-xapian-perl]]
17 - [[plugins/po]] depends on [[!debpkg po4a]] (and possibly [[!debpkg gettext]] and [[!debpkg liblocale-gettext-perl]], or does something else use those?)
18 - [[plugins/amazon_s3]] depends on [[!debpkg libnet-amazon-s3-perl]] and [[!debpkg libfile-mimeinfo-perl]]
19 - [[plugins/highlight]] depends on [[!debpkg libhighlight-perl]]
20 - [[plugins/htmlbalance]] depends on [[!debpkg libhtml-tree-perl]]
21 - [[plugins/typography]] depends on [[!debpkg libtext-typography-perl]]
22 - [[plugins/creole]] depends on [[!debpkg libtext-wikicreole-perl]]
23 - [[plugins/wikitext]] depends on [[!debpkg libtext-wikiformat-perl]]
24 - [[plugins/rst]] depends on [[!debpkg librpc-xml-perl]] and [[!debpkg python-docutils]], and pulls in Python
25 - [[plugins/blogspam]] depends on [[!debpkg librpc-xml-perl]]
26 - [[plugins/prettydate]] depends on [[!debpkg libtimedate-perl]]
27 - [[plugins/hnb]] depends on [[!debpkg hnb]]
28 - [[plugins/fortune]] depends on [[!debpkg fortune]]
29 - [[plugins/filecheck]] depends on [[!debpkg libfile-mimeinfo-perl]] and file
30 - [[plugins/ddate]] depends on [[!debpkg libdatetime-calendar-discordian-perl]] and [[!debpkg libdatetime-perl]]
31 - [[plugins/otl]] depends on [[!debpkg vim-vimoutliner]]
32 - [[plugins/haiku]] depends on [[!debpkg libcoy-perl]]
33 - [[plugins/sortnaturally]] depends on [[!debpkg libsort-naturally-perl]]
34 - [[plugins/pinger]] depends on [[!debpkg liblwpx-paranoidagent-perl]] (it works with plain LWP, but less securely) and should probably just depend on [[!debpkg libcrypt-ssleay-perl]]
35 - [[plugins/openid]] depends on [[!debpkg libnet-openid-consumer-perl]], and should either recommend or just depend on [[!debpkg liblwpx-paranoidagent-perl]] and [[!debpkg libcrypt-ssleay-perl]]
36 - Support for tla depends on [[!debpkg libmailtools-perl]] (could make this a package depending on [[!debpkg tla]] and [[!debpkg libmailtools-perl]])
37
38 Also, ikiwiki should probably just depend on [[!debpkg libauthen-passphrase-perl]] and refuse to store insecure passwords.
39
40 [[!tag wishlist]]