]> sipb.mit.edu Git - ikiwiki.git/blob - ikiwiki.spec
(no commit message)
[ikiwiki.git] / ikiwiki.spec
1 Name:           ikiwiki
2 Version: 3.20100102.3
3 Release:        1%{?dist}
4 Summary:        A wiki compiler
5
6 Group:          Applications/Internet
7 License:        GPLv2+
8 URL:            http://ikiwiki.info/
9 Source0:        http://ftp.debian.org/debian/pool/main/i/%{name}/%{name}_%{version}.tar.gz
10 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11 BuildArch:      noarch
12
13 BuildRequires:  perl(Text::Markdown)
14 BuildRequires:  perl(Mail::Sendmail)
15 BuildRequires:  perl(HTML::Scrubber)
16 BuildRequires:  perl(XML::Simple)
17 BuildRequires:  perl(Date::Parse)
18 BuildRequires:  perl(Date::Format)
19 BuildRequires:  perl(HTML::Template)
20 BuildRequires:  perl(CGI::FormBuilder)
21 BuildRequires:  perl(CGI::Session)
22 BuildRequires:  perl(File::MimeInfo)
23 BuildRequires:  gettext
24 BuildRequires:  po4a
25
26 Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27
28 Requires:       perl(Text::Markdown)
29 Requires:       perl(Mail::Sendmail)
30 Requires:       perl(HTML::Scrubber)
31 Requires:       perl(XML::Simple)
32 Requires:       perl(CGI::FormBuilder)
33 Requires:       perl(CGI::Session)
34 Requires:       perl(Digest::SHA1)
35
36 Requires:       python-docutils
37
38 %define cgi_bin %{_libexecdir}/w3m/cgi-bin
39
40
41 %description
42 Ikiwiki is a wiki compiler. It converts wiki pages into HTML pages
43 suitable for publishing on a website. Ikiwiki stores pages and history
44 in a revision control system such as Subversion or Git. There are many
45 other features, including support for blogging, as well as a large
46 array of plugins.
47
48
49 %prep
50 %setup0 -q -n %{name}
51
52 # Filter unwanted Provides:
53 %{__cat} << \EOF > %{name}-prov
54 #!/bin/sh
55 %{__perl_provides} $* |\
56   %{__sed} -e '/perl(IkiWiki.*)/d'
57 EOF
58
59 %define __perl_provides %{_builddir}/%{name}/%{name}-prov
60 %{__chmod} +x %{__perl_provides}
61
62 # Filter Requires, all used by plugins
63 # - Monotone: see bz 450267
64 %{__cat} << \EOF > %{name}-req
65 #!/bin/sh
66 %{__perl_requires} $* |\
67   %{__sed} -e '/perl(IkiWiki.*)/d' \
68            -e '/perl(Monotone)/d'
69 EOF
70
71 %define __perl_requires %{_builddir}/%{name}/%{name}-req
72 %{__chmod} +x %{__perl_requires}
73
74 # goes into the -w3m subpackage
75 %{__cat} << \EOF > README.fedora
76 See http://ikiwiki.info/w3mmode/ for more information.
77 EOF
78
79
80 %build
81 %{__perl} Makefile.PL INSTALLDIRS=vendor PREFIX=%{_prefix}
82 # parallel builds currently don't work
83 %{__make} 
84
85
86 %install
87 %{__rm} -rf %{buildroot}
88 %{__make} pure_install DESTDIR=%{buildroot} W3M_CGI_BIN=%{cgi_bin}
89 %find_lang %{name}
90
91 %clean
92 %{__rm} -rf %{buildroot}
93
94
95 %files -f %{name}.lang
96 %defattr(-,root,root,-)
97 %{_bindir}/ikiwiki*
98 %{_sbindir}/ikiwiki*
99 %{_mandir}/man1/ikiwiki*
100 %{_mandir}/man8/ikiwiki*
101 %{_datadir}/ikiwiki
102 %dir %{_sysconfdir}/ikiwiki
103 %config(noreplace) %{_sysconfdir}/ikiwiki/*
104 # contains a packlist only
105 %exclude %{perl_vendorarch}
106 %{perl_vendorlib}/IkiWiki*
107 %exclude %{perl_vendorlib}/IkiWiki*/Plugin/skeleton.pm.example
108 %{_libdir}/ikiwiki
109 %doc README debian/changelog debian/NEWS html
110 %doc IkiWiki/Plugin/skeleton.pm.example
111
112
113 %package w3m
114 Summary:        Ikiwiki w3m cgi meta-wrapper
115 Group:          Applications/Internet
116 Requires:       w3m
117 Requires:       %{name} = %{version}-%{release}
118
119 %description w3m
120 Enable usage of all of ikiwiki's web features (page editing, etc) in
121 the w3m web browser without a web server. w3m supports local CGI
122 scripts, and ikiwiki can be set up to run that way using the
123 meta-wrapper in this package.
124
125
126 %files w3m
127 %defattr(-,root,root,-)
128 %doc README.fedora
129 %{cgi_bin}/ikiwiki-w3m.cgi