Remove img style attribute from recentchanges.tmpl; the default style.css covers...
[ikiwiki.git] / debian / NEWS
1 ikiwiki (2.00) unstable; urgency=low
2
3   With the 2.0 release of ikiwiki, some major changes have been made to the
4   default configuration:
5
6   * The 'usedirs' setting is enabled by default. This *will* break all URLs
7     to wikis that did not have 'usedirs' turned on before, unless you follow
8     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
9     or edit your setup file to turn usedirs off:
10        usedirs => 0,
11
12   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
13     perl module is available. Password logins are also still enabled
14     by default. If you like, you can turn either OpenID or password logins
15     off via the 'disable_plugins' setting.
16
17  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
18
19 ikiwiki (1.51) unstable; urgency=low
20
21   Some wikis need to be rebuilt on upgrade to this version, due to changes to
22   page layout and the style sheet. If you listed your wiki in
23   /etc/ikiwiki/wikilist this will be done automatically when the Debian
24   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
25
26  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
27
28 ikiwiki (1.50) unstable; urgency=low
29
30   Permalinks and guids in rss and atom feeds for wikis using the usedirs
31   options will change in this release. If you have already enabled usedirs,
32   you may need to take steps to avoid flooding aggregators.
33
34  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
35
36 ikiwiki (1.49) unstable; urgency=low
37
38   Third-party plugins that use htmlpage() or abs2rel() to generate links
39   may need changes to support the new "usedirs" option.
40
41  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
42
43 ikiwiki (1.47) unstable; urgency=low
44  
45   Due to a security fix, wikis that have the htmlscrubber enabled can no
46   longer use the meta plugin to insert html link and meta tags.
47
48   Some special case methods have been added for safely including stylesheets,
49   and for doing openid delegation. See the meta plugin docs for details.
50  
51  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
52
53 ikiwiki (1.45) unstable; urgency=low
54
55   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
56   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
57   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
58
59  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
60
61 ikiwiki (1.44) unstable; urgency=low
62
63   The htmllink() function has changed slightly and plugins that use it may
64   need to change how they call it. This function's first three parameters
65   are unchanged, but additional options are now passed using named
66   parameters. If you used htmllink with more than 3 parameters, you will
67   need to change it. The plugin interface version has been increased to 1.02
68   to reflect this change.
69
70  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
71
72 ikiwiki (1.42) unstable; urgency=low
73
74   The anonok setting in config files has been removed. To enable
75   httpauth support on your wiki, you should now enable the anonok plugin,
76   instead.
77
78   Third-party plugins that use pagespec_match() should be updated to pass
79   the new third parameter (from) to that function. This is needed for the
80   new relative glob matching to work.
81
82  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
83
84 ikiwiki (1.34) unstable; urgency=low
85
86   The httpauth setting in config files has been removed. To enable
87   httpauth support on your wiki, you should now enable the httpauth plugin,
88   instead.
89
90   This release includes OpenID support that is enabled through the openid
91   plugin. I recommend turning this on to make it easier for users to sign
92   in to your wiki.
93
94  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
95
96 ikiwiki (1.32) unstable; urgency=low
97
98   There is a change to the plugin interface in this version. Any plugins that
99   modify data in %links should pass scan => 1 when registering the hook that
100   does so.
101
102  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
103
104 ikiwiki (1.29) unstable; urgency=low
105
106   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
107   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
108   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
109
110   There is a change to the plugin interface in this version. Plugins that use
111   %renderedfiles will need to be updated, as the hash's values are now arrays
112   of rendered files. Plugins that cause a page to render additional files
113   should use the new will_render function to register the files.
114
115  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
116
117 ikiwiki (1.22) unstable; urgency=low
118   
119   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
120   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
121   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
122   to force a rebuild.
123
124   If you have modified versions of ikiwiki's html templates, you will need
125   to update your templates to link to the stylesheet file using
126   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
127   STYLEURL.
128
129   There have also been some changes to the plugin interface:
130   Any plugins that use santize, htmlize, or format hooks will need to be
131   updated for this version of ikiwiki since these hooks have been changed
132   to use named parameters.
133
134  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
135
136 ikiwiki (1.13) unstable; urgency=low
137
138   The GlobList format which was used for specifiying sets of pages, has been
139   replaced with a new, more expressive PageSpec format. While GlobLists will
140   continue to work, that format is deprecated, and you are encouraged to use
141   PageSpecs from now on, and also to change any GlobLists in your wiki to
142   PageSpecs. See the new PageSpec page for details.
143   
144   You will need to rebuild your wiki when upgrading to this version. If you
145   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
146   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
147   rebuild.
148
149  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
150
151 ikiwiki (1.11) unstable; urgency=low
152
153   Some changes to tags in this release, due to a new tag plugin. If you have
154   been using the meta plugin to tag pages, you'll want to enable the tag
155   plugin too, and change things like this:
156
157   [[meta link="foobar"]]
158
159   To this:
160
161   [[tag foobar]]
162
163   The new tags will appear at page footers, and are also easier to type.
164
165   There have also been some changes to the plugin interface, particularly the
166   interface of pagetemplate hooks has changed. See the changelog for details.
167
168  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
169
170 ikiwiki (1.8) unstable; urgency=low
171
172   If your wiki is configured with a setup file, you should modify it to
173   stop setting the "plugin" list directly, and instead add or remove plugins
174   via the add_plugins and disable_plugins lines. For example, if you had:
175
176         plugin => [qw{inline smiley search}],
177
178   Change it to these lines, which disables the default htmlscrubber plugin
179   and adds the two additional plugins:
180
181         add_plugins => [qw{smiley search}],
182         disable_plugins => [qw{htmlscrubber}],
183
184   Making this change makes your ikiwiki setup file more future-proof since
185   new default plugins will be automatically used.
186   
187   You will need to rebuild your ikiwiki wrappers when upgrading to this
188   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
189   done automatically when the Debian package is upgraded. Or use
190   ikiiki-mass-rebuild --refresh to force a refresh.
191
192  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
193
194 ikiwiki (1.1) unstable; urgency=low
195
196   There have been several configuration changes in this release of ikiwiki:
197
198   The --svn and --no-svn switches are removed, instead you should use
199    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
200   be changed to set rcs => "svn"; if your setup file sets svn => 0
201   then change it to use rcs => "" to disable svn.
202
203   The --hyperestraier switch is gone too. To enable searching, turn on the
204   search plugin, by passing --plugin=search or through the plugin setting in
205   the setup file.
206
207   The --sanitize and --no-sanitize switches are also gone, replaced with the
208   htmlscrubber plugin. This plugin is enabled by default, to disable it,
209   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
210   setup file.
211
212   Discussion pages are enabled by default, but if your wiki is configured
213   with a setup file, you need to edit it to keep them enabled on upgrade
214   to this version. Add a line reading:
215   discussion => 1,
216
217   You will need to rebuild your wiki when upgrading to this version.
218   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
219   automatically when the Debian package is upgraded. Or use
220   ikiiki-mass-rebuild to force a rebuild.
221
222  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400