(no commit message)
[ikiwiki.git] / doc / bugs / CGI__44___formbuilder__44___non-existent_field_address.mdwn
1 Error received when clicking on the "edit" link:
2
3 > `Error: [CGI::FormBuilder::AUTOLOAD] Fatal: Attempt to address
4 > non-existent field 'text' by name at
5 > /home/tealart/bin/share/perl/5.8.4/IkiWiki/CGI.pm line 112`
6
7 Error received when following a "Create New Page" (eg. ?) link: 
8
9 > `Error: [CGI::FormBuilder::AUTOLOAD] Fatal: Attempt to address
10 > non-existent field 'param' by name at
11 > /home/tealart/bin/share/perl/5.8.4/IkiWiki/Plugin/editpage.pm line 122`
12
13 I could probably find several other flavors of this error if I went
14 looking, but I trust you get the idea. 
15
16 The CGI starts to render (this isn't the "you forgot to set the
17 permissions/turn on the CGI" error) and then fails. 
18
19 Further details:
20
21 - Running on shared hosting (dreamhost; but everything compiles,
22   dependencies installed, the site generates perfectly, other CGIs
23   work, the file permissions work).
24
25 - It's running perl 5.8.4, but I did upgrade gettext to 0.17
26
27 - the server is running gcc v3.3.5 (at this point, this is the main
28   difference between the working system and my box.)
29
30 - I've removed the locale declarations from both the config file and
31   the environment variable.
32
33 - I've also modified the page template and have my templates in a non
34   standard location. The wiki compiles fine, with the template, but
35   might this be an issue? The CGI script doesn't (seem) to load under
36   the new template, but I'm not sure how to address this issue.
37
38 - All of the required/suggested module dependencies are installed
39   (finally) to the latest version including (relevantly)
40   CGI::FormBuilder 3.0501.
41
42 - I'm running ikiwiki v3.08. Did I mention that it works perfectly in
43   nearly every other way that I've managed to test thusfar?
44
45 ----
46
47 > I suspect that your perl is too old and is incompatible with the version of CGI::FormBuilder you have installed.
48
49 > Is so, it seems likely that the same error message can be reproduced by running a simple command like this at the command line:
50
51 >     perl -e 'use warnings; use strict; use CGI::FormBuilder; my $form=CGI::FormBuilder->new; $form->text("boo")'
52
53 > --[[Joey]]