]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
add news
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.11) UNRELEASED; urgency=low
2
3   * Patch from Enrico that
4     - Adds a tag plugin that allows more easily tagging pages.
5       The meta plugin can also still be used for that, but the tag plugin
6       also lists a page's tags at the bottom of the page.
7     - Allows preprocessor directives to have parameters with no specified
8       value.
9     - Fixes preprocessor directive parameter parsing so that
10       foo=bar baz now means "foo=bar" and a "baz" with no value.
11   * Run pagetemplate hooks when inlining pages so that inlined pages also
12     list their tags.
13   * Make all plugins with pagetemplate hooks check that variables exist
14     on the template before setting them, for robustness.
15   * Switch pagetemplate hooks to using named parameters.
16   * Pass a "destpage" parameter to preprocessor and pagetemplate hooks.
17     This will be the page that a source page will be part of, which is
18     different than the source page for inlined pages.
19   * Audited all plugins to endure they pass page, destpage to htmllink
20     appropriatly. This means inlining of various plugins will not work
21     properly, with correct links generated.
22
23  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
24
25 ikiwiki (1.10) unstable; urgency=low
26
27   * Run page through any relevant filters when generating a page preview.
28   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
29     default throughout the wiki, not only on wikitext pages. Decided to call
30     this a feature, and split the camelcase support out into a separate plugin
31     that is independant of wikitext.
32   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
33
34  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
35
36 ikiwiki (1.9) unstable; urgency=low
37
38   * Improve display of parentlinks and page title of toplevel index page.
39   * Patch from Faidon to use svn --limit when possible for recentchanges,
40     speeds up recentchanges a lot for wikis with more history.
41   * Patch from Recai to fix utf8 issues in git backend.
42   * Add wikitext markup plugin, which supports ".wiki" pages written in the
43     original wiki syntax, CamelCase links and all.
44   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
45     support, to edit pages etc without a web server.
46   * Display CGI processing errors if present.
47   * Fix from Faidon for a XML parser issue that breaks utf-8 for
48     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
49     area, and also way slow.
50   * Match 'web commit from' in SVN and git, these are web commits too.
51     (Faidon)
52   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
53     readable and avoid future mistakes. The patch seems to work and for the
54     first time I have a UTF-8 username ;-) (Faidon)
55   * Use form->field consistently, not form->param.
56   * Patch from Recai to allow selection of page type when creating a new page.
57     Default page type is inherited from the link clicked on to create the new
58     page.
59
60  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
61
62 ikiwiki (1.8) unstable; urgency=low
63
64   * Fix orphans plugin to not count a link to a nonexistant page as a reason
65     for a page not being an orphan.
66   * Support pinging services such as Technorati using XML-RPC to notify them
67     about changes to rss feeds.
68   * Parse svn log as xml for improved utf8 and security. Note that this makes
69     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
70   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
71     flagged string even if the locale causes it to generate utf8 output,
72     so make sure to let perl know it should be handled as utf8. Also,
73     the optimised version used for standard time formats won't work if the
74     user has changed locale, so drop it. Thanks, Faidon Liambotis.
75   * Fix re-encoding of the comments field to utf8 if a commit fails
76     due to a conflict. Thanks, Faidon Liambotis.
77   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
78     Liambotis.
79   * Add insane double encode/decode to utf8 around call to markdown.
80     This works around a truely strange bug, which is apparently a bug in
81     perl, #376329. Also added a test case for it.
82   * Improve layout of edit page so formatting help link is always visible w/o
83     getting in the way of the preview.
84   * Centralised all calls to HTML::Template and force all the templates
85     to be read as utf8.
86   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
87   * Introduce add_plugins and disable_plugins config options in setup files.
88     This allows adding or removing plugins w/o overriding the whole list of
89     default plugins, which makes it easier to upgrade when new default plugins
90     are added.
91   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
92     default (of course!). Based on a patch by Faidon Liambotis.
93   * Add a html plugin, which can be used to write wikis in raw html,
94     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
95     defaults to not processing .html files, since w/o this plugin they would
96     be copied unsanitised. With this plugin, it will process and html
97     sanitise them, like any other page type.
98   * Rebuilding wrappers is necessary on upgrade to this version.
99   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
100     will be automatically done on all upgrades.
101   * Don't send pings if the wiki is being rebuilt.
102   * Work around very innefficient behavior in File::Spec::abs2rel. Result
103     is a savings of 2 pointless fork/execs per link calculation, which
104     results in ~25% speedup of ikiwiki building its own doc wiki, and
105     about 35% speedup displaying RecentChanges!
106   * Make RecentChanges use a table and some CSS, should be much more readable.
107     No code changes involved.
108   * Encode & in diffurl in examples, to conform to pedantic rules.
109   * Speed up RecentChanges by another 40% or so with some memoization.
110   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
111     in time to build the doc wiki.
112
113  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
114
115 ikiwiki (1.7) unstable; urgency=low
116
117   * Updated logo from Recai with some kerning and alingment tuning.
118   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
119     changed some output.
120   * Copyright update.
121
122  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
123
124 ikiwiki (1.6) unstable; urgency=low
125
126   * YA utf-8 patch from Recai, this time to fix previewing a page so that
127     the text in the input box is re-encoded back to utf-8.
128   * -CSD does not affect modules, so readfile() was not using the utf-8 input
129     layer, which led to lots of problems; make it force read files as utf-8.
130     Closes: #373203
131   * Note that as a consequence, this version of ikiwiki will actually try to
132     parse utf8 in source files for the first time, which may expose broken
133     utf8 in wiki sources that was hidden before. Most common will be
134     perl warnings like "utf8 "\xE9" does not map to Unicode"
135   * writefile() likewise needs to use the utf8 output layer.
136   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
137     there.
138   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
139     given the readfile fix.
140   * Add utf-8 testcases for readfile and htmlize.
141   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
142     safe.
143   * More utf-8 fixes from Recai, partly to things I broke above:
144     - The serious problem is that writefile() saves the content in undecoded
145       format in CGI, hence all (non-ascii) chars are corrupted permanently.
146     - Comment field in edit page is not decoded and all the non-ascii chars in
147       this field are corrupted as the result.  We should decode it as we do it
148       for the content.
149     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
150       character in print.
151   * New SVG logo from Recai.
152
153  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
154
155 ikiwiki (1.5) unstable; urgency=low
156
157   * Add --timeformat config option to allow changing how dates are displayed.
158     Note that as a side effect, dates will now be displayed using the local
159     timezone, not as GMT.
160   * More security review.
161   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
162     for some handy stuff like:
163     - Using links as a kind of tag; creating blog pages that list all pages
164       containing a given tag/link or not containing some other tag.
165     - Subscribing to mail notifications whenever a change is made to a page
166       that is a backlink of page foo. Ie, "Please notify me of changes in all
167       pages that link to my home page in the wiki"
168     - Locking any pages that are linked to from a particular page, so that
169       lists of locks can be exposed in the wiki.
170   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
171     when a todo item is done, instead of the previous moving it to a different
172     subdir.
173   * Allow pagetemplate plugins to override *anything* in the template.
174   * Add a meta plugin, which allows specifying various metadata about pages,
175     like license and author. It also allows for inserting html link and meta
176     tags into html, overriding the title, and adding hidden WikiLinks, which
177     can be useful when using link-based globbing for page categorisation.
178   * Remove preprocessor directives from inlined pages.
179   * Allow simple preprocessor directive values to be specified w/o quotes.
180   * Add support for using git instead of subversion as the RCS backend,
181     tremendous thanks to Recai Oktaş for this.
182   * Doc updates for git.
183   * Fix absolute url munging in rss generation to support https, ftp, etc urls
184     not just http urls.
185   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
186     utf-8 for edit and other fields, and for recentchanges. There may still
187     be utf-8 issues with the preferences page though.
188
189  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
190
191 ikiwiki (1.4) unstable; urgency=low
192
193   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
194     very strange way of enabling proper XHTML <br /> type tags. Output html
195     should be always valid again now.
196   * The page name and parent links has switched from using a <h1> to a styled
197     <span>, so pages can use <h1> internally instead of needing to use <h2>.
198   * Updated all of ikiwiki's own wiki pages for that.
199   * Add pagetemplate hook, which can be used by plugins that want to mess
200     around with adding new stuff to the page template.
201   * Remove headercontent; the search plugin now adds the search box to the
202     header by registering a pagetemplate hook, and other plugins should do
203     similarly.
204   * Rebuilding on upgrade to this version is recommended.
205   * Add a html validity check to the test suite, using the wdg-html-validator,
206     if available.
207   * Make the html valid when there is nothing in the actions list.
208   * Reordered some function call parameters for consistency.
209   * Enable full utf-8 support for page input and output.
210   * Add a workaround for markdown, which does not work well with utf-8
211     strings.
212   * --getctime had bitrotted (well I only ever used it the once so far..),
213     fix and make it a bit more flexible
214   * rcs_getctime is changed, now rather than needing to loop over all pages,
215     it should just use the rcs to get the ctime of the passed file.
216   * When inlining a page in another one, links from the inlined page are now
217     expanded the same as they are when rendering the inlined page as a
218     standalone page. So rather than being expanded from the POV of the
219     inlining page, they are expanded from the POV of the inlined page.
220
221     For example, a link from blog/foo to "bar" will now link to blog/bar
222     if it exists. Previously this needed to be a link explicitly to
223     "blog/bar"; such links will also continue to work.
224
225     (This was slightly complex to do as the link still has to be constructed
226     relative to the inlining page.)
227   * Make page edit textarea resize to fit browser window.
228   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
229     do not need a full rebuild, in order to update any basewiki pages.
230
231  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
232
233 ikiwiki (1.3) unstable; urgency=low
234
235   * Fix the preinst introduced in the last version. Closes: #367458
236
237  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
238
239 ikiwiki (1.2) unstable; urgency=low
240
241   * Remove dups from the brokenlinks list.
242   * Add libc6-dev to dependencies, needed to build wrappers.
243   * Install wikilist in correct location. Closes: #367371
244
245  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
246
247 ikiwiki (1.1) unstable; urgency=low
248
249   * Rename inlinepage to depends, so that it can be used to refer to more
250     dependency relationships than just inlining. This will require a rebuild
251     on upgrade to this version.
252   * Move the rss link, put it in the blogpost form if there is one and at the
253     top if not. This is both nicer because easier to find, and it cleans up
254     the code which had used inlinepage as a flag for adding the link later.
255   * Allow the depends GlobList to be built up from multiple sources (such as
256     plugins) during a page render.
257   * Which means that more than one blog is now supported to appear on a
258     single page. (With some limitations, like only the last one getting an
259     rss file.)
260   * Added a plugin system.
261   * Added a pagecount plugin, enabled by default.
262   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
263   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
264     backlinks when the backlinks hadn't really changed.
265   * Moved inline page support, rss generation etc into the inline plugin,
266     enabled by default.
267   * Added brokenlinks plugin, not enabled by default, but rather handy.
268   * Fix several broken links in the doc wiki.
269   * Smarter behavior when creating a page and a page of the same name (but
270     different location) already exists.
271   * Add an orphans plugin for finding pages that nothing links to.
272   * Removed backlinks page, which it turns out nothing used.
273   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
274     it, this will allow for adding a unit test suite.
275   * Add unit tests for several core functions, including globlist_match,
276     dirname, basename, bestlink, linkify, pagetitle, titlepage.
277   * Smart globlist merging.
278   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
279     to pave the way for adding other RCS support. This also changes the
280     setup files, where before they had svn => 1 or svn => 0, now they have
281     rcs => "svn" or rcs => "".
282   * Add a debian/NEWS file with upgrade notes.
283   * Load whatever rcs module is specified, so new ones can be just dropped in
284     as plugins and work. (Well, in theory.)
285   * Add some basic docs about writing RCS modules.
286   * Broke search capability out into a plugin, removed the --hyperestraier
287     switch.
288   * Added smiley plugin, nicely controlled and documented by the smileys page.
289   * Copied in some smileys from Moin Moin.
290   * Allow links of the form [[some page|page]], with whitespace in the link
291     text.
292   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
293     and --disable-plugin htmlscrubber.
294   * Allow discussion links on pages to be turned off with --no-discussion.
295   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
296   * Add some new config items to the estseek.conf template, which are needed
297     by hyperestraier 1.2.3.
298
299  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
300
301 ikiwiki (1.0) unstable; urgency=low
302
303   * First official release.
304
305  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400