adapt misc.tmpl to html5
[ikiwiki.git] / debian / NEWS
1 ikiwiki (3.20100427) unstable; urgency=low
2
3   This version of ikiwiki has a lot of changes that you need to know about.
4
5   Now you can include customised versions of templates in the source
6   of your wiki. (For example, templates/page.tmpl.) When these templates
7   are changed, ikiwiki will automatically rebuild pages that use them.
8
9   Allowing untrusted users to upload attachments with the ".tmpl"
10   extension is not recommended, as that allows anyone to change
11   a wiki's templates.
12
13   The --getctime switch is renamed to --gettimes, and it also gets the 
14   file modification time. And it's a lot faster (when using git). But
15   the really important change is, you don't have to remember to use this
16   switch. Now ikiwiki will do it when it needs to.
17
18   At last, the "tagged()" pagespec only matches tags, not regular wikilinks.
19   If your wiki accidentially relied on the old, buggy behavior, you might
20   need to change its pagespecs to use "link()".
21
22   Many of your wishes have been answered: Now tag pages can automatically be
23   created when new tags are used. This feature is enabled by default if you
24   have configured a tagbase. It can be turned on or off using the
25   tag_autocreate setting.
26
27   These changes may also affect some users:
28
29   * The title_natural sort method (as used by the inline directive, etc)
30     has been moved to the new sortnaturally plugin, which is not enabled
31     by default since it requires the Sort::Naturally perl module.
32
33   * The add_templates option has been removed from the underlay plugin.
34     If you used this option, you can instead use templates/ subdirectories
35     inside underlay directories added by the add_underlays option.
36
37   Due to the above and other changes, all wikis need to be rebuilt on
38   upgrade to this version. If you listed your wiki in /etc/ikiwiki/wikilist
39   this will be done automatically when the Debian package is upgraded. Or
40   use ikiwiki-mass-rebuild to force a rebuild.
41
42  -- Joey Hess <joeyh@debian.org>  Tue, 27 Apr 2010 00:00:00 -0400
43
44 ikiwiki (3.20091017) unstable; urgency=low
45
46   To take advantage of significant performance improvements, all
47   wikis need to be rebuilt on upgrade to this version. If you
48   listed your wiki in /etc/ikiwiki/wikilist this will be done
49   automatically when the Debian package is upgraded. Or use
50   ikiwiki-mass-rebuild to force a rebuild.
51
52  -- Joey Hess <joeyh@debian.org>  Mon, 05 Oct 2009 16:48:59 -0400
53
54 ikiwiki (3.1415926) unstable; urgency=low
55
56   In order to fix a performance bug, all wikis need to be rebuilt on
57   upgrade to this version. If you listed your wiki in
58   /etc/ikiwiki/wikilist this will be done automatically when the
59   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force
60   a rebuild.
61
62  -- Joey Hess <joeyh@debian.org>  Tue, 25 Aug 2009 17:24:43 -0400
63
64 ikiwiki (3.13) unstable; urgency=low
65
66   The `ikiwiki-transition deduplinks` command introduced in the
67   last release was buggy. If you followed the NEWS file instructions
68   and ran it, you should run `ikiwiki -setup` to rebuild your wiki
69   to fix the problem.
70
71  -- Joey Hess <joeyh@debian.org>  Fri, 22 May 2009 13:04:02 -0400
72
73 ikiwiki (3.12) unstable; urgency=low
74
75   You may want to run `ikiwiki-transition deduplinks your.setup`
76   after upgrading to this version of ikiwiki. This command will
77   optimise your wiki's saved state, removing duplicate information
78   that can slow ikiwiki down.
79
80  -- Joey Hess <joeyh@debian.org>  Wed, 06 May 2009 00:25:06 -0400
81
82 ikiwiki (3.01) unstable; urgency=low
83
84   If your wiki uses git, and you have a `diffurl` configured in
85   its setup file, you should be aware that gitweb has stopped
86   supporting the url form commonly used for the `diffurl`.
87
88   You can change your setup to use the newer gitweb url form:
89
90     http://git.example.com/gitweb.cgi?p=wiki.git;a=blobdiff;f=[[file]];h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_commit]];hpb=[[sha1_parent]]
91
92   The changes from the old form are the addition of the `hpb` parameter,
93   and the change to the value used for the `hb` parameter.
94
95  -- Joey Hess <joeyh@debian.org>  Mon, 05 Jan 2009 18:18:05 -0500
96
97 ikiwiki (3.00) unstable; urgency=low
98
99   The 3.0 release of ikiwiki changes several defaults and finishes
100   some transitions. You will need to modify your wikis to work with
101   ikiwiki 3.0. A document explaining the process is available
102   in </usr/share/doc/ikiwiki/html/tips/upgrade_to_3.0.html>
103
104  -- Joey Hess <joeyh@debian.org>  Tue, 23 Dec 2008 16:14:18 -0500
105
106 ikiwiki (2.62) unstable; urgency=low
107
108   TexImg standard preamble changed
109
110   The teximg plugin now has a configurable LaTeX preamble.
111   As part of this change the `mchem` LaTeX package has been removed from
112   the default LaTeX preamble as it wasn't included in many TeX installations.
113
114   The previous behaviour can be restored by adding the following to your
115   ikiwiki setup:
116
117         teximg_prefix => '\documentclass{scrartcl}
118                 \usepackage[version=3]{mhchem}
119                 \usepackage{amsmath}
120                 \usepackage{amsfonts}
121                 \usepackage{amssymb}
122                 \pagestyle{empty}
123                 \begin{document}',
124
125   In addition, the rendering mechanism has been changed to use `dvipng` by
126   default, if available.
127
128  -- Joey Hess <joeyh@debian.org>  Sun, 24 Aug 2008 15:00:40 -0400
129
130 ikiwiki (2.60) unstable; urgency=low
131
132   Admin preferences are moving from the web interface to the setup file.
133   There are three new options in the setup file: `locked_pages`, `banned_users`,
134   and `allowed_attachments`. The admin prefs page can still be used, but
135   that's deprecated, and the prefs will be hidden if a value is not already
136   set. If a value is set in the web interface, you're encouraged to move that
137   setting to your setup file now, since version 3.0 will remove the deprecated
138   admin prefs web interface.
139
140   Also, the layout of the setup file has changed in a significant way in this
141   release. Old setup files will continue to work, but new features, like the
142   new websetup interface, require a new format setup file. You can convert
143   old setup files into the new format by running 
144   `ikiwiki-transition setupformat ikiwiki.setup`
145
146  -- Joey Hess <joeyh@debian.org>  Fri, 01 Aug 2008 17:02:14 -0400
147
148 ikiwiki (2.52) unstable; urgency=low
149
150   All wikis need to be rebuilt on upgrade to this version. If you listed your
151   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
152   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
153
154  -- Joey Hess <joeyh@debian.org>  Sun, 06 Jul 2008 15:10:05 -0400
155
156 ikiwiki (2.49) unstable; urgency=low
157
158   The search plugin no longer uses hyperestraier. Instead, to use it you
159   will now need to install xapian-omega, and the Search::Xapian,
160   HTML::Scrubber, and Digest::SHA1 perl modules. Ie,
161   `apt-get install xapian-omega libsearch-xapian-perl libhtml-scrubber-perl libdigest-sha1-perl`
162
163   Also, wikis that use the search plugin will need to be rebuilt,
164   since the search form has changed. This will not be done automatically,
165   but can be done by running `ikiwiki-mass-upgrade` as root, or
166   running `ikiwiki -setup` on individual setup files.
167
168  -- Joey Hess <joeyh@debian.org>  Wed, 04 Jun 2008 00:29:28 -0400
169
170 ikiwiki (2.48) unstable; urgency=high
171
172   If you allowed password based logins to your wiki, those passwords were
173   stored in cleartext in the userdb. To guard against exposing users'
174   passwords, I recommend you install the Authen::Passphrase perl module, and
175   then run `ikiwiki-transition hashpassword /path/to/srcdir` to replace all
176   existing cleartext passwords with strong (blowfish) hashes.
177
178  -- Joey Hess <joeyh@debian.org>  Thu, 29 May 2008 14:39:34 -0400
179
180 ikiwiki (2.46) unstable; urgency=low
181  
182   There were some significant template changes in ikiwiki 2.42 (and 1.33.5).
183   If you have locally modified versions of the templates, they need to be
184   updated. Most notably, the editpage.tmpl has a new FIELD-SID added to it,
185   without which web editing will fail.
186  
187  -- Joey Hess <joeyh@debian.org>  Tue, 06 May 2008 14:30:14 -0400
188
189 ikiwiki (2.40) unstable; urgency=low
190
191   ikiwiki now has an new syntax for preprocessor directives, using the
192   prefix '!':
193
194   [[!directive ...]]
195
196   This new syntax no longer relies on spaces to distinguish between
197   wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
198   in their link text, and preprocessor directives without arguments (such
199   as "toc") need not use a trailing space.
200
201   To enable the new syntax, set prefix_directives to true in your ikiwiki
202   config.  For backward compatibility with existing wikis,
203   prefix_directives currently defaults to false.  In ikiwiki 3.0,
204   prefix_directives will default to true, and wikis which have not yet
205   converted to the new syntax will need to set prefix_directives to false
206   in their setup files.
207
208   To convert your wiki to the new syntax, ikiwiki provides a new script
209   ikiwiki-transition.
210
211   Even with prefix_directives disabled, ikiwiki now allows an optional '!'
212   prefix on preprocessor directives (but still requires a space).  Thus, a
213   directive which uses a '!' prefix and contains a space will work with
214   ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
215   This allows the underlay to work with all ikiwikis.
216
217  -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
218
219 ikiwiki (2.30) unstable; urgency=low
220
221   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
222   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
223   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
224   Custom RecentChanges pages can be easily set up that display only changes
225   to a subset of pages, or only changes by a subset of users.
226   
227   All wikis need to be rebuilt on upgrade to this version. If you listed your
228   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
229   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
230
231   With this excellent new RecentChanges support, the mail notification system
232   is its age (and known to be variously buggy and underimplemented for
233   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
234   from this version. If you were subscribed to commit mails, you should be
235   able to accomplish the same thing by subscribing to a RecentChanges feed.
236
237   The "notify" field in setup files is no longer used, and
238   silently ignored. You may want to remove it from your setup file.
239
240  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
241
242 ikiwiki (2.20) unstable; urgency=low
243
244   The template plugin has begin to htmlize the variables passed to templates.
245   This is normally what you want, but to get the old behavior and get at the
246   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
247  
248  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
249
250 ikiwiki (2.16) unstable; urgency=low
251
252   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
253   release, to avoid the basewiki including pages with names like "blog".
254   Redirection pages have been left behind for these moved pages temporarily,
255   and will be removed later.
256
257   If you use the calendar plugin, ikiwiki is now smarter and your nightly
258   cron job to update the wiki doesn't need to rebuild everything. Just pass
259   --refresh to ikiwiki in the cron job and it will update only pages that
260   contain out of date calendars.
261
262  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
263
264 ikiwiki (2.14) unstable; urgency=low
265
266   This version of ikiwiki is more picky about symlinks in the path leading
267   to the srcdir, and will refuse to use a srcdir specified by such a path.
268   This was necessary to avoid some potential exploits, but could potentially
269   break (semi-)working wikis. If your wiki has a srcdir path containing a
270   symlink, you should change it to use a path that does not.
271
272  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
273
274 ikiwiki (2.9) unstable; urgency=low
275
276   Since ikiwiki 2.0 was released, some limitiations have been added to what
277   ikiwiki considers a WikiLink. In short, if there are any spaces in between
278   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
279   contains things meant to be WikiLinks that contain spaces, you will need to
280   fix them, by replacing the spaces with underscores.
281   
282   WikiLink have always been documented to not contain spaces, but bugs in
283   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
284   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
285   release. These fixes are necessary to avoid ambiguity between
286   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
287   these bugs (and their fixes) may have caused.
288
289  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
290
291 ikiwiki (2.6) unstable; urgency=low
292
293   In this version the rst plugin allows raw html to be embedded in rst files.
294   As long as the htmlscrubber is enabled, this should be safe. If you are
295   using the rst plugin without the htmlscrubber in a publically writable wiki,
296   you should turn on the htmlscrubber.
297
298  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
299
300 ikiwiki (2.5) unstable; urgency=low
301
302   Due to some config changes in this version, wrappers need to be rebuilt on
303   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
304   one automatically when the Debian package is upgraded.
305
306  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
307
308 ikiwiki (2.1) unstable; urgency=low
309
310   Some wikis need to be rebuilt on upgrade to this version, due to changes to
311   page templates and the style sheet. If you listed your wiki in
312   /etc/ikiwiki/wikilist this will be done automatically when the Debian
313   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
314
315  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
316
317 ikiwiki (2.00) unstable; urgency=low
318
319   With the 2.0 release of ikiwiki, some major changes have been made to the
320   default configuration:
321
322   * The 'usedirs' setting is enabled by default. This *will* break all URLs
323     to wikis that did not have 'usedirs' turned on before, unless you follow
324     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
325     or edit your setup file to turn usedirs off:
326        usedirs => 0,
327
328   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
329     perl module is available. Password logins are also still enabled
330     by default. If you like, you can turn either OpenID or password logins
331     off via the 'disable_plugins' setting.
332
333  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
334
335 ikiwiki (1.51) unstable; urgency=low
336
337   Some wikis need to be rebuilt on upgrade to this version, due to changes to
338   page layout and the style sheet. If you listed your wiki in
339   /etc/ikiwiki/wikilist this will be done automatically when the Debian
340   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
341
342  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
343
344 ikiwiki (1.50) unstable; urgency=low
345
346   Permalinks and guids in rss and atom feeds for wikis using the usedirs
347   options will change in this release. If you have already enabled usedirs,
348   you may need to take steps to avoid flooding aggregators.
349
350  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
351
352 ikiwiki (1.49) unstable; urgency=low
353
354   Third-party plugins that use htmlpage() or abs2rel() to generate links
355   may need changes to support the new "usedirs" option.
356
357  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
358
359 ikiwiki (1.47) unstable; urgency=low
360  
361   Due to a security fix, wikis that have the htmlscrubber enabled can no
362   longer use the meta plugin to insert html link and meta tags.
363
364   Some special case methods have been added for safely including stylesheets,
365   and for doing openid delegation. See the meta plugin docs for details.
366  
367  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
368
369 ikiwiki (1.45) unstable; urgency=low
370
371   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
372   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
373   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
374
375  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
376
377 ikiwiki (1.44) unstable; urgency=low
378
379   The htmllink() function has changed slightly and plugins that use it may
380   need to change how they call it. This function's first three parameters
381   are unchanged, but additional options are now passed using named
382   parameters. If you used htmllink with more than 3 parameters, you will
383   need to change it. The plugin interface version has been increased to 1.02
384   to reflect this change.
385
386  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
387
388 ikiwiki (1.42) unstable; urgency=low
389
390   The anonok setting in config files has been removed. To enable
391   httpauth support on your wiki, you should now enable the anonok plugin,
392   instead.
393
394   Third-party plugins that use pagespec_match() should be updated to pass
395   the new third parameter (from) to that function. This is needed for the
396   new relative glob matching to work.
397
398  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
399
400 ikiwiki (1.34) unstable; urgency=low
401
402   The httpauth setting in config files has been removed. To enable
403   httpauth support on your wiki, you should now enable the httpauth plugin,
404   instead.
405
406   This release includes OpenID support that is enabled through the openid
407   plugin. I recommend turning this on to make it easier for users to sign
408   in to your wiki.
409
410  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
411
412 ikiwiki (1.32) unstable; urgency=low
413
414   There is a change to the plugin interface in this version. Any plugins that
415   modify data in %links should pass scan => 1 when registering the hook that
416   does so.
417
418  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
419
420 ikiwiki (1.29) unstable; urgency=low
421
422   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
423   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
424   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
425
426   There is a change to the plugin interface in this version. Plugins that use
427   %renderedfiles will need to be updated, as the hash's values are now arrays
428   of rendered files. Plugins that cause a page to render additional files
429   should use the new will_render function to register the files.
430
431  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
432
433 ikiwiki (1.22) unstable; urgency=low
434   
435   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
436   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
437   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
438   to force a rebuild.
439
440   If you have modified versions of ikiwiki's html templates, you will need
441   to update your templates to link to the stylesheet file using
442   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
443   STYLEURL.
444
445   There have also been some changes to the plugin interface:
446   Any plugins that use santize, htmlize, or format hooks will need to be
447   updated for this version of ikiwiki since these hooks have been changed
448   to use named parameters.
449
450  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
451
452 ikiwiki (1.13) unstable; urgency=low
453
454   The GlobList format which was used for specifiying sets of pages, has been
455   replaced with a new, more expressive PageSpec format. While GlobLists will
456   continue to work, that format is deprecated, and you are encouraged to use
457   PageSpecs from now on, and also to change any GlobLists in your wiki to
458   PageSpecs. See the new PageSpec page for details.
459   
460   You will need to rebuild your wiki when upgrading to this version. If you
461   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
462   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
463   rebuild.
464
465  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
466
467 ikiwiki (1.11) unstable; urgency=low
468
469   Some changes to tags in this release, due to a new tag plugin. If you have
470   been using the meta plugin to tag pages, you'll want to enable the tag
471   plugin too, and change things like this:
472
473   [[meta link="foobar"]]
474
475   To this:
476
477   [[tag foobar]]
478
479   The new tags will appear at page footers, and are also easier to type.
480
481   There have also been some changes to the plugin interface, particularly the
482   interface of pagetemplate hooks has changed. See the changelog for details.
483
484  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
485
486 ikiwiki (1.8) unstable; urgency=low
487
488   If your wiki is configured with a setup file, you should modify it to
489   stop setting the "plugin" list directly, and instead add or remove plugins
490   via the add_plugins and disable_plugins lines. For example, if you had:
491
492         plugin => [qw{inline smiley search}],
493
494   Change it to these lines, which disables the default htmlscrubber plugin
495   and adds the two additional plugins:
496
497         add_plugins => [qw{smiley search}],
498         disable_plugins => [qw{htmlscrubber}],
499
500   Making this change makes your ikiwiki setup file more future-proof since
501   new default plugins will be automatically used.
502   
503   You will need to rebuild your ikiwiki wrappers when upgrading to this
504   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
505   done automatically when the Debian package is upgraded. Or use
506   ikiiki-mass-rebuild --refresh to force a refresh.
507
508  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
509
510 ikiwiki (1.1) unstable; urgency=low
511
512   There have been several configuration changes in this release of ikiwiki:
513
514   The --svn and --no-svn switches are removed, instead you should use
515    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
516   be changed to set rcs => "svn"; if your setup file sets svn => 0
517   then change it to use rcs => "" to disable svn.
518
519   The --hyperestraier switch is gone too. To enable searching, turn on the
520   search plugin, by passing --plugin=search or through the plugin setting in
521   the setup file.
522
523   The --sanitize and --no-sanitize switches are also gone, replaced with the
524   htmlscrubber plugin. This plugin is enabled by default, to disable it,
525   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
526   setup file.
527
528   Discussion pages are enabled by default, but if your wiki is configured
529   with a setup file, you need to edit it to keep them enabled on upgrade
530   to this version. Add a line reading:
531   discussion => 1,
532
533   You will need to rebuild your wiki when upgrading to this version.
534   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
535   automatically when the Debian package is upgraded. Or use
536   ikiiki-mass-rebuild to force a rebuild.
537
538  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400