]> sipb.mit.edu Git - ikiwiki.git/blob - doc/forum/is_it_possible_to_NOT_add_openid2_meta_tags.mdwn
response
[ikiwiki.git] / doc / forum / is_it_possible_to_NOT_add_openid2_meta_tags.mdwn
1 ### "meta openid" problems
2
3 I have add the followning to _index.mdwn_ on my site.
4
5     \[[!meta openid="http://certifi.ca/lunix"
6     server="http://certifi.ca/_serve"]]
7
8 This resulted in the following being added to my site
9
10     <link href="http://certifi.ca/_serve" rel="openid.server" />
11     <link href="http://certifi.ca/_serve" rel="openid2.provider" />
12     <link href="http://certifi.ca/lunix" rel="openid.delegate" />
13     <link href="http://certifi.ca/lunix" rel="openid2.local_id" /> -->
14
15 Perhaps I have done something wrong but this fails to work when I try to log in to several sites using my sites url as my login.  
16 If I edit index.html and remove the two openid2 lines all works fine.  
17 **Is there a way to only add openid version 1 tags to my index.html ?  
18 Or a way to make it work the way it is ?**  
19
20 Cheers  
21 Mick  
22 \_lunix_
23
24 > Before I think about adding a way to not add the openid 2 tags,
25 > I'd like to know what the problem is. Is there something
26 > wrong with the tags? Does your openid provider not support
27 > openid 2, and the site you are logging into sees the openid 2 tags
28 > and uses it, not falling back to openid 1? 
29
30 > Since certifi.ca is a public openid provider (run by a
31 > guy I know even!), I should be
32 > able to reproduce your problem if you can tell me what
33 > site(s) you are trying to log into. --[[Joey]]