3a8705680052223e7939a13bc83b3f520c09b3f0
[ikiwiki.git] / debian / NEWS
1 ikiwiki (3.20100422) unstable; urgency=low
2
3   This version of ikiwiki has a lot of changes that you need to know about.
4
5   The --getctime switch is renamed to --gettimes, and it also gets the 
6   file modification time. And it's a lot faster (when using git). But
7   the really important change is, you don't have to remember to use this
8   switch. Now ikiwiki will do it when it needs to.
9
10   Starting from this version, the "tagged()" pagespec only matches tags,
11   not regular wikilinks. If your wiki accidentially relied on the old,
12   buggy behavior, you might need to change its pagespecs to use "link()".
13
14   Now tag pages can automatically be created as new tags are used. This
15   feature is enabled by default if you have configured a tagbase. It
16   can be turned on or off using the tag_autocreate setting.
17
18   The title_natural sort method (as used by the inline directive, etc)
19   have been moved to the new sortnaturally plugin, which is not enabled
20   by default since it requires the Sort::Naturally perl module.
21
22   Due to the above and other changes, all wikis need to be rebuilt on
23   upgrade to this version. If you listed your wiki in /etc/ikiwiki/wikilist
24   this will be done automatically when the Debian package is upgraded. Or
25   use ikiwiki-mass-rebuild to force a rebuild.
26
27  -- Joey Hess <joeyh@debian.org>  Wed, 21 Apr 2010 20:31:29 -0400
28
29 ikiwiki (3.20091017) unstable; urgency=low
30
31   To take advantage of significant performance improvements, all
32   wikis need to be rebuilt on upgrade to this version. If you
33   listed your wiki in /etc/ikiwiki/wikilist this will be done
34   automatically when the Debian package is upgraded. Or use
35   ikiwiki-mass-rebuild to force a rebuild.
36
37  -- Joey Hess <joeyh@debian.org>  Mon, 05 Oct 2009 16:48:59 -0400
38
39 ikiwiki (3.1415926) unstable; urgency=low
40
41   In order to fix a performance bug, all wikis need to be rebuilt on
42   upgrade to this version. If you listed your wiki in
43   /etc/ikiwiki/wikilist this will be done automatically when the
44   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force
45   a rebuild.
46
47  -- Joey Hess <joeyh@debian.org>  Tue, 25 Aug 2009 17:24:43 -0400
48
49 ikiwiki (3.13) unstable; urgency=low
50
51   The `ikiwiki-transition deduplinks` command introduced in the
52   last release was buggy. If you followed the NEWS file instructions
53   and ran it, you should run `ikiwiki -setup` to rebuild your wiki
54   to fix the problem.
55
56  -- Joey Hess <joeyh@debian.org>  Fri, 22 May 2009 13:04:02 -0400
57
58 ikiwiki (3.12) unstable; urgency=low
59
60   You may want to run `ikiwiki-transition deduplinks your.setup`
61   after upgrading to this version of ikiwiki. This command will
62   optimise your wiki's saved state, removing duplicate information
63   that can slow ikiwiki down.
64
65  -- Joey Hess <joeyh@debian.org>  Wed, 06 May 2009 00:25:06 -0400
66
67 ikiwiki (3.01) unstable; urgency=low
68
69   If your wiki uses git, and you have a `diffurl` configured in
70   its setup file, you should be aware that gitweb has stopped
71   supporting the url form commonly used for the `diffurl`.
72
73   You can change your setup to use the newer gitweb url form:
74
75     http://git.example.com/gitweb.cgi?p=wiki.git;a=blobdiff;f=[[file]];h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_commit]];hpb=[[sha1_parent]]
76
77   The changes from the old form are the addition of the `hpb` parameter,
78   and the change to the value used for the `hb` parameter.
79
80  -- Joey Hess <joeyh@debian.org>  Mon, 05 Jan 2009 18:18:05 -0500
81
82 ikiwiki (3.00) unstable; urgency=low
83
84   The 3.0 release of ikiwiki changes several defaults and finishes
85   some transitions. You will need to modify your wikis to work with
86   ikiwiki 3.0. A document explaining the process is available
87   in </usr/share/doc/ikiwiki/html/tips/upgrade_to_3.0.html>
88
89  -- Joey Hess <joeyh@debian.org>  Tue, 23 Dec 2008 16:14:18 -0500
90
91 ikiwiki (2.62) unstable; urgency=low
92
93   TexImg standard preamble changed
94
95   The teximg plugin now has a configurable LaTeX preamble.
96   As part of this change the `mchem` LaTeX package has been removed from
97   the default LaTeX preamble as it wasn't included in many TeX installations.
98
99   The previous behaviour can be restored by adding the following to your
100   ikiwiki setup:
101
102         teximg_prefix => '\documentclass{scrartcl}
103                 \usepackage[version=3]{mhchem}
104                 \usepackage{amsmath}
105                 \usepackage{amsfonts}
106                 \usepackage{amssymb}
107                 \pagestyle{empty}
108                 \begin{document}',
109
110   In addition, the rendering mechanism has been changed to use `dvipng` by
111   default, if available.
112
113  -- Joey Hess <joeyh@debian.org>  Sun, 24 Aug 2008 15:00:40 -0400
114
115 ikiwiki (2.60) unstable; urgency=low
116
117   Admin preferences are moving from the web interface to the setup file.
118   There are three new options in the setup file: `locked_pages`, `banned_users`,
119   and `allowed_attachments`. The admin prefs page can still be used, but
120   that's deprecated, and the prefs will be hidden if a value is not already
121   set. If a value is set in the web interface, you're encouraged to move that
122   setting to your setup file now, since version 3.0 will remove the deprecated
123   admin prefs web interface.
124
125   Also, the layout of the setup file has changed in a significant way in this
126   release. Old setup files will continue to work, but new features, like the
127   new websetup interface, require a new format setup file. You can convert
128   old setup files into the new format by running 
129   `ikiwiki-transition setupformat ikiwiki.setup`
130
131  -- Joey Hess <joeyh@debian.org>  Fri, 01 Aug 2008 17:02:14 -0400
132
133 ikiwiki (2.52) unstable; urgency=low
134
135   All wikis need to be rebuilt on upgrade to this version. If you listed your
136   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
137   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
138
139  -- Joey Hess <joeyh@debian.org>  Sun, 06 Jul 2008 15:10:05 -0400
140
141 ikiwiki (2.49) unstable; urgency=low
142
143   The search plugin no longer uses hyperestraier. Instead, to use it you
144   will now need to install xapian-omega, and the Search::Xapian,
145   HTML::Scrubber, and Digest::SHA1 perl modules. Ie,
146   `apt-get install xapian-omega libsearch-xapian-perl libhtml-scrubber-perl libdigest-sha1-perl`
147
148   Also, wikis that use the search plugin will need to be rebuilt,
149   since the search form has changed. This will not be done automatically,
150   but can be done by running `ikiwiki-mass-upgrade` as root, or
151   running `ikiwiki -setup` on individual setup files.
152
153  -- Joey Hess <joeyh@debian.org>  Wed, 04 Jun 2008 00:29:28 -0400
154
155 ikiwiki (2.48) unstable; urgency=high
156
157   If you allowed password based logins to your wiki, those passwords were
158   stored in cleartext in the userdb. To guard against exposing users'
159   passwords, I recommend you install the Authen::Passphrase perl module, and
160   then run `ikiwiki-transition hashpassword /path/to/srcdir` to replace all
161   existing cleartext passwords with strong (blowfish) hashes.
162
163  -- Joey Hess <joeyh@debian.org>  Thu, 29 May 2008 14:39:34 -0400
164
165 ikiwiki (2.46) unstable; urgency=low
166  
167   There were some significant template changes in ikiwiki 2.42 (and 1.33.5).
168   If you have locally modified versions of the templates, they need to be
169   updated. Most notably, the editpage.tmpl has a new FIELD-SID added to it,
170   without which web editing will fail.
171  
172  -- Joey Hess <joeyh@debian.org>  Tue, 06 May 2008 14:30:14 -0400
173
174 ikiwiki (2.40) unstable; urgency=low
175
176   ikiwiki now has an new syntax for preprocessor directives, using the
177   prefix '!':
178
179   [[!directive ...]]
180
181   This new syntax no longer relies on spaces to distinguish between
182   wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
183   in their link text, and preprocessor directives without arguments (such
184   as "toc") need not use a trailing space.
185
186   To enable the new syntax, set prefix_directives to true in your ikiwiki
187   config.  For backward compatibility with existing wikis,
188   prefix_directives currently defaults to false.  In ikiwiki 3.0,
189   prefix_directives will default to true, and wikis which have not yet
190   converted to the new syntax will need to set prefix_directives to false
191   in their setup files.
192
193   To convert your wiki to the new syntax, ikiwiki provides a new script
194   ikiwiki-transition.
195
196   Even with prefix_directives disabled, ikiwiki now allows an optional '!'
197   prefix on preprocessor directives (but still requires a space).  Thus, a
198   directive which uses a '!' prefix and contains a space will work with
199   ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
200   This allows the underlay to work with all ikiwikis.
201
202  -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
203
204 ikiwiki (2.30) unstable; urgency=low
205
206   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
207   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
208   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
209   Custom RecentChanges pages can be easily set up that display only changes
210   to a subset of pages, or only changes by a subset of users.
211   
212   All wikis need to be rebuilt on upgrade to this version. If you listed your
213   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
214   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
215
216   With this excellent new RecentChanges support, the mail notification system
217   is its age (and known to be variously buggy and underimplemented for
218   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
219   from this version. If you were subscribed to commit mails, you should be
220   able to accomplish the same thing by subscribing to a RecentChanges feed.
221
222   The "notify" field in setup files is no longer used, and
223   silently ignored. You may want to remove it from your setup file.
224
225  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
226
227 ikiwiki (2.20) unstable; urgency=low
228
229   The template plugin has begin to htmlize the variables passed to templates.
230   This is normally what you want, but to get the old behavior and get at the
231   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
232  
233  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
234
235 ikiwiki (2.16) unstable; urgency=low
236
237   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
238   release, to avoid the basewiki including pages with names like "blog".
239   Redirection pages have been left behind for these moved pages temporarily,
240   and will be removed later.
241
242   If you use the calendar plugin, ikiwiki is now smarter and your nightly
243   cron job to update the wiki doesn't need to rebuild everything. Just pass
244   --refresh to ikiwiki in the cron job and it will update only pages that
245   contain out of date calendars.
246
247  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
248
249 ikiwiki (2.14) unstable; urgency=low
250
251   This version of ikiwiki is more picky about symlinks in the path leading
252   to the srcdir, and will refuse to use a srcdir specified by such a path.
253   This was necessary to avoid some potential exploits, but could potentially
254   break (semi-)working wikis. If your wiki has a srcdir path containing a
255   symlink, you should change it to use a path that does not.
256
257  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
258
259 ikiwiki (2.9) unstable; urgency=low
260
261   Since ikiwiki 2.0 was released, some limitiations have been added to what
262   ikiwiki considers a WikiLink. In short, if there are any spaces in between
263   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
264   contains things meant to be WikiLinks that contain spaces, you will need to
265   fix them, by replacing the spaces with underscores.
266   
267   WikiLink have always been documented to not contain spaces, but bugs in
268   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
269   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
270   release. These fixes are necessary to avoid ambiguity between
271   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
272   these bugs (and their fixes) may have caused.
273
274  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
275
276 ikiwiki (2.6) unstable; urgency=low
277
278   In this version the rst plugin allows raw html to be embedded in rst files.
279   As long as the htmlscrubber is enabled, this should be safe. If you are
280   using the rst plugin without the htmlscrubber in a publically writable wiki,
281   you should turn on the htmlscrubber.
282
283  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
284
285 ikiwiki (2.5) unstable; urgency=low
286
287   Due to some config changes in this version, wrappers need to be rebuilt on
288   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
289   one automatically when the Debian package is upgraded.
290
291  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
292
293 ikiwiki (2.1) unstable; urgency=low
294
295   Some wikis need to be rebuilt on upgrade to this version, due to changes to
296   page templates and the style sheet. If you listed your wiki in
297   /etc/ikiwiki/wikilist this will be done automatically when the Debian
298   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
299
300  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
301
302 ikiwiki (2.00) unstable; urgency=low
303
304   With the 2.0 release of ikiwiki, some major changes have been made to the
305   default configuration:
306
307   * The 'usedirs' setting is enabled by default. This *will* break all URLs
308     to wikis that did not have 'usedirs' turned on before, unless you follow
309     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
310     or edit your setup file to turn usedirs off:
311        usedirs => 0,
312
313   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
314     perl module is available. Password logins are also still enabled
315     by default. If you like, you can turn either OpenID or password logins
316     off via the 'disable_plugins' setting.
317
318  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
319
320 ikiwiki (1.51) unstable; urgency=low
321
322   Some wikis need to be rebuilt on upgrade to this version, due to changes to
323   page layout and the style sheet. If you listed your wiki in
324   /etc/ikiwiki/wikilist this will be done automatically when the Debian
325   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
326
327  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
328
329 ikiwiki (1.50) unstable; urgency=low
330
331   Permalinks and guids in rss and atom feeds for wikis using the usedirs
332   options will change in this release. If you have already enabled usedirs,
333   you may need to take steps to avoid flooding aggregators.
334
335  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
336
337 ikiwiki (1.49) unstable; urgency=low
338
339   Third-party plugins that use htmlpage() or abs2rel() to generate links
340   may need changes to support the new "usedirs" option.
341
342  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
343
344 ikiwiki (1.47) unstable; urgency=low
345  
346   Due to a security fix, wikis that have the htmlscrubber enabled can no
347   longer use the meta plugin to insert html link and meta tags.
348
349   Some special case methods have been added for safely including stylesheets,
350   and for doing openid delegation. See the meta plugin docs for details.
351  
352  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
353
354 ikiwiki (1.45) unstable; urgency=low
355
356   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
357   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
358   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
359
360  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
361
362 ikiwiki (1.44) unstable; urgency=low
363
364   The htmllink() function has changed slightly and plugins that use it may
365   need to change how they call it. This function's first three parameters
366   are unchanged, but additional options are now passed using named
367   parameters. If you used htmllink with more than 3 parameters, you will
368   need to change it. The plugin interface version has been increased to 1.02
369   to reflect this change.
370
371  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
372
373 ikiwiki (1.42) unstable; urgency=low
374
375   The anonok setting in config files has been removed. To enable
376   httpauth support on your wiki, you should now enable the anonok plugin,
377   instead.
378
379   Third-party plugins that use pagespec_match() should be updated to pass
380   the new third parameter (from) to that function. This is needed for the
381   new relative glob matching to work.
382
383  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
384
385 ikiwiki (1.34) unstable; urgency=low
386
387   The httpauth setting in config files has been removed. To enable
388   httpauth support on your wiki, you should now enable the httpauth plugin,
389   instead.
390
391   This release includes OpenID support that is enabled through the openid
392   plugin. I recommend turning this on to make it easier for users to sign
393   in to your wiki.
394
395  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
396
397 ikiwiki (1.32) unstable; urgency=low
398
399   There is a change to the plugin interface in this version. Any plugins that
400   modify data in %links should pass scan => 1 when registering the hook that
401   does so.
402
403  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
404
405 ikiwiki (1.29) unstable; urgency=low
406
407   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
408   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
409   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
410
411   There is a change to the plugin interface in this version. Plugins that use
412   %renderedfiles will need to be updated, as the hash's values are now arrays
413   of rendered files. Plugins that cause a page to render additional files
414   should use the new will_render function to register the files.
415
416  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
417
418 ikiwiki (1.22) unstable; urgency=low
419   
420   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
421   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
422   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
423   to force a rebuild.
424
425   If you have modified versions of ikiwiki's html templates, you will need
426   to update your templates to link to the stylesheet file using
427   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
428   STYLEURL.
429
430   There have also been some changes to the plugin interface:
431   Any plugins that use santize, htmlize, or format hooks will need to be
432   updated for this version of ikiwiki since these hooks have been changed
433   to use named parameters.
434
435  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
436
437 ikiwiki (1.13) unstable; urgency=low
438
439   The GlobList format which was used for specifiying sets of pages, has been
440   replaced with a new, more expressive PageSpec format. While GlobLists will
441   continue to work, that format is deprecated, and you are encouraged to use
442   PageSpecs from now on, and also to change any GlobLists in your wiki to
443   PageSpecs. See the new PageSpec page for details.
444   
445   You will need to rebuild your wiki when upgrading to this version. If you
446   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
447   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
448   rebuild.
449
450  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
451
452 ikiwiki (1.11) unstable; urgency=low
453
454   Some changes to tags in this release, due to a new tag plugin. If you have
455   been using the meta plugin to tag pages, you'll want to enable the tag
456   plugin too, and change things like this:
457
458   [[meta link="foobar"]]
459
460   To this:
461
462   [[tag foobar]]
463
464   The new tags will appear at page footers, and are also easier to type.
465
466   There have also been some changes to the plugin interface, particularly the
467   interface of pagetemplate hooks has changed. See the changelog for details.
468
469  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
470
471 ikiwiki (1.8) unstable; urgency=low
472
473   If your wiki is configured with a setup file, you should modify it to
474   stop setting the "plugin" list directly, and instead add or remove plugins
475   via the add_plugins and disable_plugins lines. For example, if you had:
476
477         plugin => [qw{inline smiley search}],
478
479   Change it to these lines, which disables the default htmlscrubber plugin
480   and adds the two additional plugins:
481
482         add_plugins => [qw{smiley search}],
483         disable_plugins => [qw{htmlscrubber}],
484
485   Making this change makes your ikiwiki setup file more future-proof since
486   new default plugins will be automatically used.
487   
488   You will need to rebuild your ikiwiki wrappers when upgrading to this
489   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
490   done automatically when the Debian package is upgraded. Or use
491   ikiiki-mass-rebuild --refresh to force a refresh.
492
493  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
494
495 ikiwiki (1.1) unstable; urgency=low
496
497   There have been several configuration changes in this release of ikiwiki:
498
499   The --svn and --no-svn switches are removed, instead you should use
500    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
501   be changed to set rcs => "svn"; if your setup file sets svn => 0
502   then change it to use rcs => "" to disable svn.
503
504   The --hyperestraier switch is gone too. To enable searching, turn on the
505   search plugin, by passing --plugin=search or through the plugin setting in
506   the setup file.
507
508   The --sanitize and --no-sanitize switches are also gone, replaced with the
509   htmlscrubber plugin. This plugin is enabled by default, to disable it,
510   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
511   setup file.
512
513   Discussion pages are enabled by default, but if your wiki is configured
514   with a setup file, you need to edit it to keep them enabled on upgrade
515   to this version. Add a line reading:
516   discussion => 1,
517
518   You will need to rebuild your wiki when upgrading to this version.
519   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
520   automatically when the Debian package is upgraded. Or use
521   ikiiki-mass-rebuild to force a rebuild.
522
523  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400