repost bug: rst plugin has python hardcode in shebang line
[ikiwiki.git] / doc / bugs / rst_plugin_has_python_hardcode_in_shebang_line.mdwn
1 Current the rst plugin uses this shebang line:
2
3    #!/usr/bin/python
4
5 The problem is that rst plugin uses some feature (for example, iterator comprehension) which is unavailable on old version of Python.
6
7 So rst plugin will not work on a machine which has an old version of python in system path even though
8 the user have installed a new version of python in other place.  For example, I am using ikiwiki with the rst plugin on Mac OS X 10.4 which ships python 2.3 but I do have python2.6 installed on /opt/local/bin/python (via macports).
9
10 Thus I suggest to change the shebang line to:
11
12    #!/usr/bin/env python
13