]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* Turn $config{wiki_file_prune_regexps} into an array that is easier to
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.36) UNRELEASED; urgency=low
2
3   * Fix various links on the hyperestradier pages.
4   * Use POST for poll to avoid some robots.
5   * Fix sometimes broken links to Discussion pages from blog pages.
6   * Add userdir config setting.
7   * Fix man page perms in install.
8   * Fix an issue with inlining a page with a rss feed inside another
9     page with an rss feed.
10   * Turn $config{wiki_file_prune_regexps} into an array that is easier to
11     manipulate.
12   * Only exclude rss and atom files from processing if the inline plugin
13     is enabled and that feed type is enabled. Else it's just a copyable file
14     type.
15   * Move rss and atom option handling code into the inline plugin.
16   * Applied a rather old patch from Recai to fix the "pruning is too strict"
17     issue. Now you can have wiki source directories inside dotdirs and the
18     like, if you want.
19
20  -- Joey Hess <joeyh@debian.org>  Thu, 21 Dec 2006 13:54:24 -0500
21
22 ikiwiki (1.35) unstable; urgency=low
23
24   * Fix daemonisation code to only do daemon setup things after forking the
25     child process.
26   * The hack used to make the pagetemplate hook have access to the editpage
27     template won't work with CGI::FormBuilder 3.0401, so disable it for now.
28   * CGI::FormBuilder 3.0401 seems to work ok now with ikiwiki, although
29     there might still be bugs lurking..
30
31  -- Joey Hess <joeyh@debian.org>  Fri,  1 Dec 2006 19:14:36 -0500
32
33 ikiwiki (1.34.2) unstable; urgency=low
34
35   * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
36     ~user/.ikiwiki/wikilist will be read.
37   * Fix url absolution code in inline plugin to support class and id fields in
38     links and imgs, and to support anchor urls.
39   * More build deps updates.
40   * /dev/null fortune failures
41
42  -- Joey Hess <joeyh@debian.org>  Tue, 28 Nov 2006 12:58:47 -0500
43
44 ikiwiki (1.34.1) unstable; urgency=low
45
46   * Add libtime-duration-perl to build deps, as it's used by the svn module
47     which is now tested at build.
48
49  -- Joey Hess <joeyh@debian.org>  Mon, 27 Nov 2006 12:26:12 -0500
50
51 ikiwiki (1.34) unstable; urgency=low
52
53   * Add an openid plugin to support logging in using OpenID.
54   * Web commits by OpenID users will record the full OpenID url for the user,
55     but in recentchanges, these urls will be converted to a simplified display
56     form+link.
57   * Modified svn, git, tla backends to recognise such web commits.
58   * Move httpauth support to a plugin.
59   * Add openidsignup config option.
60   * Make the openid plugin support the callbacks from myopenid.com via its
61     affiliate program.
62   * Add toggle plugin.
63   * Add a poll plugin.
64   * Add quick mode for archive page generation.
65   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
66     many other plugins. It's an easy way to boost ikiwiki from its default,
67     basic wiki, to a full-featured wiki, without manually picking the right
68     set of plugins. New plugins will be added to goodstuff from time to
69     time.
70   * Change how post signin actions are propigated through the signin process;
71     they're now stored in the session.
72   * Add optional "desc" parameter to shortcut definitions.
73   * Avoid locking the wiki at all when handling some basic cgi stuff
74     (searches, recentchanges).
75   * Add "last" parameter to hook function. Very basic ordering, and hopefully
76     nothing more spohisticated will be needed.
77   * Add formbuilder_setup and formbuilder hooks.
78   * Split out a passwordauth module, that holds all the traditional password
79     based authentication etc code. It's enabled by default, but can be disabled
80     if you want only openid or some other auth method.
81   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
82   * Add some code to the build system that tries to determine if the
83     lib installation directory is in @INC. If it's not, munge ikiwiki
84     to hardcode the path to the lib directory. This should allow installing
85     ikiwiki in nonstandard locations, including home directories, by just
86     setting PREFIX at build time.
87   * Fix nested examples directory in deb.
88   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
89   * Add a test suite for the svn backend.
90   * Add a test suite for the git backend, from Recai
91   * Daemonize before sending RPC pings, since that can take a while
92     and/or hang.
93   * Daemonize before sending commit mails, as that can also take a long
94     time/hang if the mail server is unhappy.
95   * Factor out commit mail sending code into new function.
96   * Change rcs_commit, it is now passed the name of the user doing the commit
97     and their IP address, and needs to construct its own commit message
98     containing them, or do something more appropriate for the given RCS.
99   * Add softwaresite example.
100   * Mercurial backend improvements, including --get-ctime support. (Emanuele
101     Aina)
102   * Git backend improvements, including bug fixes and better robustness,
103     from Recai.
104
105  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 20:46:56 -0500
106
107 ikiwiki (1.33) unstable; urgency=low
108
109   * Fix issue with aggregate plugin updating expired pages.
110   * Avoid syntax errors in templates used by the template plugin crashing
111     ikiwiki.
112   * Enable utf8 file IO in aggregate plugin.
113   * Fix some issues with the new registration form.
114   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
115   * Make sure to check for errors from every eval.
116   * Fix img plugin's handling of adding dependencies for images that do not
117     yet exist.
118   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
119     FORM-SUBMIT unusable on customised formbuilder templates. For now,
120     hardcode the submit buttons in editpage.tmpl instead of using the
121     template variable, which is ok, since the buttons are static.
122   * Work with hyperestraier 1.4.9.
123
124  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
125
126 ikiwiki (1.32) unstable; urgency=low
127
128   * Add a separate pass to find page links, and only render each page once,
129     instead of over and over. Typical speedup is ~4x. Max possible speedup:
130     8x.
131   * Add "scan" parameter to hook(), which is used to make the hook be called
132     during the scanning pass, as well as the render pass. The meta and tag
133     plugins need to use the new scan parameter, so will any others that modify
134     %links.
135   * Now that links are calculated in a separate pass, it can also
136     precalculate backlinks in one pass, which is O(N^2) instead of the
137     previous code that was O(N^3). A very nice speedup for wikis with lots
138     (thousands) of pages.
139   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
140     Erdem.
141   * Add a default stylesheet entry for the pagecloud.
142   * Add examples page with some examples of things that can be done using
143     ikiwiki, like a weblog. The examples can be copied into a user's wiki
144     for a quick start, without needing to learn everything about how to put
145     them together.
146   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
147   * Add perlmagick to build-depends so syntax check of img plugin works.
148     Closes: #396702
149   * Improve login/register process, the login dialog has only name and
150     password fields, which allows more web browsers to regognise it as a login
151     field, and is less confusing.
152   * Implemented expiry options for aggregate plugin.
153   * Use precalculated backlinks info when determining if files need an update
154     due to a page they link to being added/removed. Mostly significant if
155     there are lots of pages.
156   * Remove duplicate link info when saving index. In some cases it could
157     pile up rather badly. (Probably not the best way to deal with this
158     problem.)
159   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
160     or what have you, by creating enclosures for non-page items that are
161     included in feeds.
162
163  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
164
165 ikiwiki (1.31) unstable; urgency=low
166
167   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
168   * Change the rss feed title from the wikiname to the page title, with
169     an exception for the wiki's toplevel index page, which will still use the
170     wikiname as the feed title.
171     Overriding the page title with meta title already overrode the rss feed
172     tittle.
173   * Add an img plugin, based on Christian Mock's img plugin, but stripped
174     down to the bare essentials. Useful for handling large images on websites.
175   * Sanitize possibly problimatic characters out of the polygen grammar names,
176     just in case. Should not be exploitable anyway, since it only tries to run
177     polygen after finding the specified grammar file.
178   * Add missing dependency on the URI perl module.
179   * Add basic spam fighting tool for admins: An admin's prefs page now allows
180     editing a list of banned users.
181
182  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
183
184 ikiwiki (1.30) unstable; urgency=low
185
186   * Add no_override parameter to hook().
187   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
188     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
189     can be configured using a page in wiki.
190   * Fix support for --pingurl at the command line.
191   * Fix a subtle bug in will_render that broke some builds, by only clearing
192     items from renderedfiles the first time per build.
193   * Wrap entire technortati ping operation in an eval to catch all possible
194     failure modes, after I observed a simple ->value crashing ikiwiki when
195     a ping failed.
196
197  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
198
199 ikiwiki (1.29) unstable; urgency=low
200
201   * Patch from Paul Tötterman to use CP in the Makefile.
202   * Patch from Alec Berryman adding a http_auth config item that allows
203     using HTTP Authentication instead of ikiwiki's built in authentication.
204     Useful for eg, large sites with their own previously existing user auth
205     setup. Closes: #384534
206   * Change %renderedfiles to store an array of files rendered from a given
207     source file, to allow tracking of extra rendered files like rss feeds.
208   * Note that plugins that accessed this variable will need to be updated!
209     The plugin interface has been increased to version 1.01 for this change.
210     As few plugins use %renderedfiles I haven't done anything else to ensure
211     compatability of old plugins.
212   * Add will_render function to the plugin interface, used to register that a
213     page renders a destination file, and do some security checks. Previously
214     but no longer rendered files will be cleaned up.
215   * Use will_render in the inline and linkmap plugins.
216   * You will need to rebuild your wiki on upgrade to this version.
217   * Atom feed support based on a patch by Clint Adams.
218   * Add feeds=no option to inline preprocessor directive to turn off all types
219     of feeds.
220   * $IkiWiki::version now holds the program version, and is accessible to
221     plugins.
222   * Make the aggregate plugin emphasize error messages.
223   * Patch from Recai to limit recentchanges to displaying max 10 files for a
224     given changeset (to avoid large number of file changes excessively
225     bloating the page).
226
227  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
228
229 ikiwiki (1.28) unstable; urgency=low
230
231   * inline: Add ability to sort by page name, based on a patch from
232     Benjamin A'Lee.
233   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
234     braindead interface. Closes: #389383
235   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
236     and b) those poor Mac OSX users and their case insensative files!
237   * Don't fail syntax check if Text::Typography isn't installed.
238     Closes: #389406
239
240  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
241
242 ikiwiki (1.27) unstable; urgency=low
243
244   * Work on firming up the plugin interface:
245     - Plugins should not need to load IkiWiki::Render to get commonly
246       used functions, so moved some functions from there to IkiWiki.
247     - Picked out the set of functions and variables that most plugins
248       use, documented them, and made IkiWiki export them by default,
249       like a proper perl module should.
250     - Use the other functions at your own risk.
251     - This is not quite complete, I still have to decide whether to
252       export some other things.
253   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
254     referring to stuff now exported by the IkiWiki module.
255   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
256     to declare which version of the interface your plugin needs.
257   * Anyone with a third-party ikiwiki plugin is strongly encouraged
258     to make like changes to it and avoid use of non-exported symbols from
259     "IkiWiki::".
260   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
261   * Support hyperestradier version 1.4.2, which adds a new required phraseform
262     setting.
263   * If an inlined page has a permalink, link the page title to that.
264   * Patch from Recai to use utf8 when reading the setup file, so that
265     utf8 wikinames from there will be used properly.
266   * Patch from Recai to kill utf-8 on the wiki name when generating the
267     session cookie.
268   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
269   * Fix a baseurl problem in hyperestradier search results.
270   * Add a stub local.css to avoid problems with 404's.
271   * Patch from Recai to fix a wide character warning from the search plugin
272     during setup if the wikiname contains utf8.
273   * Yet another fix for those poor case-insensative OS X users.
274   * pagetemplate hooks are now also called when generating cgi pages.
275   * Add a favicon plugin, which simply adds a link tag for an icon to each
276     page (and cgis).
277   * Patch from James Westby to deal with the case where you're editing a
278     new page, hit cancel, and need to be redirected to somewhere sane.
279   * Various documentation improvements by various wiki users.
280   * Support Text::Markdown from CPAN, which has a different interface from
281     the original markdown or the one in Debian.
282   * Version the libcgi-session-perl dependency, some features that need
283     the new version are used in some cases (sslcookie).
284   * Numerous tla fixes from Clint.
285   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
286     a multi-resolution favicon.ico.
287   * README.Debian: typo Closes: #388110
288   * chomp trailing newline at the end of templates read in by the template
289     plugin, to allow use of the template preprocessor directive in
290     whitespace-sensative situations. Closes: #387073
291   * Patch from James Westby to make the location of the estseek.cgi script
292     configurable.
293   * Add typography (SmartyPants) plugin by Recai.
294   * Add --render mode, which can be used to preview an edit at the command
295     line by test rendering a single page.
296   * Add a googlecalendar plugin. A bit special-purpose, but it shows
297     one way to to deal with user-supplied content that could cause XSS
298     issues w/o the htmlscrubber, and won't survive the scrubber.
299
300  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
301
302 ikiwiki (1.26) unstable; urgency=low
303
304   * Add a missing -n to tla undo call.
305   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
306     writes before consuming its whole stdin. Avoid this deadlock.
307   * Fix alt tags for outline checkboxes.
308
309  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
310
311 ikiwiki (1.25) unstable; urgency=low
312
313   * Add proper waitpid calls for open2ed processes throughout to avoid
314     zombies; this hit htmltidy especially badly.
315   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
316     subversion repos and fixing some other issues.
317   * Add support for tla, contributed by Clint Adams. Closes: #385936
318   * Add support for mercurial, contributed by Emanuele Aina.
319   * Include <link rel> tag for RSS feeds, used by some aggregators and
320     firefox to find the feed.
321   * Add a linkmap plugin (requires graphviz).
322
323  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
324
325 ikiwiki (1.24) unstable; urgency=low
326
327   * Simplify the data structure returned by rcs_recentchanges to avoid
328     each rcs plugin needing to form complex strings on its own.
329   * Fix another destpage issue in the inline directive. Closes: #385512
330     again.
331
332  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
333
334 ikiwiki (1.23) unstable; urgency=low
335
336   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
337
338  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
339
340 ikiwiki (1.22) unstable; urgency=low
341
342   * Change how the stylesheet url is determined in the templates: Remove
343     STYLEURL and add BASEURL to all templates (some already had it). This
344     new more general variable can be used to link to other things (eg, images)
345     from the template, as well as stylesheets.
346   * Fix a bug introduced last version to do with nested inlines.
347   * Allow preprocessor directives to span multiple lines, both to make
348     long ones with lots of values easier to write, and to allow for ones with
349     multi-line quoted values.
350   * Allow preprocessor directives to contain python-like triple-quoted
351     text blocks, for easy nesting of quotes inside.
352   * Add a template plugin.
353   * Make pagespec merge code smarter about merging duplicate pagespecs.
354   * Patch from Jordà Polo to make Setup::Standard support hashes in config
355     files.
356   * Change order of linkify and preprocess; first preprocess and then linkify.
357     This allows passing a wikilink inside a parameter to a preprocessor
358     directive without it being expanded to html, and leaking out of the
359     parameter, which had required some non-obvious use of triple-quoting
360     to avoid. Note that any preprocessor plugins that output something
361     that looks like a wikilink will now have it treated as such; AFAIK
362     this doesn't change any behavior though except for the template plugin.
363   * Enable preprocessor directives when previewing an edit.
364   * Make all pages pull in a local.css style sheet, if present. This won't
365     be included in ikiwiki, but can be created to make local styling changes
366     w/o needing to merge in every new change to the distributed style.css.
367   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
368   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
369     from a different directory.
370   * Generalised preprocesser loop protection code.
371   * Patch from James Westby to allow a description to be set for rss feeds.
372   * Patch from James Westby to add a template for the search form.
373   * Added a ddate plugin.
374   * Patch from James Westby to add a --sslcookie switch, which forces
375     cookies to only be sent over ssl connections to avoid interception.
376   * Fix preferences page on anonok wikis; still need to sign in to get
377     to the preferences page.
378   * Add toc (table of contents) plugin.
379   * Change htmlize, format, and sanitize hooks to use named parameters.
380   * Patch from James Westby to add an actions option to inline; this
381     adds Edit and Discussion links at the end of blog entries.
382   * Due to some css changes, you'll want to rebuild your wiki on upgrade
383     to this version. Will be handled automatically by the deb.
384   * Add processed date to aggregate preprocessor directive status output.
385
386  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
387
388 ikiwiki (1.21) unstable; urgency=low
389
390   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
391   * If a page links to itself, mark up the link text in a span with
392     class="selflink" so that it can be styled. I don't have a useful style
393     defined for that though.
394   * Call filter hooks on inlined page content.
395   * Support inlining pages raw, rather than creating a blog.
396   * Clean up yes/no parameter parsing in inline plugin.
397   * Implemented better cycle detection in the inline plugin; nested inlines
398     will now work.
399   * Add a map plugin contributed by Alessandro Dotti Contra.
400   * Add otl format plugin, which handles files as created by vimoutliner.
401   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
402   * Add first draft at a Restructured Text (rst) plugin, by Sergio
403     Talens-Oliag. Note that this has many known issues -- see the caveats on
404     the plugin's page.
405   * Credit everyone who wrote a plugin on the plugins' wiki pages.
406   * Fix utf-8 in blog post form.
407
408  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
409
410 ikiwiki (1.20) unstable; urgency=low
411
412   * Relicense the templates and basewiki under the 2-clause BSD license.
413     Since these can easily become part of other people's websites, they
414     should be under as permissive a license as possible.
415   * Add --syslog config option, to log to the syslog.
416   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
417     transient failure to fork (which I've seen happen in the wild).
418   * Fix a bug in the aggregator introduced last version that caused all
419     aggregator state to be lost during a non-aggregating build.
420
421  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
422
423 ikiwiki (1.19) unstable; urgency=low
424
425   * Fix several related bugs in page type determination during online editing.
426   * Add some locking to prevent 2 aggregators from running at once.
427   * Fix an infinite loop in the aggregator when finding a unique filename.
428
429  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
430
431 ikiwiki (1.18) unstable; urgency=low
432
433   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
434   * Add --version.
435   * Man page format fixups.
436   * If the meta plugin overides the page title, set a title_overridden
437     variable in the template to true. This allows doing things with the
438     templates conditional on the title being overriden.
439   * Add a %pagecase which maps lower-case page names to the actual case
440     used in the filename. Use this in bestlinks calculation instead of
441     forcing the link to lowercase.
442   * Also use %pagecase in various other places that want to check if a page
443     with a given name exists.
444   * This means that links to pages with mixed case names will now work,
445     even if the link is in some other case mixture, and mixed case pages
446     should be fully supported throughout ikiwiki.
447   * Recommend rebuilding wikis on upgrade to this version.
448
449  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
450
451 ikiwiki (1.17) unstable; urgency=low
452
453   * Disable tidy generator tag.
454   * Move tidy back to sanitize hook, found out how to only show body.
455   * Turn off tidy indentation too.
456   * Turn on HTML::Template loop_context_vars; not actually used in stock
457     templates but can be useful for things like making comma-delimited lists
458     of tags or what have you.
459   * Remove <br> from end of aggregate preprocessor directive output.
460   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
461     case-sensative filesystems like OSX.
462   * Improve markdown loading. First, try to load it as a proper perl module,
463     in case it was installed as one. Then fall back to trying
464     /usr/bin/markdown.
465   * Document in install page how to install markdown, since it has no
466     installation procedure in the upstream tarball.
467   * Set die_on_bad_params => 0 for all templates, to allow users to modify
468     them without annoyances.
469   * Suck in the page content when generating an inline archive page, to work
470     around the meta plugin's lack of caching of title metadata across runs.
471
472  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
473
474 ikiwiki (1.16) unstable; urgency=low
475
476   * Try to handle relative links in aggregated feeds. However,
477     the current support is a crude hack due to limitations of XML::Feed:
478     xml:base is not supported, neither is Content-Location. And of course,
479     relative links in RSS feeds are ill-undefined..
480   * Make aggregator save permalinks and author name to pages as metadata.
481   * Add permalink and author support to meta plugin, affecting RSS feeds
482     and blog pages.
483   * Various CSS and formatting changes.
484   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
485   * Add xhtml files to the default prune regexp.
486   * Also generate rel=bookmark links for permalinks.
487   * Fix the htmltidy plugin, which wasn't working due my breaking it when
488     I added it..
489   * Don't run tidy with -xml as that fails if the input is not well-formed.
490     Run it with -asxhtml instead, so it will output well-formed xhtml no
491     matter what the input.
492   * Disable tidy warnings too.
493   * Add a new format hook, and make tidy use it, since tidy can really only
494     operate on and output complete html documents, not the body chunks
495     that sanitise gets.
496   * Fix dates in rss feeds if running localised, so they're still rfc 822.
497
498  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
499
500 ikiwiki (1.15) unstable; urgency=low
501
502   * Remove CDPATH and other env vars perl taint checking doesn't like.
503     Closes: #381279
504   * Added created_before and created_after PageSpec limits.
505
506  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
507
508 ikiwiki (1.14) unstable; urgency=low
509
510   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
511     by 10% or so.
512   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
513   * Added many unit tests for pagespec_match.
514
515  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
516
517 ikiwiki (1.13) unstable; urgency=low
518
519   * ikiwiki can now download and aggregate feeds with its new aggregate
520     plugin, so it's possible to implement a Planet using ikiwiki!
521   * Add a run_hooks function for the common task of running all hooks of a
522     given type.
523   * Add a savestate hook.
524   * Don't put blog post forms on pages if there's no cgiurl set.
525   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
526     --wrappers to do that.
527   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
528     to update pages that haven't changed on disk.
529   * Change meta tags to use html entity-escaped text for values, so that
530     quotes and such can be represented in title tags.
531   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
532     for the above.
533   * Make --rebuild also cause --aggregate to re-download and write aggregated
534     pages.
535   * Avoid outputting duplicate meta info.
536   * Include title metadata on aggregated posts for capitalised and un-munged
537     titles.
538   * Title metadata of inlined pages now shows up in blogs and rss feeds.
539   * Fix issue with unicode filenames and updating the hyper estradier search
540     index. (Aka Please Please Please, let that be the last one.)
541   * Patch from Roland Mas to support an rss=no parameter to inline directives.
542     Closes: #380743
543   * Renamed GlobLists to PageSpecs.
544   * PageSpecs can now include nested parens, "and", and "or". This remains
545     backwards compatible to the old GlobList format. It's implemented by
546     treating the GlobList as a very limited microlanguage that is transformed
547     to perl code that does the matching.
548   * The old GlobList format is deprecated, and I encourage users to switch to
549     using the new PageSpec format. Compatability with the old format will be
550     removed at some point, possibly by 2.0.
551   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
552   * Add support for creation_month and creation_year to PageSpec.
553     Closes: #380680
554   * Changes to index file encoding.
555
556  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
557
558 ikiwiki (1.12) unstable; urgency=low
559
560   "Viva l'Italia!"
561   * New pagestats plugin from Enrico, which can generate a table counting
562     the backlinks for each page, or a del.icio.us style cloud.
563   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
564     the wikiformat plugin works. Thanks, Emanuele Aina.
565   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
566     display, running them through pagetitle. This removes ugly underscores and
567     other gunk from the display, much nicer. You may want to rebuild your wiki
568     when upgrading to get the cleanup globally.
569   * Polygen plugin from Enrico.
570   * htmltidy plugin from Faidon.
571   * Locale patch from Faidon:
572     - Adds a locale setting to setup files.
573     - Proper local time, if the locale configuration option is used.
574     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
575       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
576       impossible.
577   * Add getopt hook type, this allows plugins to add new command-line options.
578   * Add --tagbase option to tag plugin.
579   * Add exclude option in setup files, works same as --exclude.
580   * Put categories in rss feeds for tagged items.
581   * Allow preprocessor directives to be expanded in inlined blog pages.
582     However, to avoid inlining loops etc, don't expand inline directives in
583     inlined pages.
584   * fortune plugin (trivial)
585   * Tag plugins according to type.
586
587  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
588
589 ikiwiki (1.11) unstable; urgency=low
590
591   * Patch from Enrico that
592     - Adds a tag plugin that allows more easily tagging pages.
593       The meta plugin can also still be used for that, but the tag plugin
594       also lists a page's tags at the bottom of the page.
595     - Allows preprocessor directives to have parameters with no specified
596       value.
597     - Fixes preprocessor directive parameter parsing so that
598       foo=bar baz now means "foo=bar" and a "baz" with no value.
599   * Run pagetemplate hooks when inlining pages so that inlined pages also
600     list their tags.
601   * Make all plugins with pagetemplate hooks check that variables exist
602     on the template before setting them, for robustness.
603   * Switch pagetemplate hooks to using named parameters.
604   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
605     This will be the page that a source page will be part of, which is
606     different than the source page for inlined pages.
607   * Audited all plugins to endure they pass (page, destpage) to htmllink
608     appropriatly. This means inlining of various plugins will not work
609     properly, with correct links generated.
610
611  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
612
613 ikiwiki (1.10) unstable; urgency=low
614
615   * Run page through any relevant filters when generating a page preview.
616   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
617     default throughout the wiki, not only on wikitext pages. Decided to call
618     this a feature, and split the camelcase support out into a separate plugin
619     that is independant of wikitext.
620   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
621
622  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
623
624 ikiwiki (1.9) unstable; urgency=low
625
626   * Improve display of parentlinks and page title of toplevel index page.
627   * Patch from Faidon to use svn --limit when possible for recentchanges,
628     speeds up recentchanges a lot for wikis with more history.
629   * Patch from Recai to fix utf8 issues in git backend.
630   * Add wikitext markup plugin, which supports ".wiki" pages written in the
631     original wiki syntax, CamelCase links and all.
632   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
633     support, to edit pages etc without a web server.
634   * Display CGI processing errors if present.
635   * Fix from Faidon for a XML parser issue that breaks utf-8 for
636     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
637     area, and also way slow.
638   * Match 'web commit from' in SVN and git, these are web commits too.
639     (Faidon)
640   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
641     readable and avoid future mistakes. The patch seems to work and for the
642     first time I have a UTF-8 username ;-) (Faidon)
643   * Use form->field consistently, not form->param.
644   * Patch from Recai to allow selection of page type when creating a new page.
645     Default page type is inherited from the link clicked on to create the new
646     page.
647
648  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
649
650 ikiwiki (1.8) unstable; urgency=low
651
652   * Fix orphans plugin to not count a link to a nonexistant page as a reason
653     for a page not being an orphan.
654   * Support pinging services such as Technorati using XML-RPC to notify them
655     about changes to rss feeds.
656   * Parse svn log as xml for improved utf8 and security. Note that this makes
657     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
658   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
659     flagged string even if the locale causes it to generate utf8 output,
660     so make sure to let perl know it should be handled as utf8. Also,
661     the optimised version used for standard time formats won't work if the
662     user has changed locale, so drop it. Thanks, Faidon Liambotis.
663   * Fix re-encoding of the comments field to utf8 if a commit fails
664     due to a conflict. Thanks, Faidon Liambotis.
665   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
666     Liambotis.
667   * Add insane double encode/decode to utf8 around call to markdown.
668     This works around a truely strange bug, which is apparently a bug in
669     perl, #376329. Also added a test case for it.
670   * Improve layout of edit page so formatting help link is always visible w/o
671     getting in the way of the preview.
672   * Centralised all calls to HTML::Template and force all the templates
673     to be read as utf8.
674   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
675   * Introduce add_plugins and disable_plugins config options in setup files.
676     This allows adding or removing plugins w/o overriding the whole list of
677     default plugins, which makes it easier to upgrade when new default plugins
678     are added.
679   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
680     default (of course!). Based on a patch by Faidon Liambotis.
681   * Add a html plugin, which can be used to write wikis in raw html,
682     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
683     defaults to not processing .html files, since w/o this plugin they would
684     be copied unsanitised. With this plugin, it will process and html
685     sanitise them, like any other page type.
686   * Rebuilding wrappers is necessary on upgrade to this version.
687   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
688     will be automatically done on all upgrades.
689   * Don't send pings if the wiki is being rebuilt.
690   * Work around very innefficient behavior in File::Spec::abs2rel. Result
691     is a savings of 2 pointless fork/execs per link calculation, which
692     results in ~25% speedup of ikiwiki building its own doc wiki, and
693     about 35% speedup displaying RecentChanges!
694   * Make RecentChanges use a table and some CSS, should be much more readable.
695     No code changes involved.
696   * Encode & in diffurl in examples, to conform to pedantic rules.
697   * Speed up RecentChanges by another 40% or so with some memoization.
698   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
699     in time to build the doc wiki.
700
701  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
702
703 ikiwiki (1.7) unstable; urgency=low
704
705   * Updated logo from Recai with some kerning and alingment tuning.
706   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
707     changed some output.
708   * Copyright update.
709
710  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
711
712 ikiwiki (1.6) unstable; urgency=low
713
714   * YA utf-8 patch from Recai, this time to fix previewing a page so that
715     the text in the input box is re-encoded back to utf-8.
716   * -CSD does not affect modules, so readfile() was not using the utf-8 input
717     layer, which led to lots of problems; make it force read files as utf-8.
718     Closes: #373203
719   * Note that as a consequence, this version of ikiwiki will actually try to
720     parse utf8 in source files for the first time, which may expose broken
721     utf8 in wiki sources that was hidden before. Most common will be
722     perl warnings like "utf8 "\xE9" does not map to Unicode"
723   * writefile() likewise needs to use the utf8 output layer.
724   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
725     there.
726   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
727     given the readfile fix.
728   * Add utf-8 testcases for readfile and htmlize.
729   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
730     safe.
731   * More utf-8 fixes from Recai, partly to things I broke above:
732     - The serious problem is that writefile() saves the content in undecoded
733       format in CGI, hence all (non-ascii) chars are corrupted permanently.
734     - Comment field in edit page is not decoded and all the non-ascii chars in
735       this field are corrupted as the result.  We should decode it as we do it
736       for the content.
737     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
738       character in print.
739   * New SVG logo from Recai.
740
741  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
742
743 ikiwiki (1.5) unstable; urgency=low
744
745   * Add --timeformat config option to allow changing how dates are displayed.
746     Note that as a side effect, dates will now be displayed using the local
747     timezone, not as GMT.
748   * More security review.
749   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
750     for some handy stuff like:
751     - Using links as a kind of tag; creating blog pages that list all pages
752       containing a given tag/link or not containing some other tag.
753     - Subscribing to mail notifications whenever a change is made to a page
754       that is a backlink of page foo. Ie, "Please notify me of changes in all
755       pages that link to my home page in the wiki"
756     - Locking any pages that are linked to from a particular page, so that
757       lists of locks can be exposed in the wiki.
758   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
759     when a todo item is done, instead of the previous moving it to a different
760     subdir.
761   * Allow pagetemplate plugins to override *anything* in the template.
762   * Add a meta plugin, which allows specifying various metadata about pages,
763     like license and author. It also allows for inserting html link and meta
764     tags into html, overriding the title, and adding hidden WikiLinks, which
765     can be useful when using link-based globbing for page categorisation.
766   * Remove preprocessor directives from inlined pages.
767   * Allow simple preprocessor directive values to be specified w/o quotes.
768   * Add support for using git instead of subversion as the RCS backend,
769     tremendous thanks to Recai Oktaş for this.
770   * Doc updates for git.
771   * Fix absolute url munging in rss generation to support https, ftp, etc urls
772     not just http urls.
773   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
774     utf-8 for edit and other fields, and for recentchanges. There may still
775     be utf-8 issues with the preferences page though.
776
777  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
778
779 ikiwiki (1.4) unstable; urgency=low
780
781   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
782     very strange way of enabling proper XHTML <br /> type tags. Output html
783     should be always valid again now.
784   * The page name and parent links has switched from using a <h1> to a styled
785     <span>, so pages can use <h1> internally instead of needing to use <h2>.
786   * Updated all of ikiwiki's own wiki pages for that.
787   * Add pagetemplate hook, which can be used by plugins that want to mess
788     around with adding new stuff to the page template.
789   * Remove headercontent; the search plugin now adds the search box to the
790     header by registering a pagetemplate hook, and other plugins should do
791     similarly.
792   * Rebuilding on upgrade to this version is recommended.
793   * Add a html validity check to the test suite, using the wdg-html-validator,
794     if available.
795   * Make the html valid when there is nothing in the actions list.
796   * Reordered some function call parameters for consistency.
797   * Enable full utf-8 support for page input and output.
798   * Add a workaround for markdown, which does not work well with utf-8
799     strings.
800   * --getctime had bitrotted (well I only ever used it the once so far..),
801     fix and make it a bit more flexible
802   * rcs_getctime is changed, now rather than needing to loop over all pages,
803     it should just use the rcs to get the ctime of the passed file.
804   * When inlining a page in another one, links from the inlined page are now
805     expanded the same as they are when rendering the inlined page as a
806     standalone page. So rather than being expanded from the POV of the
807     inlining page, they are expanded from the POV of the inlined page.
808
809     For example, a link from blog/foo to "bar" will now link to blog/bar
810     if it exists. Previously this needed to be a link explicitly to
811     "blog/bar"; such links will also continue to work.
812
813     (This was slightly complex to do as the link still has to be constructed
814     relative to the inlining page.)
815   * Make page edit textarea resize to fit browser window.
816   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
817     do not need a full rebuild, in order to update any basewiki pages.
818
819  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
820
821 ikiwiki (1.3) unstable; urgency=low
822
823   * Fix the preinst introduced in the last version. Closes: #367458
824
825  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
826
827 ikiwiki (1.2) unstable; urgency=low
828
829   * Remove dups from the brokenlinks list.
830   * Add libc6-dev to dependencies, needed to build wrappers.
831   * Install wikilist in correct location. Closes: #367371
832
833  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
834
835 ikiwiki (1.1) unstable; urgency=low
836
837   * Rename inlinepage to depends, so that it can be used to refer to more
838     dependency relationships than just inlining. This will require a rebuild
839     on upgrade to this version.
840   * Move the rss link, put it in the blogpost form if there is one and at the
841     top if not. This is both nicer because easier to find, and it cleans up
842     the code which had used inlinepage as a flag for adding the link later.
843   * Allow the depends GlobList to be built up from multiple sources (such as
844     plugins) during a page render.
845   * Which means that more than one blog is now supported to appear on a
846     single page. (With some limitations, like only the last one getting an
847     rss file.)
848   * Added a plugin system.
849   * Added a pagecount plugin, enabled by default.
850   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
851   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
852     backlinks when the backlinks hadn't really changed.
853   * Moved inline page support, rss generation etc into the inline plugin,
854     enabled by default.
855   * Added brokenlinks plugin, not enabled by default, but rather handy.
856   * Fix several broken links in the doc wiki.
857   * Smarter behavior when creating a page and a page of the same name (but
858     different location) already exists.
859   * Add an orphans plugin for finding pages that nothing links to.
860   * Removed backlinks page, which it turns out nothing used.
861   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
862     it, this will allow for adding a unit test suite.
863   * Add unit tests for several core functions, including globlist_match,
864     dirname, basename, bestlink, linkify, pagetitle, titlepage.
865   * Smart globlist merging.
866   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
867     to pave the way for adding other RCS support. This also changes the
868     setup files, where before they had svn => 1 or svn => 0, now they have
869     rcs => "svn" or rcs => "".
870   * Add a debian/NEWS file with upgrade notes.
871   * Load whatever rcs module is specified, so new ones can be just dropped in
872     as plugins and work. (Well, in theory.)
873   * Add some basic docs about writing RCS modules.
874   * Broke search capability out into a plugin, removed the --hyperestraier
875     switch.
876   * Added smiley plugin, nicely controlled and documented by the smileys page.
877   * Copied in some smileys from Moin Moin.
878   * Allow links of the form [[some page|page]], with whitespace in the link
879     text.
880   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
881     and --disable-plugin htmlscrubber.
882   * Allow discussion links on pages to be turned off with --no-discussion.
883   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
884   * Add some new config items to the estseek.conf template, which are needed
885     by hyperestraier 1.2.3.
886
887  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
888
889 ikiwiki (1.0) unstable; urgency=low
890
891   * First official release.
892
893  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400