theme: Now <TMPL_IF THEME_$NAME> can be used in all templates when a theme is enabled.
[ikiwiki.git] / debian / NEWS
1 ikiwiki (3.20110122) unstable; urgency=low
2
3   If you have custom CSS that uses "#feedlinks" or "#blogform", you will
4   need to change it to instead use ".feedlinks" and ".blogform"
5
6  -- Joey Hess <joeyh@debian.org>  Fri, 14 Jan 2011 14:34:54 -0400
7
8 ikiwiki (3.20100515) unstable; urgency=low
9
10   There are two significant changes to the page.tmpl template in this version.
11   If you have a locally modified version of that template, you will need to
12   update it at least to contain the following in the HTML <head>:
13
14     <TMPL_IF DYNAMIC>
15     <TMPL_IF FORCEBASEURL><base href="<TMPL_VAR FORCEBASEURL>" /><TMPL_ELSE>
16     <TMPL_IF BASEURL><base href="<TMPL_VAR BASEURL>" /></TMPL_IF>
17     </TMPL_IF>
18     </TMPL_IF>
19
20   Also, the footer should be wrapped in <TMPL_UNLESS DYNAMIC> ... </TMPL_UNLESS>
21   
22   There is a new "comment()" pagespec, that can be used to match a
23   comment on a page. It is recommended it be used instead of the old
24   method of using a pagespec such as "internal(comment_*)" to match
25   things that looked like comments. The old pagespec will now also match
26   comments that are held for moderation; likely not what you want.
27
28   There have also been some changes to the style.css in this version,
29   particularly to support the new openid selector. If you have a modified
30   version, of style.css, updating it (or moving it to local.css) is
31   recommended.
32
33  -- Joey Hess <joeyh@debian.org>  Wed, 05 May 2010 21:47:08 -0400
34
35 ikiwiki (3.20100427) unstable; urgency=low
36
37   This version of ikiwiki has a lot of changes that you need to know about.
38
39   Now you can include customised versions of templates in the source
40   of your wiki. (For example, templates/page.tmpl.) When these templates
41   are changed, ikiwiki will automatically rebuild pages that use them.
42
43   Allowing untrusted users to upload attachments with the ".tmpl"
44   extension is not recommended, as that allows anyone to change
45   a wiki's templates.
46
47   The --getctime switch is renamed to --gettime, and it also gets the 
48   file modification time. And it's a lot faster (when using git). But
49   the really important change is, you don't have to remember to use this
50   switch. Now ikiwiki will do it when it needs to.
51
52   At last, the "tagged()" pagespec only matches tags, not regular wikilinks.
53   If your wiki accidentially relied on the old, buggy behavior, you might
54   need to change its pagespecs to use "link()".
55
56   Many of your wishes have been answered: Now tag pages can automatically be
57   created when new tags are used. This feature is enabled by default if you
58   have configured a tagbase. It can be turned on or off using the
59   tag_autocreate setting.
60
61   These changes may also affect some users:
62
63   * The title_natural sort method (as used by the inline directive, etc)
64     has been moved to the new sortnaturally plugin, which is not enabled
65     by default since it requires the Sort::Naturally perl module.
66
67   * The add_templates option has been removed from the underlay plugin.
68     If you used this option, you can instead use templates/ subdirectories
69     inside underlay directories added by the add_underlays option.
70
71   Due to the above and other changes, all wikis need to be rebuilt on
72   upgrade to this version. If you listed your wiki in /etc/ikiwiki/wikilist
73   this will be done automatically when the Debian package is upgraded. Or
74   use ikiwiki-mass-rebuild to force a rebuild.
75
76  -- Joey Hess <joeyh@debian.org>  Tue, 27 Apr 2010 00:00:00 -0400
77
78 ikiwiki (3.20091017) unstable; urgency=low
79
80   To take advantage of significant performance improvements, all
81   wikis need to be rebuilt on upgrade to this version. If you
82   listed your wiki in /etc/ikiwiki/wikilist this will be done
83   automatically when the Debian package is upgraded. Or use
84   ikiwiki-mass-rebuild to force a rebuild.
85
86  -- Joey Hess <joeyh@debian.org>  Mon, 05 Oct 2009 16:48:59 -0400
87
88 ikiwiki (3.1415926) unstable; urgency=low
89
90   In order to fix a performance bug, all wikis need to be rebuilt on
91   upgrade to this version. If you listed your wiki in
92   /etc/ikiwiki/wikilist this will be done automatically when the
93   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force
94   a rebuild.
95
96  -- Joey Hess <joeyh@debian.org>  Tue, 25 Aug 2009 17:24:43 -0400
97
98 ikiwiki (3.13) unstable; urgency=low
99
100   The `ikiwiki-transition deduplinks` command introduced in the
101   last release was buggy. If you followed the NEWS file instructions
102   and ran it, you should run `ikiwiki -setup` to rebuild your wiki
103   to fix the problem.
104
105  -- Joey Hess <joeyh@debian.org>  Fri, 22 May 2009 13:04:02 -0400
106
107 ikiwiki (3.12) unstable; urgency=low
108
109   You may want to run `ikiwiki-transition deduplinks your.setup`
110   after upgrading to this version of ikiwiki. This command will
111   optimise your wiki's saved state, removing duplicate information
112   that can slow ikiwiki down.
113
114  -- Joey Hess <joeyh@debian.org>  Wed, 06 May 2009 00:25:06 -0400
115
116 ikiwiki (3.01) unstable; urgency=low
117
118   If your wiki uses git, and you have a `diffurl` configured in
119   its setup file, you should be aware that gitweb has stopped
120   supporting the url form commonly used for the `diffurl`.
121
122   You can change your setup to use the newer gitweb url form:
123
124     http://git.example.com/gitweb.cgi?p=wiki.git;a=blobdiff;f=[[file]];h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_commit]];hpb=[[sha1_parent]]
125
126   The changes from the old form are the addition of the `hpb` parameter,
127   and the change to the value used for the `hb` parameter.
128
129  -- Joey Hess <joeyh@debian.org>  Mon, 05 Jan 2009 18:18:05 -0500
130
131 ikiwiki (3.00) unstable; urgency=low
132
133   The 3.0 release of ikiwiki changes several defaults and finishes
134   some transitions. You will need to modify your wikis to work with
135   ikiwiki 3.0. A document explaining the process is available
136   in </usr/share/doc/ikiwiki/html/tips/upgrade_to_3.0.html>
137
138  -- Joey Hess <joeyh@debian.org>  Tue, 23 Dec 2008 16:14:18 -0500
139
140 ikiwiki (2.62) unstable; urgency=low
141
142   TexImg standard preamble changed
143
144   The teximg plugin now has a configurable LaTeX preamble.
145   As part of this change the `mchem` LaTeX package has been removed from
146   the default LaTeX preamble as it wasn't included in many TeX installations.
147
148   The previous behaviour can be restored by adding the following to your
149   ikiwiki setup:
150
151         teximg_prefix => '\documentclass{scrartcl}
152                 \usepackage[version=3]{mhchem}
153                 \usepackage{amsmath}
154                 \usepackage{amsfonts}
155                 \usepackage{amssymb}
156                 \pagestyle{empty}
157                 \begin{document}',
158
159   In addition, the rendering mechanism has been changed to use `dvipng` by
160   default, if available.
161
162  -- Joey Hess <joeyh@debian.org>  Sun, 24 Aug 2008 15:00:40 -0400
163
164 ikiwiki (2.60) unstable; urgency=low
165
166   Admin preferences are moving from the web interface to the setup file.
167   There are three new options in the setup file: `locked_pages`, `banned_users`,
168   and `allowed_attachments`. The admin prefs page can still be used, but
169   that's deprecated, and the prefs will be hidden if a value is not already
170   set. If a value is set in the web interface, you're encouraged to move that
171   setting to your setup file now, since version 3.0 will remove the deprecated
172   admin prefs web interface.
173
174   Also, the layout of the setup file has changed in a significant way in this
175   release. Old setup files will continue to work, but new features, like the
176   new websetup interface, require a new format setup file. You can convert
177   old setup files into the new format by running 
178   `ikiwiki-transition setupformat ikiwiki.setup`
179
180  -- Joey Hess <joeyh@debian.org>  Fri, 01 Aug 2008 17:02:14 -0400
181
182 ikiwiki (2.52) unstable; urgency=low
183
184   All wikis need to be rebuilt on upgrade to this version. If you listed your
185   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
186   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
187
188  -- Joey Hess <joeyh@debian.org>  Sun, 06 Jul 2008 15:10:05 -0400
189
190 ikiwiki (2.49) unstable; urgency=low
191
192   The search plugin no longer uses hyperestraier. Instead, to use it you
193   will now need to install xapian-omega, and the Search::Xapian,
194   HTML::Scrubber, and Digest::SHA1 perl modules. Ie,
195   `apt-get install xapian-omega libsearch-xapian-perl libhtml-scrubber-perl libdigest-sha1-perl`
196
197   Also, wikis that use the search plugin will need to be rebuilt,
198   since the search form has changed. This will not be done automatically,
199   but can be done by running `ikiwiki-mass-upgrade` as root, or
200   running `ikiwiki -setup` on individual setup files.
201
202  -- Joey Hess <joeyh@debian.org>  Wed, 04 Jun 2008 00:29:28 -0400
203
204 ikiwiki (2.48) unstable; urgency=high
205
206   If you allowed password based logins to your wiki, those passwords were
207   stored in cleartext in the userdb. To guard against exposing users'
208   passwords, I recommend you install the Authen::Passphrase perl module, and
209   then run `ikiwiki-transition hashpassword /path/to/srcdir` to replace all
210   existing cleartext passwords with strong (blowfish) hashes.
211
212  -- Joey Hess <joeyh@debian.org>  Thu, 29 May 2008 14:39:34 -0400
213
214 ikiwiki (2.46) unstable; urgency=low
215  
216   There were some significant template changes in ikiwiki 2.42 (and 1.33.5).
217   If you have locally modified versions of the templates, they need to be
218   updated. Most notably, the editpage.tmpl has a new FIELD-SID added to it,
219   without which web editing will fail.
220  
221  -- Joey Hess <joeyh@debian.org>  Tue, 06 May 2008 14:30:14 -0400
222
223 ikiwiki (2.40) unstable; urgency=low
224
225   ikiwiki now has an new syntax for preprocessor directives, using the
226   prefix '!':
227
228   [[!directive ...]]
229
230   This new syntax no longer relies on spaces to distinguish between
231   wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
232   in their link text, and preprocessor directives without arguments (such
233   as "toc") need not use a trailing space.
234
235   To enable the new syntax, set prefix_directives to true in your ikiwiki
236   config.  For backward compatibility with existing wikis,
237   prefix_directives currently defaults to false.  In ikiwiki 3.0,
238   prefix_directives will default to true, and wikis which have not yet
239   converted to the new syntax will need to set prefix_directives to false
240   in their setup files.
241
242   To convert your wiki to the new syntax, ikiwiki provides a new script
243   ikiwiki-transition.
244
245   Even with prefix_directives disabled, ikiwiki now allows an optional '!'
246   prefix on preprocessor directives (but still requires a space).  Thus, a
247   directive which uses a '!' prefix and contains a space will work with
248   ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
249   This allows the underlay to work with all ikiwikis.
250
251  -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
252
253 ikiwiki (2.30) unstable; urgency=low
254
255   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
256   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
257   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
258   Custom RecentChanges pages can be easily set up that display only changes
259   to a subset of pages, or only changes by a subset of users.
260   
261   All wikis need to be rebuilt on upgrade to this version. If you listed your
262   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
263   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
264
265   With this excellent new RecentChanges support, the mail notification system
266   is its age (and known to be variously buggy and underimplemented for
267   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
268   from this version. If you were subscribed to commit mails, you should be
269   able to accomplish the same thing by subscribing to a RecentChanges feed.
270
271   The "notify" field in setup files is no longer used, and
272   silently ignored. You may want to remove it from your setup file.
273
274  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
275
276 ikiwiki (2.20) unstable; urgency=low
277
278   The template plugin has begin to htmlize the variables passed to templates.
279   This is normally what you want, but to get the old behavior and get at the
280   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
281  
282  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
283
284 ikiwiki (2.16) unstable; urgency=low
285
286   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
287   release, to avoid the basewiki including pages with names like "blog".
288   Redirection pages have been left behind for these moved pages temporarily,
289   and will be removed later.
290
291   If you use the calendar plugin, ikiwiki is now smarter and your nightly
292   cron job to update the wiki doesn't need to rebuild everything. Just pass
293   --refresh to ikiwiki in the cron job and it will update only pages that
294   contain out of date calendars.
295
296  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
297
298 ikiwiki (2.14) unstable; urgency=low
299
300   This version of ikiwiki is more picky about symlinks in the path leading
301   to the srcdir, and will refuse to use a srcdir specified by such a path.
302   This was necessary to avoid some potential exploits, but could potentially
303   break (semi-)working wikis. If your wiki has a srcdir path containing a
304   symlink, you should change it to use a path that does not.
305
306  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
307
308 ikiwiki (2.9) unstable; urgency=low
309
310   Since ikiwiki 2.0 was released, some limitiations have been added to what
311   ikiwiki considers a WikiLink. In short, if there are any spaces in between
312   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
313   contains things meant to be WikiLinks that contain spaces, you will need to
314   fix them, by replacing the spaces with underscores.
315   
316   WikiLink have always been documented to not contain spaces, but bugs in
317   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
318   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
319   release. These fixes are necessary to avoid ambiguity between
320   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
321   these bugs (and their fixes) may have caused.
322
323  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
324
325 ikiwiki (2.6) unstable; urgency=low
326
327   In this version the rst plugin allows raw html to be embedded in rst files.
328   As long as the htmlscrubber is enabled, this should be safe. If you are
329   using the rst plugin without the htmlscrubber in a publically writable wiki,
330   you should turn on the htmlscrubber.
331
332  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
333
334 ikiwiki (2.5) unstable; urgency=low
335
336   Due to some config changes in this version, wrappers need to be rebuilt on
337   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
338   one automatically when the Debian package is upgraded.
339
340  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
341
342 ikiwiki (2.1) unstable; urgency=low
343
344   Some wikis need to be rebuilt on upgrade to this version, due to changes to
345   page templates and the style sheet. If you listed your wiki in
346   /etc/ikiwiki/wikilist this will be done automatically when the Debian
347   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
348
349  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
350
351 ikiwiki (2.00) unstable; urgency=low
352
353   With the 2.0 release of ikiwiki, some major changes have been made to the
354   default configuration:
355
356   * The 'usedirs' setting is enabled by default. This *will* break all URLs
357     to wikis that did not have 'usedirs' turned on before, unless you follow
358     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
359     or edit your setup file to turn usedirs off:
360        usedirs => 0,
361
362   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
363     perl module is available. Password logins are also still enabled
364     by default. If you like, you can turn either OpenID or password logins
365     off via the 'disable_plugins' setting.
366
367  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
368
369 ikiwiki (1.51) unstable; urgency=low
370
371   Some wikis need to be rebuilt on upgrade to this version, due to changes to
372   page layout and the style sheet. If you listed your wiki in
373   /etc/ikiwiki/wikilist this will be done automatically when the Debian
374   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
375
376  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
377
378 ikiwiki (1.50) unstable; urgency=low
379
380   Permalinks and guids in rss and atom feeds for wikis using the usedirs
381   options will change in this release. If you have already enabled usedirs,
382   you may need to take steps to avoid flooding aggregators.
383
384  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
385
386 ikiwiki (1.49) unstable; urgency=low
387
388   Third-party plugins that use htmlpage() or abs2rel() to generate links
389   may need changes to support the new "usedirs" option.
390
391  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
392
393 ikiwiki (1.47) unstable; urgency=low
394  
395   Due to a security fix, wikis that have the htmlscrubber enabled can no
396   longer use the meta plugin to insert html link and meta tags.
397
398   Some special case methods have been added for safely including stylesheets,
399   and for doing openid delegation. See the meta plugin docs for details.
400  
401  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
402
403 ikiwiki (1.45) unstable; urgency=low
404
405   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
406   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
407   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
408
409  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
410
411 ikiwiki (1.44) unstable; urgency=low
412
413   The htmllink() function has changed slightly and plugins that use it may
414   need to change how they call it. This function's first three parameters
415   are unchanged, but additional options are now passed using named
416   parameters. If you used htmllink with more than 3 parameters, you will
417   need to change it. The plugin interface version has been increased to 1.02
418   to reflect this change.
419
420  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
421
422 ikiwiki (1.42) unstable; urgency=low
423
424   The anonok setting in config files has been removed. To enable
425   httpauth support on your wiki, you should now enable the anonok plugin,
426   instead.
427
428   Third-party plugins that use pagespec_match() should be updated to pass
429   the new third parameter (from) to that function. This is needed for the
430   new relative glob matching to work.
431
432  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
433
434 ikiwiki (1.34) unstable; urgency=low
435
436   The httpauth setting in config files has been removed. To enable
437   httpauth support on your wiki, you should now enable the httpauth plugin,
438   instead.
439
440   This release includes OpenID support that is enabled through the openid
441   plugin. I recommend turning this on to make it easier for users to sign
442   in to your wiki.
443
444  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
445
446 ikiwiki (1.32) unstable; urgency=low
447
448   There is a change to the plugin interface in this version. Any plugins that
449   modify data in %links should pass scan => 1 when registering the hook that
450   does so.
451
452  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
453
454 ikiwiki (1.29) unstable; urgency=low
455
456   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
457   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
458   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
459
460   There is a change to the plugin interface in this version. Plugins that use
461   %renderedfiles will need to be updated, as the hash's values are now arrays
462   of rendered files. Plugins that cause a page to render additional files
463   should use the new will_render function to register the files.
464
465  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
466
467 ikiwiki (1.22) unstable; urgency=low
468   
469   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
470   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
471   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
472   to force a rebuild.
473
474   If you have modified versions of ikiwiki's html templates, you will need
475   to update your templates to link to the stylesheet file using
476   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
477   STYLEURL.
478
479   There have also been some changes to the plugin interface:
480   Any plugins that use santize, htmlize, or format hooks will need to be
481   updated for this version of ikiwiki since these hooks have been changed
482   to use named parameters.
483
484  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
485
486 ikiwiki (1.13) unstable; urgency=low
487
488   The GlobList format which was used for specifiying sets of pages, has been
489   replaced with a new, more expressive PageSpec format. While GlobLists will
490   continue to work, that format is deprecated, and you are encouraged to use
491   PageSpecs from now on, and also to change any GlobLists in your wiki to
492   PageSpecs. See the new PageSpec page for details.
493   
494   You will need to rebuild your wiki when upgrading to this version. If you
495   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
496   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
497   rebuild.
498
499  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
500
501 ikiwiki (1.11) unstable; urgency=low
502
503   Some changes to tags in this release, due to a new tag plugin. If you have
504   been using the meta plugin to tag pages, you'll want to enable the tag
505   plugin too, and change things like this:
506
507   [[meta link="foobar"]]
508
509   To this:
510
511   [[tag foobar]]
512
513   The new tags will appear at page footers, and are also easier to type.
514
515   There have also been some changes to the plugin interface, particularly the
516   interface of pagetemplate hooks has changed. See the changelog for details.
517
518  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
519
520 ikiwiki (1.8) unstable; urgency=low
521
522   If your wiki is configured with a setup file, you should modify it to
523   stop setting the "plugin" list directly, and instead add or remove plugins
524   via the add_plugins and disable_plugins lines. For example, if you had:
525
526         plugin => [qw{inline smiley search}],
527
528   Change it to these lines, which disables the default htmlscrubber plugin
529   and adds the two additional plugins:
530
531         add_plugins => [qw{smiley search}],
532         disable_plugins => [qw{htmlscrubber}],
533
534   Making this change makes your ikiwiki setup file more future-proof since
535   new default plugins will be automatically used.
536   
537   You will need to rebuild your ikiwiki wrappers when upgrading to this
538   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
539   done automatically when the Debian package is upgraded. Or use
540   ikiiki-mass-rebuild --refresh to force a refresh.
541
542  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
543
544 ikiwiki (1.1) unstable; urgency=low
545
546   There have been several configuration changes in this release of ikiwiki:
547
548   The --svn and --no-svn switches are removed, instead you should use
549    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
550   be changed to set rcs => "svn"; if your setup file sets svn => 0
551   then change it to use rcs => "" to disable svn.
552
553   The --hyperestraier switch is gone too. To enable searching, turn on the
554   search plugin, by passing --plugin=search or through the plugin setting in
555   the setup file.
556
557   The --sanitize and --no-sanitize switches are also gone, replaced with the
558   htmlscrubber plugin. This plugin is enabled by default, to disable it,
559   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
560   setup file.
561
562   Discussion pages are enabled by default, but if your wiki is configured
563   with a setup file, you need to edit it to keep them enabled on upgrade
564   to this version. Add a line reading:
565   discussion => 1,
566
567   You will need to rebuild your wiki when upgrading to this version.
568   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
569   automatically when the Debian package is upgraded. Or use
570   ikiiki-mass-rebuild to force a rebuild.
571
572  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400