]> sipb.mit.edu Git - ikiwiki.git/blob - doc/bugs/Checksum_errors_on_the_pristine-tar_branch.mdwn
Merge branch 'master' of ssh://git.ikiwiki.info/srv/git/ikiwiki.info
[ikiwiki.git] / doc / bugs / Checksum_errors_on_the_pristine-tar_branch.mdwn
1 I'm in the process of installing ikiwiki on my home page (hooray), and wants to have the newest stable version available. I suppose that's the one on the `pristine-tar` branch. But I'm unable to recreate the newest `.tar` file, in fact there's errors in all these `.tar.gz` files on that branch:
2
3 * `ikiwiki_2.20.tar.gz`
4 * `ikiwiki_2.30.tar.gz`
5 * `ikiwiki_2.31.1.tar.gz`
6 * `ikiwiki_2.46.tar.gz`
7 * `ikiwiki_2.47.tar.gz`
8 * `ikiwiki_2.48.tar.gz`
9 * `ikiwiki_2.49.tar.gz`
10 * `ikiwiki_2.50.tar.gz`
11 * `ikiwiki_2.51.tar.gz`
12 * `ikiwiki_2.62.1.tar.gz`
13 * `ikiwiki_2.62.tar.gz`
14 * `ikiwiki_3.20101129.tar.gz`
15 * `ikiwiki_3.20101201.tar.gz`
16 * `ikiwiki_3.20101231.tar.gz`
17 * `ikiwiki_3.20110105.tar.gz`
18 * `ikiwiki_3.20110122.tar.gz`
19 * `ikiwiki_3.20110123.tar.gz`
20 * `ikiwiki_3.20110124.tar.gz`
21
22 The operation fails on these files with a "Checksum validation failed" error from `xdelta`(1). The `pristine-tar`(1) version is 1.00, installed with `apt-get` on Ubuntu 10.04.2 LTS. Is this version too old, or are there some errors on this branch?
23
24 A complete output of the "pristine-tar checkout" of all files is stored on <https://gist.github.com/836720> .
25
26 For now, I'll download the `.tar.gz` from <http://packages.debian.org/unstable/source/ikiwiki>, or maybe install `ikiwiki_3.20110124_all.deb`. Would you recommend using that `.deb` file on Ubuntu 10.04.2 LTS, or is it Debian-specific? -- sunny256 2011-02-21 08:42+0100