]> sipb.mit.edu Git - ikiwiki.git/blob - doc/bugs/Problems_using_cygwin.mdwn
8c615f296bb2bea0d82c33ea29374bd082d30020
[ikiwiki.git] / doc / bugs / Problems_using_cygwin.mdwn
1 I'd like to run ikiwiki under cygwin.  I'm new to ikiwiki and have tried to follow the setup tutorial as best I could.  I got all the way up to step 7, but I can't get the CGI to run successfully (step 8).
2
3 After editing ikiwiki.setup, and running "ikiwiki --setup", the CGI script is successfully created.  However, if I then click on "Edit Page" link, I see nothing in the browser and the following in the logs:
4
5 <pre>
6 ==> /var/log/apache2/access_log <==
7 192.168.0.125 - - [06/Oct/2006:15:12:05 -0500] "GET /cgi-bin/ikiwiki.cgi?page=index&do=edit HTTP/1.1" 500 666
8
9 ==> /var/log/apache2/error_log <==
10 [Fri Oct 06 15:12:07 2006] [error] [client 192.168.0.125] HTML::Template::param() : attempt to set parameter 'form-submit' with an array ref - parameter is not a TMPL_LOOP! at /usr/lib/perl5/site_perl/5.8/CGI/FormBuilder.pm line 1415, referer: http://imrisws36/wiki/
11 [Fri Oct 06 15:12:07 2006] [error] [client 192.168.0.125] Premature end of script headers: ikiwiki.cgi, referer: http://imrisws36/wiki/
12 </pre>
13
14 Can anyone decipher this for me?  I spent some time with cpan earlier today downloading the latest version I could find of prerequisite modules such as HTML::Template and CGI::FormBuilder.
15
16 > It would help to know what version of CGI::FormBuilder you have. Mine
17 > (3.03.01) does not seem to contain this error message. --[[Joey]]
18
19 I have version 3.0401 of CGI::FormBuilder -- the latest from CPAN.  If you are wondering about any other modules, the answer 
20 is likely the same: the latest from CPAN.  And you're right: the error string in question does not appear in CGI::FormBuilder.  I found it in HTML::Template (version 2.8).
21
22 -----
23
24 OK, so downgrading CGI::FormBuilder to 3.0302 makes the problem go away.  I'll leave it to you to figure out whether the bug is in CGI::FormBuilder or in IkiWiki. --Steve
25
26 Maybee this bug should be renamed as "doesn't work with CGI::FormBuilder (3.04)." I get same error on FreeBSD.  
27
28     HTML::Template::param() : attempt to set parameter 'form-submit' with an array 
29     ref - parameter is not a TMPL_LOOP! 
30     at /usr/local/lib/perl5/site_perl/5.8.7/CGI/FormBuilder.pm line 1415
31
32 version info:
33
34     root@freedom# pkg_info | grep p5-CGI
35     p5-CGI-FastTemplate-1.09 Perl module for manage templates and parses templates
36     p5-CGI-FormBuilder-3.0401 FormBuilder for CGI
37     p5-CGI-Session-4.14 Perl extension for persistent session management
38
39 --Mark
40
41 > Seems likely.. So far I've been lazy and stuck with the FormBuilder in Debian, so haven't got a system I can debug this on (sorry). --[[Joey]]
42
43 -----
44
45 A different problem has reared its ugly head.  When I click on "RecentChanges", the CGI complains about an undefined subroutine:
46
47 <pre>
48 ==> apache2/error_log <==
49 [Thu Oct 12 16:20:52 2006] [error] [client 192.168.0.125] Undefined subroutine &IkiWiki::XMLin called at /usr/lib/perl5/site_perl/5.8/IkiWiki/Rcs/svn.pm line 143., referer: http://imrisws36/wiki/index.html?updated
50 [Thu Oct 12 16:20:52 2006] [error] [client 192.168.0.125] Premature end of script headers: ikiwiki.cgi, referer: http://imrisws36/wiki/index.html?updated
51 </pre>
52
53 Indeed there is no such routine IkiWiki::XMLin().  I don't understand how this can possibly work -- as it manifestly does on linux.
54
55 > XMLin is supposed to be exported by XML::Simple. My guess is that, due to a missing error check, XML::Simple is failing to load, and it's not aborting then. You probably need to install that module; in the meantime, I've fixed the missing error check in svn. --[[Joey]]