]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* Add a html plugin, which can be used to write wikis in raw html,
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.8) UNRELEASED; urgency=low
2
3   * Fix orphans plugin to not count a link to a nonexistant page as a reason
4     for a page not being an orphan.
5   * Support pinging services such as Technorati using XML-RPC to notify them
6     about changes to rss feeds.
7   * Parse svn log as xml for improved utf8 and security. Note that this makes
8     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
9   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
10     flagged string even if the locale causes it to generate utf8 output,
11     so make sure to let perl know it should be handled as utf8. Also,
12     the optimised version used for standard time formats won't work if the
13     user has changed locale, so drop it. Thanks, Faidon Liambotis.
14   * Fix re-encoding of the comments field to utf8 if a commit fails
15     due to a conflict. Thanks, Faidon Liambotis.
16   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
17     Liambotis.
18   * Add insane double encode/decode to utf8 around call to markdown.
19     This works around a truely strange bug, which is apparently a bug in
20     perl, #376329. Also added a test case for it.
21   * Improve layout of edit page so formatting help link is always visible w/o
22     getting in the way of the preview.
23   * Centralised all calls to HTML::Template and force all the templates
24     to be read as utf8.
25   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
26   * Introduce add_plugins and disable_plugins config options in setup files.
27     This allows adding or removing plugins w/o overriding the whole list of
28     default plugins, which makes it easier to upgrade when new default plugins
29     are added.
30   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
31     default (of course!). Based on a patch by Faidon Liambotis.
32   * Add a html plugin, which can be used to write wikis in raw html,
33     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
34     defaults to not processing .html files, since w/o this plugin they would
35     be copied unsanitised. With this plugin, it will process, and html
36     sanitise, them like any other page type.
37
38  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 18:15:30 -0400
39
40 ikiwiki (1.7) unstable; urgency=low
41
42   * Updated logo from Recai with some kerning and alingment tuning.
43   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
44     changed some output.
45   * Copyright update.
46
47  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
48
49 ikiwiki (1.6) unstable; urgency=low
50
51   * YA utf-8 patch from Recai, this time to fix previewing a page so that
52     the text in the input box is re-encoded back to utf-8.
53   * -CSD does not affect modules, so readfile() was not using the utf-8 input
54     layer, which led to lots of problems; make it force read files as utf-8.
55     Closes: #373203
56   * Note that as a consequence, this version of ikiwiki will actually try to
57     parse utf8 in source files for the first time, which may expose broken
58     utf8 in wiki sources that was hidden before. Most common will be
59     perl warnings like "utf8 "\xE9" does not map to Unicode"
60   * writefile() likewise needs to use the utf8 output layer.
61   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
62     there.
63   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
64     given the readfile fix.
65   * Add utf-8 testcases for readfile and htmlize.
66   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
67     safe.
68   * More utf-8 fixes from Recai, partly to things I broke above:
69     - The serious problem is that writefile() saves the content in undecoded
70       format in CGI, hence all (non-ascii) chars are corrupted permanently.
71     - Comment field in edit page is not decoded and all the non-ascii chars in
72       this field are corrupted as the result.  We should decode it as we do it
73       for the content.
74     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
75       character in print.
76   * New SVG logo from Recai.
77
78  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
79
80 ikiwiki (1.5) unstable; urgency=low
81
82   * Add --timeformat config option to allow changing how dates are displayed.
83     Note that as a side effect, dates will now be displayed using the local
84     timezone, not as GMT.
85   * More security review.
86   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
87     for some handy stuff like:
88     - Using links as a kind of tag; creating blog pages that list all pages
89       containing a given tag/link or not containing some other tag.
90     - Subscribing to mail notifications whenever a change is made to a page
91       that is a backlink of page foo. Ie, "Please notify me of changes in all
92       pages that link to my home page in the wiki"
93     - Locking any pages that are linked to from a particular page, so that
94       lists of locks can be exposed in the wiki.
95   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
96     when a todo item is done, instead of the previous moving it to a different
97     subdir.
98   * Allow pagetemplate plugins to override *anything* in the template.
99   * Add a meta plugin, which allows specifying various metadata about pages,
100     like license and author. It also allows for inserting html link and meta
101     tags into html, overriding the title, and adding hidden WikiLinks, which
102     can be useful when using link-based globbing for page categorisation.
103   * Remove preprocessor directives from inlined pages.
104   * Allow simple preprocessor directive values to be specified w/o quotes.
105   * Add support for using git instead of subversion as the RCS backend,
106     tremendous thanks to Recai Oktaş for this.
107   * Doc updates for git.
108   * Fix absolute url munging in rss generation to support https, ftp, etc urls
109     not just http urls.
110   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
111     utf-8 for edit and other fields, and for recentchanges. There may still
112     be utf-8 issues with the preferences page though.
113
114  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
115
116 ikiwiki (1.4) unstable; urgency=low
117
118   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
119     very strange way of enabling proper XHTML <br /> type tags. Output html
120     should be always valid again now.
121   * The page name and parent links has switched from using a <h1> to a styled
122     <span>, so pages can use <h1> internally instead of needing to use <h2>.
123   * Updated all of ikiwiki's own wiki pages for that.
124   * Add pagetemplate hook, which can be used by plugins that want to mess
125     around with adding new stuff to the page template.
126   * Remove headercontent; the search plugin now adds the search box to the
127     header by registering a pagetemplate hook, and other plugins should do
128     similarly.
129   * Rebuilding on upgrade to this version is recommended.
130   * Add a html validity check to the test suite, using the wdg-html-validator,
131     if available.
132   * Make the html valid when there is nothing in the actions list.
133   * Reordered some function call parameters for consistency.
134   * Enable full utf-8 support for page input and output.
135   * Add a workaround for markdown, which does not work well with utf-8
136     strings.
137   * --getctime had bitrotted (well I only ever used it the once so far..),
138     fix and make it a bit more flexible
139   * rcs_getctime is changed, now rather than needing to loop over all pages,
140     it should just use the rcs to get the ctime of the passed file.
141   * When inlining a page in another one, links from the inlined page are now
142     expanded the same as they are when rendering the inlined page as a
143     standalone page. So rather than being expanded from the POV of the
144     inlining page, they are expanded from the POV of the inlined page.
145
146     For example, a link from blog/foo to "bar" will now link to blog/bar
147     if it exists. Previously this needed to be a link explicitly to
148     "blog/bar"; such links will also continue to work.
149
150     (This was slightly complex to do as the link still has to be constructed
151     relative to the inlining page.)
152   * Make page edit textarea resize to fit browser window.
153   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
154     do not need a full rebuild, in order to update any basewiki pages.
155
156  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
157
158 ikiwiki (1.3) unstable; urgency=low
159
160   * Fix the preinst introduced in the last version. Closes: #367458
161
162  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
163
164 ikiwiki (1.2) unstable; urgency=low
165
166   * Remove dups from the brokenlinks list.
167   * Add libc6-dev to dependencies, needed to build wrappers.
168   * Install wikilist in correct location. Closes: #367371
169
170  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
171
172 ikiwiki (1.1) unstable; urgency=low
173
174   * Rename inlinepage to depends, so that it can be used to refer to more
175     dependency relationships than just inlining. This will require a rebuild
176     on upgrade to this version.
177   * Move the rss link, put it in the blogpost form if there is one and at the
178     top if not. This is both nicer because easier to find, and it cleans up
179     the code which had used inlinepage as a flag for adding the link later.
180   * Allow the depends GlobList to be built up from multiple sources (such as
181     plugins) during a page render.
182   * Which means that more than one blog is now supported to appear on a
183     single page. (With some limitations, like only the last one getting an
184     rss file.)
185   * Added a plugin system.
186   * Added a pagecount plugin, enabled by default.
187   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
188   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
189     backlinks when the backlinks hadn't really changed.
190   * Moved inline page support, rss generation etc into the inline plugin,
191     enabled by default.
192   * Added brokenlinks plugin, not enabled by default, but rather handy.
193   * Fix several broken links in the doc wiki.
194   * Smarter behavior when creating a page and a page of the same name (but
195     different location) already exists.
196   * Add an orphans plugin for finding pages that nothing links to.
197   * Removed backlinks page, which it turns out nothing used.
198   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
199     it, this will allow for adding a unit test suite.
200   * Add unit tests for several core functions, including globlist_match,
201     dirname, basename, bestlink, linkify, pagetitle, titlepage.
202   * Smart globlist merging.
203   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
204     to pave the way for adding other RCS support. This also changes the
205     setup files, where before they had svn => 1 or svn => 0, now they have
206     rcs => "svn" or rcs => "".
207   * Add a debian/NEWS file with upgrade notes.
208   * Load whatever rcs module is specified, so new ones can be just dropped in
209     as plugins and work. (Well, in theory.)
210   * Add some basic docs about writing RCS modules.
211   * Broke search capability out into a plugin, removed the --hyperestraier
212     switch.
213   * Added smiley plugin, nicely controlled and documented by the smileys page.
214   * Copied in some smileys from Moin Moin.
215   * Allow links of the form [[some page|page]], with whitespace in the link
216     text.
217   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
218     and --disable-plugin htmlscrubber.
219   * Allow discussion links on pages to be turned off with --no-discussion.
220   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
221   * Add some new config items to the estseek.conf template, which are needed
222     by hyperestraier 1.2.3.
223
224  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
225
226 ikiwiki (1.0) unstable; urgency=low
227
228   * First official release.
229
230  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400