short report so that others know when they encouter this.
[ikiwiki.git] / doc / bugs / librpc-xml-perl_0.69_breaks_XML-RPC_plugins.mdwn
1 Upgrading to `librpc-xml-perl` 0.69-1 on debian breaks external XML-RPC plugins (such as [[rst]]).
2 Refresing the wiki fails with an error message like this:
3
4     RPC::XML::Parser::new: This method should have
5     been overridden by the RPC::XML::Parser class at
6     /usr/share/perl5/RPC/XML/Parser.pm line 46, <GEN1> line 30.
7
8 It appears an incompatible change in the library creates this problem.
9
10 `librpc-xml-perl` version 0.67-1 works. The easiest solution is to downgrade to this version,
11 or disable XML-RPC plugins if they are not needed.