implement aggregate_locking design
[ikiwiki.git] / debian / NEWS
1 ikiwiki (2.30) unstable; urgency=low
2
3   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
4   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
5   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
6   Custom RecentChanges pages can be easily set up that display only changes
7   to a subset of pages, or only changes by a subset of users.
8   
9   All wikis need to be rebuilt on upgrade to this version. If you listed your
10   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
11   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
12
13   With this excellent new RecentChanges support, the mail notification system
14   is showing its age (and known to be variously buggy and underimplemented for
15   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
16   from this version. If you were subscribed to commit mails, you should be
17   able to accomplish the same thing by subscribing to a RecentChanges feed.
18
19   The "svnrepo" and "notify" fields in setup files are no longer used, and
20   silently ignored. You may want to remove them from your setup file.
21
22  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
23
24 ikiwiki (2.20) unstable; urgency=low
25
26   The template plugin has begin to htmlize the variables passed to templates.
27   This is normally what you want, but to get the old behavior and get at the
28   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
29  
30  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
31
32 ikiwiki (2.16) unstable; urgency=low
33
34   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
35   release, to avoid the basewiki including pages with names like "blog".
36   Redirection pages have been left behind for these moved pages temporarily,
37   and will be removed later.
38
39   If you use the calendar plugin, ikiwiki is now smarter and your nightly
40   cron job to update the wiki doesn't need to rebuild everything. Just pass
41   --refresh to ikiwiki in the cron job and it will update only pages that
42   contain out of date calendars.
43
44  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
45
46 ikiwiki (2.14) unstable; urgency=low
47
48   This version of ikiwiki is more picky about symlinks in the path leading
49   to the srcdir, and will refuse to use a srcdir specified by such a path.
50   This  was necessary to avoid some potential exploits, but could potentially
51   break (semi-)working wikis. If your wiki has a srcdir path containing a
52   symlink, you should change it to use a path that does not.
53
54  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
55
56 ikiwiki (2.9) unstable; urgency=low
57
58   Since ikiwiki 2.0 was released, some limitiations have been added to what
59   ikiwiki considers a WikiLink. In short, if there are any spaces in between
60   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
61   contains things meant to be WikiLinks that contain spaces, you will need to
62   fix them, by replacing the spaces with underscores.
63   
64   WikiLink have always been documented to not contain spaces, but bugs in
65   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
66   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
67   release. These fixes are necessary to avoid ambiguity between
68   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
69   these bugs (and their fixes) may have caused.
70
71  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
72
73 ikiwiki (2.6) unstable; urgency=low
74
75   In this version the rst plugin allows raw html to be embedded in rst files.
76   As long as the htmlscrubber is enabled, this should be safe. If you are
77   using the rst plugin without the htmlscrubber in a publically writable wiki,
78   you should turn on the htmlscrubber.
79
80  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
81
82 ikiwiki (2.5) unstable; urgency=low
83
84   Due to some config changes in this version, wrappers need to be rebuilt on
85   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
86   one automatically when the Debian package is upgraded.
87
88  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
89
90 ikiwiki (2.1) unstable; urgency=low
91
92   Some wikis need to be rebuilt on upgrade to this version, due to changes to
93   page templates and the style sheet. If you listed your wiki in
94   /etc/ikiwiki/wikilist this will be done automatically when the Debian
95   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
96
97  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
98
99 ikiwiki (2.00) unstable; urgency=low
100
101   With the 2.0 release of ikiwiki, some major changes have been made to the
102   default configuration:
103
104   * The 'usedirs' setting is enabled by default. This *will* break all URLs
105     to wikis that did not have 'usedirs' turned on before, unless you follow
106     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
107     or edit your setup file to turn usedirs off:
108        usedirs => 0,
109
110   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
111     perl module is available. Password logins are also still enabled
112     by default. If you like, you can turn either OpenID or password logins
113     off via the 'disable_plugins' setting.
114
115  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
116
117 ikiwiki (1.51) unstable; urgency=low
118
119   Some wikis need to be rebuilt on upgrade to this version, due to changes to
120   page layout and the style sheet. If you listed your wiki in
121   /etc/ikiwiki/wikilist this will be done automatically when the Debian
122   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
123
124  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
125
126 ikiwiki (1.50) unstable; urgency=low
127
128   Permalinks and guids in rss and atom feeds for wikis using the usedirs
129   options will change in this release. If you have already enabled usedirs,
130   you may need to take steps to avoid flooding aggregators.
131
132  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
133
134 ikiwiki (1.49) unstable; urgency=low
135
136   Third-party plugins that use htmlpage() or abs2rel() to generate links
137   may need changes to support the new "usedirs" option.
138
139  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
140
141 ikiwiki (1.47) unstable; urgency=low
142  
143   Due to a security fix, wikis that have the htmlscrubber enabled can no
144   longer use the meta plugin to insert html link and meta tags.
145
146   Some special case methods have been added for safely including stylesheets,
147   and for doing openid delegation. See the meta plugin docs for details.
148  
149  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
150
151 ikiwiki (1.45) unstable; urgency=low
152
153   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
154   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
155   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
156
157  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
158
159 ikiwiki (1.44) unstable; urgency=low
160
161   The htmllink() function has changed slightly and plugins that use it may
162   need to change how they call it. This function's first three parameters
163   are unchanged, but additional options are now passed using named
164   parameters. If you used htmllink with more than 3 parameters, you will
165   need to change it. The plugin interface version has been increased to 1.02
166   to reflect this change.
167
168  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
169
170 ikiwiki (1.42) unstable; urgency=low
171
172   The anonok setting in config files has been removed. To enable
173   httpauth support on your wiki, you should now enable the anonok plugin,
174   instead.
175
176   Third-party plugins that use pagespec_match() should be updated to pass
177   the new third parameter (from) to that function. This is needed for the
178   new relative glob matching to work.
179
180  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
181
182 ikiwiki (1.34) unstable; urgency=low
183
184   The httpauth setting in config files has been removed. To enable
185   httpauth support on your wiki, you should now enable the httpauth plugin,
186   instead.
187
188   This release includes OpenID support that is enabled through the openid
189   plugin. I recommend turning this on to make it easier for users to sign
190   in to your wiki.
191
192  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
193
194 ikiwiki (1.32) unstable; urgency=low
195
196   There is a change to the plugin interface in this version. Any plugins that
197   modify data in %links should pass scan => 1 when registering the hook that
198   does so.
199
200  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
201
202 ikiwiki (1.29) unstable; urgency=low
203
204   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
205   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
206   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
207
208   There is a change to the plugin interface in this version. Plugins that use
209   %renderedfiles will need to be updated, as the hash's values are now arrays
210   of rendered files. Plugins that cause a page to render additional files
211   should use the new will_render function to register the files.
212
213  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
214
215 ikiwiki (1.22) unstable; urgency=low
216   
217   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
218   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
219   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
220   to force a rebuild.
221
222   If you have modified versions of ikiwiki's html templates, you will need
223   to update your templates to link to the stylesheet file using
224   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
225   STYLEURL.
226
227   There have also been some changes to the plugin interface:
228   Any plugins that use santize, htmlize, or format hooks will need to be
229   updated for this version of ikiwiki since these hooks have been changed
230   to use named parameters.
231
232  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
233
234 ikiwiki (1.13) unstable; urgency=low
235
236   The GlobList format which was used for specifiying sets of pages, has been
237   replaced with a new, more expressive PageSpec format. While GlobLists will
238   continue to work, that format is deprecated, and you are encouraged to use
239   PageSpecs from now on, and also to change any GlobLists in your wiki to
240   PageSpecs. See the new PageSpec page for details.
241   
242   You will need to rebuild your wiki when upgrading to this version. If you
243   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
244   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
245   rebuild.
246
247  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
248
249 ikiwiki (1.11) unstable; urgency=low
250
251   Some changes to tags in this release, due to a new tag plugin. If you have
252   been using the meta plugin to tag pages, you'll want to enable the tag
253   plugin too, and change things like this:
254
255   [[meta link="foobar"]]
256
257   To this:
258
259   [[tag foobar]]
260
261   The new tags will appear at page footers, and are also easier to type.
262
263   There have also been some changes to the plugin interface, particularly the
264   interface of pagetemplate hooks has changed. See the changelog for details.
265
266  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
267
268 ikiwiki (1.8) unstable; urgency=low
269
270   If your wiki is configured with a setup file, you should modify it to
271   stop setting the "plugin" list directly, and instead add or remove plugins
272   via the add_plugins and disable_plugins lines. For example, if you had:
273
274         plugin => [qw{inline smiley search}],
275
276   Change it to these lines, which disables the default htmlscrubber plugin
277   and adds the two additional plugins:
278
279         add_plugins => [qw{smiley search}],
280         disable_plugins => [qw{htmlscrubber}],
281
282   Making this change makes your ikiwiki setup file more future-proof since
283   new default plugins will be automatically used.
284   
285   You will need to rebuild your ikiwiki wrappers when upgrading to this
286   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
287   done automatically when the Debian package is upgraded. Or use
288   ikiiki-mass-rebuild --refresh to force a refresh.
289
290  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
291
292 ikiwiki (1.1) unstable; urgency=low
293
294   There have been several configuration changes in this release of ikiwiki:
295
296   The --svn and --no-svn switches are removed, instead you should use
297    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
298   be changed to set rcs => "svn"; if your setup file sets svn => 0
299   then change it to use rcs => "" to disable svn.
300
301   The --hyperestraier switch is gone too. To enable searching, turn on the
302   search plugin, by passing --plugin=search or through the plugin setting in
303   the setup file.
304
305   The --sanitize and --no-sanitize switches are also gone, replaced with the
306   htmlscrubber plugin. This plugin is enabled by default, to disable it,
307   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
308   setup file.
309
310   Discussion pages are enabled by default, but if your wiki is configured
311   with a setup file, you need to edit it to keep them enabled on upgrade
312   to this version. Add a line reading:
313   discussion => 1,
314
315   You will need to rebuild your wiki when upgrading to this version.
316   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
317   automatically when the Debian package is upgraded. Or use
318   ikiiki-mass-rebuild to force a rebuild.
319
320  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400