Welcome to 2019
[ikiwiki.git] / doc / bugs / Discussion_link_not_translated_in_post.mdwn
1 In my sent post (without Polish characters in title, of course ;) ) I still
2 can see "Discussion" link, instead of Polish "Dyskusja" link. --[[Paweł|ptecza]]
3
4 > I don't know what post you're referring to, more details please.
5 > --[[Joey]]
6
7 >> Sorry for the laconic bug report. I meant my blog and the post I sent
8 >> to it. It works exactly like your blog at bugs page and I also created it
9 >> for my ikiwiki users to bug reporting :)
10
11 >> So, I sent the post to my blog and I can see that "Discussion" link
12 >> from `inlinepage.tmpl` file is not translated to Polish. Now I hope
13 >> you know what I mean :) --[[Paweł|ptecza]]
14
15 >>> Joey, what about my bug report? ;) --[[Paweł|ptecza]]
16
17 >>>> Found and [[fixed|bugs/done]] --[[Joey]].
18
19 >>>>> Hm. I can't see any changes. I've builded ikiwiki 1.41 Debian package
20 >>>>> from the latest SVN repo sources and installed it on my machine.
21 >>>>> I've also rebuilded all my ikiwiki pages (`ikiwiki --setup ikiwiki.setup`).
22
23 >>>>> I added a few debug lines to changed block of code from
24 >>>>> `/usr/share/perl5/IkiWiki.pm` file:
25 >>>>>
26 >>>>>        open(LOG, ">>/var/log/ikiwiki.log");
27 >>>>>        print LOG "(1) \$config{locale}=$config{locale}\n";
28 >>>>>        print LOG "(1) \$ENV{LANG}=$ENV{LANG}\n";
29 >>>>>        if (defined $config{locale}) {
30 >>>>>                eval q{use POSIX};
31 >>>>>                error($@) if $@;
32 >>>>>                print LOG "(2) \$config{locale}=$config{locale}\n";
33 >>>>>                print LOG "(2) \$ENV{LANG}=$ENV{LANG}\n";
34 >>>>>                if (POSIX::setlocale(&POSIX::LC_ALL, $config{locale})) {
35 >>>>>                        $ENV{LANG}=$config{locale};
36 >>>>>                        $gettext_obj=undef;
37 >>>>>                        print LOG "(3) \$config{locale}=$config{locale}\n";
38 >>>>>                        print LOG "(3) \$ENV{LANG}=$ENV{LANG}\n";
39 >>>>>                }
40 >>>>>        }
41 >>>>>        close(LOG);
42 >>>>>
43 >>>>> Here is a piece of result after rebuild:
44 >>>>>
45 >>>>>        (1) $config{locale}=pl_PL.UTF-8
46 >>>>>        (1) $ENV{LANG}=pl_PL.UTF-8
47 >>>>>        (2) $config{locale}=pl_PL.UTF-8
48 >>>>>        (2) $ENV{LANG}=pl_PL.UTF-8
49 >>>>>        (3) $config{locale}=pl_PL.UTF-8
50 >>>>>        (3) $ENV{LANG}=pl_PL.UTF-8
51 >>>>>
52 >>>>> Is it a useful information for you? :) --[[Paweł|ptecza]]
53
54 >>>>>> Not really.. I was able to reproduce the problem you desciribed and
55 >>>>>> my changes fixed the problem I reproduced. --[[Joey]]
56
57 > Found and fixed one more, when per-post discussion links are used in a
58 > blog. --[[Joey]]
59
60 >> Yes, now it's fixed :) Thank you very much, Joey!
61
62 >> BTW, what about translating buttons to editing page ("Save Page",
63 >> "Preview" and "Cancel")? There are still hard-coded :( --[[Paweł|ptecza]]
64
65 >>> Those come via the formbuilder form, and currently my best plan for
66 >>> them is to add templates for them, as described in [[translation]]
67 >>> --[[Joey]]