Welcome to 2019
[ikiwiki.git] / doc / bugs / support_for_openid2_logins.mdwn
1 I have several complaints that users cannot contribute to my ikiwiki instances since they only have OpenID logins that support OpenID2. E.g. Yahoo!'s OpenID only supports 2.0+ 
2
3 This is not the fault of ikiwiki, though the problem lies within the [perl openid consumer](http://packages.qa.debian.org/libn/libnet-openid-consumer-perl.html) in Debian which is a 1.x implementation AFAIK.
4
5 I've contacted JanRain who have pointed me to:
6
7 * [OpenID4Perl](http://code.sxip.com/openid4perl/)
8 * Some [work](http://code.sixapart.com/svn/openid/trunk/perl/) by David Recordon
9
10 However both Perl OpenID 2.x implementations have not been released and are incomplete implementations. :(
11
12 > Both of the projects referenced above have since been released.
13 > Net::OpenID::Consumer 0.x in Debian is indeed only an OpenID 1
14 > implementation. However, Net::OpenID::Consumer 1.x claims to be
15 > an OpenID 2 implementation (it's the second of the projects
16 > above). I've filed a bug in Debian asking for the package to be
17 > updated. --[[smcv]]
18
19 > Net::OpenID::Consumer 1.x is now in Debian unstable --[[dom]]
20
21 > I've tested with yahoo, and it works with the updated module. Sweet and
22 > [[done]] --[[Joey]] 
23
24 ## A quick fix for the impatient running stable is simply `sudo apt-get install libnet-openid-consumer-perl -t unstable`