Welcome to 2019
[ikiwiki.git] / doc / tips / nearlyfreespeech / discussion.mdwn
1 with version 3.141592 I get
2 <pre>
3 HOME=/home/me /usr/bin/perl -Iblib/lib   ikiwiki.out -libdir . -dumpsetup ikiwiki.setup
4 Failed to load plugin IkiWiki::Plugin::inline: Can't use global $_ in "my" at IkiWiki/Plugin/inline.pm line 198, near "my $_"
5 Compilation failed in require at (eval 19) line 2.
6 BEGIN failed--compilation aborted at (eval 19) line 2.
7 </pre>
8
9 perl is 5.8.9
10
11 > This is fixed in 3.1415926. --[[Joey]] 
12
13
14 Hi!<br />
15 How can i upgrade my nearlyfreespeech installation of ikiwiki? To install it i have followed your instructions here.<br>
16 But now if I want to upgrade it to a newer version?<br />
17 Thanks for your incredible work!
18
19 > You can move `~/ikiwiki` out of the way and then re-download and install
20 > it ikiwiki. --[[Joey]]
21
22 Thanks a lot Joey. :-)
23
24 Hi
25
26 I installed version 3.20141016 as described, and it works mostly. However to get [[!iki plugins/sparkline]] to work properly I had to add
27
28 [[!format php """
29 set_include_path(get_include_path() . PATH_SEPARATOR . '/home/private/src/sparkline-php-0.2/lib');
30 require_once('/home/private/src/sparkline-php-0.2/lib/Sparkline_$style.php');
31 """]]
32
33 to `sparkline.pm` around line 38. This is mostly likely because
34
35 1. I didn't install sparkline into php's default path.
36 1. I don't really know php.
37 1. I don't have the time (right now) to sort out the proper way to do this.
38
39 I also haven't sorted out how to make [[!iki ikiwiki/directive/format]] fully functional. I suspect I don't have everything installed on the host. -- [[james]]