c3252062a0b7a41928f26ba987d152e3454b97dc
[ikiwiki.git] / doc / forum / Sidebar_with_links__63__.mdwn
1 I'm trying to create a template to use as a sidebar with links. The template will be static
2 (no variables are used). I first created a page with this directive: \[[!template id=sidebar]],
3 and then created the template with the web interface.
4
5 This is the code I put in the template:
6
7     <div class="infobox">
8     <ul>
9     <li>\[[Existing internal link|exists]]</li>
10     <li>\[[Non-existing internal link|doesnotexist]]</li>
11     <li>[External link](http://google.com/)</li>
12     </ul>
13     <http://google.com/>
14     </div>
15
16 This is the relevant part of the resulting html file `template/sidebar.html`:
17
18     <div class="infobox">
19     <ul>
20     <li><a href="../exists.html">Existing internal link</a></li>
21     <li><span class="createlink"><a href="http://localhost/cgi-bin/itesohome.cgi?page=doesnotexist&amp;from=templates%2Fsidebar&amp;do=create" rel="nofollow">?</a>Non-existing internal link</span></li>
22     <li>[External link](http://google.com/)</li>
23     </ul>
24     </div>
25
26 Note that the `<http://google.com/>` link has disappeared, and that `[External link](http://google.com/)`
27 has been copied literally instead of being converted to a link, as I expected.
28
29 Worse, this is the relevant part of the html file of the page that includes the template:
30
31     <div class="infobox">
32     <ul>
33     <li><span class="selflink">Existing internal link</span></li>
34     <li><span class="createlink"><a href="http://localhost/cgi-bin/itesohome.cgi?page=doesnotexist&amp;from=research&amp;do=create" rel="nofollow">?</a>Non-existing internal link</span></li>
35     <li>[External link](http://google.com/)</li>
36     </ul>
37     </div>
38
39 Note that the `Existing internal link` is no longer a link. It is only text.
40
41 What am I doing wrong? Any help or pointers will be appreciated. --[[buo]]