]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* Git backend improvements, including bug fixes and better robustness.
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Add toggle plugin.
13   * Add a poll plugin.
14   * Add quick mode for archive page generation.
15   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
16     many other plugins. It's an easy way to boost ikiwiki from its default,
17     basic wiki, to a full-featured wiki, without manually picking the right
18     set of plugins. New plugins will be added to goodstuff from time to
19     time.
20   * Change how post signin actions are propigated through the signin process;
21     they're now stored in the session.
22   * Add optional "desc" parameter to shortcut definitions.
23   * Avoid locking the wiki at all when handling some basic cgi stuff
24     (searches, recentchanges).
25   * Add "last" parameter to hook function. Very basic ordering, and hopefully
26     nothing more spohisticated will be needed.
27   * Add formbuilder_setup and formbuilder hooks.
28   * Split out a passwordauth module, that holds all the traditional password
29     based authentication etc code. It's enabled by default, but can be disabled
30     if you want only openid or some other auth method.
31   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
32   * Add some code to the build system that tries to determine if the
33     lib installation directory is in @INC. If it's not, munge ikiwiki
34     to hardcode the path to the lib directory. This should allow installing
35     ikiwiki in nonstandard locations, including home directories, by just
36     setting PREFIX at build time.
37   * Fix nested examples directory in deb.
38   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
39   * Add a test suite for the svn backend.
40   * Daemonize before sending RPC pings, since that can take a while
41     and/or hang.
42   * Daemonize before sending commit mails, as that can also take a long
43     time/hang if the mail server is unhappy.
44   * Factor out commit mail sending code into new function.
45   * Change rcs_commit, it is now passed the name of the user doing the commit
46     and their IP address, and needs to construct its own commit message
47     containing them, or do something more appropriate for the given RCS.
48   * Add softwaresite example.
49   * Mercurial backend improvements, including --get-ctime support. (Emanuele
50     Aina)
51   * Git backend improvements, including bug fixes and better robustness.
52     (Recai Oktaş)
53
54  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 15:01:14 -0500
55
56 ikiwiki (1.33) unstable; urgency=low
57
58   * Fix issue with aggregate plugin updating expired pages.
59   * Avoid syntax errors in templates used by the template plugin crashing
60     ikiwiki.
61   * Enable utf8 file IO in aggregate plugin.
62   * Fix some issues with the new registration form.
63   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
64   * Make sure to check for errors from every eval.
65   * Fix img plugin's handling of adding dependencies for images that do not
66     yet exist.
67   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
68     FORM-SUBMIT unusable on customised formbuilder templates. For now,
69     hardcode the submit buttons in editpage.tmpl instead of using the
70     template variable, which is ok, since the buttons are static.
71   * Work with hyperestraier 1.4.9.
72
73  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
74
75 ikiwiki (1.32) unstable; urgency=low
76
77   * Add a separate pass to find page links, and only render each page once,
78     instead of over and over. Typical speedup is ~4x. Max possible speedup:
79     8x.
80   * Add "scan" parameter to hook(), which is used to make the hook be called
81     during the scanning pass, as well as the render pass. The meta and tag
82     plugins need to use the new scan parameter, so will any others that modify
83     %links.
84   * Now that links are calculated in a separate pass, it can also
85     precalculate backlinks in one pass, which is O(N^2) instead of the
86     previous code that was O(N^3). A very nice speedup for wikis with lots
87     (thousands) of pages.
88   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
89     Erdem.
90   * Add a default stylesheet entry for the pagecloud.
91   * Add examples page with some examples of things that can be done using
92     ikiwiki, like a weblog. The examples can be copied into a user's wiki
93     for a quick start, without needing to learn everything about how to put
94     them together.
95   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
96   * Add perlmagick to build-depends so syntax check of img plugin works.
97     Closes: #396702
98   * Improve login/register process, the login dialog has only name and
99     password fields, which allows more web browsers to regognise it as a login
100     field, and is less confusing.
101   * Implemented expiry options for aggregate plugin.
102   * Use precalculated backlinks info when determining if files need an update
103     due to a page they link to being added/removed. Mostly significant if
104     there are lots of pages.
105   * Remove duplicate link info when saving index. In some cases it could
106     pile up rather badly. (Probably not the best way to deal with this
107     problem.)
108   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
109     or what have you, by creating enclosures for non-page items that are
110     included in feeds.
111
112  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
113
114 ikiwiki (1.31) unstable; urgency=low
115
116   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
117   * Change the rss feed title from the wikiname to the page title, with
118     an exception for the wiki's toplevel index page, which will still use the
119     wikiname as the feed title.
120     Overriding the page title with meta title already overrode the rss feed
121     tittle.
122   * Add an img plugin, based on Christian Mock's img plugin, but stripped
123     down to the bare essentials. Useful for handling large images on websites.
124   * Sanitize possibly problimatic characters out of the polygen grammar names,
125     just in case. Should not be exploitable anyway, since it only tries to run
126     polygen after finding the specified grammar file.
127   * Add missing dependency on the URI perl module.
128   * Add basic spam fighting tool for admins: An admin's prefs page now allows
129     editing a list of banned users.
130
131  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
132
133 ikiwiki (1.30) unstable; urgency=low
134
135   * Add no_override parameter to hook().
136   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
137     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
138     can be configured using a page in wiki.
139   * Fix support for --pingurl at the command line.
140   * Fix a subtle bug in will_render that broke some builds, by only clearing
141     items from renderedfiles the first time per build.
142   * Wrap entire technortati ping operation in an eval to catch all possible
143     failure modes, after I observed a simple ->value crashing ikiwiki when
144     a ping failed.
145
146  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
147
148 ikiwiki (1.29) unstable; urgency=low
149
150   * Patch from Paul Tötterman to use CP in the Makefile.
151   * Patch from Alec Berryman adding a http_auth config item that allows
152     using HTTP Authentication instead of ikiwiki's built in authentication.
153     Useful for eg, large sites with their own previously existing user auth
154     setup. Closes: #384534
155   * Change %renderedfiles to store an array of files rendered from a given
156     source file, to allow tracking of extra rendered files like rss feeds.
157   * Note that plugins that accessed this variable will need to be updated!
158     The plugin interface has been increased to version 1.01 for this change.
159     As few plugins use %renderedfiles I haven't done anything else to ensure
160     compatability of old plugins.
161   * Add will_render function to the plugin interface, used to register that a
162     page renders a destination file, and do some security checks. Previously
163     but no longer rendered files will be cleaned up.
164   * Use will_render in the inline and linkmap plugins.
165   * You will need to rebuild your wiki on upgrade to this version.
166   * Atom feed support based on a patch by Clint Adams.
167   * Add feeds=no option to inline preprocessor directive to turn off all types
168     of feeds.
169   * $IkiWiki::version now holds the program version, and is accessible to
170     plugins.
171   * Make the aggregate plugin emphasize error messages.
172   * Patch from Recai to limit recentchanges to displaying max 10 files for a
173     given changeset (to avoid large number of file changes excessively
174     bloating the page).
175
176  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
177
178 ikiwiki (1.28) unstable; urgency=low
179
180   * inline: Add ability to sort by page name, based on a patch from
181     Benjamin A'Lee.
182   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
183     braindead interface. Closes: #389383
184   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
185     and b) those poor Mac OSX users and their case insensative files!
186   * Don't fail syntax check if Text::Typography isn't installed.
187     Closes: #389406
188
189  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
190
191 ikiwiki (1.27) unstable; urgency=low
192
193   * Work on firming up the plugin interface:
194     - Plugins should not need to load IkiWiki::Render to get commonly
195       used functions, so moved some functions from there to IkiWiki.
196     - Picked out the set of functions and variables that most plugins
197       use, documented them, and made IkiWiki export them by default,
198       like a proper perl module should.
199     - Use the other functions at your own risk.
200     - This is not quite complete, I still have to decide whether to
201       export some other things.
202   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
203     referring to stuff now exported by the IkiWiki module.
204   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
205     to declare which version of the interface your plugin needs.
206   * Anyone with a third-party ikiwiki plugin is strongly encouraged
207     to make like changes to it and avoid use of non-exported symbols from
208     "IkiWiki::".
209   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
210   * Support hyperestradier version 1.4.2, which adds a new required phraseform
211     setting.
212   * If an inlined page has a permalink, link the page title to that.
213   * Patch from Recai to use utf8 when reading the setup file, so that
214     utf8 wikinames from there will be used properly.
215   * Patch from Recai to kill utf-8 on the wiki name when generating the
216     session cookie.
217   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
218   * Fix a baseurl problem in hyperestradier search results.
219   * Add a stub local.css to avoid problems with 404's.
220   * Patch from Recai to fix a wide character warning from the search plugin
221     during setup if the wikiname contains utf8.
222   * Yet another fix for those poor case-insensative OS X users.
223   * pagetemplate hooks are now also called when generating cgi pages.
224   * Add a favicon plugin, which simply adds a link tag for an icon to each
225     page (and cgis).
226   * Patch from James Westby to deal with the case where you're editing a
227     new page, hit cancel, and need to be redirected to somewhere sane.
228   * Various documentation improvements by various wiki users.
229   * Support Text::Markdown from CPAN, which has a different interface from
230     the original markdown or the one in Debian.
231   * Version the libcgi-session-perl dependency, some features that need
232     the new version are used in some cases (sslcookie).
233   * Numerous tla fixes from Clint.
234   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
235     a multi-resolution favicon.ico.
236   * README.Debian: typo Closes: #388110
237   * chomp trailing newline at the end of templates read in by the template
238     plugin, to allow use of the template preprocessor directive in
239     whitespace-sensative situations. Closes: #387073
240   * Patch from James Westby to make the location of the estseek.cgi script
241     configurable.
242   * Add typography (SmartyPants) plugin by Recai.
243   * Add --render mode, which can be used to preview an edit at the command
244     line by test rendering a single page.
245   * Add a googlecalendar plugin. A bit special-purpose, but it shows
246     one way to to deal with user-supplied content that could cause XSS
247     issues w/o the htmlscrubber, and won't survive the scrubber.
248
249  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
250
251 ikiwiki (1.26) unstable; urgency=low
252
253   * Add a missing -n to tla undo call.
254   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
255     writes before consuming its whole stdin. Avoid this deadlock.
256   * Fix alt tags for outline checkboxes.
257
258  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
259
260 ikiwiki (1.25) unstable; urgency=low
261
262   * Add proper waitpid calls for open2ed processes throughout to avoid
263     zombies; this hit htmltidy especially badly.
264   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
265     subversion repos and fixing some other issues.
266   * Add support for tla, contributed by Clint Adams. Closes: #385936
267   * Add support for mercurial, contributed by Emanuele Aina.
268   * Include <link rel> tag for RSS feeds, used by some aggregators and
269     firefox to find the feed.
270   * Add a linkmap plugin (requires graphviz).
271
272  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
273
274 ikiwiki (1.24) unstable; urgency=low
275
276   * Simplify the data structure returned by rcs_recentchanges to avoid
277     each rcs plugin needing to form complex strings on its own.
278   * Fix another destpage issue in the inline directive. Closes: #385512
279     again.
280
281  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
282
283 ikiwiki (1.23) unstable; urgency=low
284
285   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
286
287  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
288
289 ikiwiki (1.22) unstable; urgency=low
290
291   * Change how the stylesheet url is determined in the templates: Remove
292     STYLEURL and add BASEURL to all templates (some already had it). This
293     new more general variable can be used to link to other things (eg, images)
294     from the template, as well as stylesheets.
295   * Fix a bug introduced last version to do with nested inlines.
296   * Allow preprocessor directives to span multiple lines, both to make
297     long ones with lots of values easier to write, and to allow for ones with
298     multi-line quoted values.
299   * Allow preprocessor directives to contain python-like triple-quoted
300     text blocks, for easy nesting of quotes inside.
301   * Add a template plugin.
302   * Make pagespec merge code smarter about merging duplicate pagespecs.
303   * Patch from Jordà Polo to make Setup::Standard support hashes in config
304     files.
305   * Change order of linkify and preprocess; first preprocess and then linkify.
306     This allows passing a wikilink inside a parameter to a preprocessor
307     directive without it being expanded to html, and leaking out of the
308     parameter, which had required some non-obvious use of triple-quoting
309     to avoid. Note that any preprocessor plugins that output something
310     that looks like a wikilink will now have it treated as such; AFAIK
311     this doesn't change any behavior though except for the template plugin.
312   * Enable preprocessor directives when previewing an edit.
313   * Make all pages pull in a local.css style sheet, if present. This won't
314     be included in ikiwiki, but can be created to make local styling changes
315     w/o needing to merge in every new change to the distributed style.css.
316   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
317   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
318     from a different directory.
319   * Generalised preprocesser loop protection code.
320   * Patch from James Westby to allow a description to be set for rss feeds.
321   * Patch from James Westby to add a template for the search form.
322   * Added a ddate plugin.
323   * Patch from James Westby to add a --sslcookie switch, which forces
324     cookies to only be sent over ssl connections to avoid interception.
325   * Fix preferences page on anonok wikis; still need to sign in to get
326     to the preferences page.
327   * Add toc (table of contents) plugin.
328   * Change htmlize, format, and sanitize hooks to use named parameters.
329   * Patch from James Westby to add an actions option to inline; this
330     adds Edit and Discussion links at the end of blog entries.
331   * Due to some css changes, you'll want to rebuild your wiki on upgrade
332     to this version. Will be handled automatically by the deb.
333   * Add processed date to aggregate preprocessor directive status output.
334
335  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
336
337 ikiwiki (1.21) unstable; urgency=low
338
339   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
340   * If a page links to itself, mark up the link text in a span with
341     class="selflink" so that it can be styled. I don't have a useful style
342     defined for that though.
343   * Call filter hooks on inlined page content.
344   * Support inlining pages raw, rather than creating a blog.
345   * Clean up yes/no parameter parsing in inline plugin.
346   * Implemented better cycle detection in the inline plugin; nested inlines
347     will now work.
348   * Add a map plugin contributed by Alessandro Dotti Contra.
349   * Add otl format plugin, which handles files as created by vimoutliner.
350   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
351   * Add first draft at a Restructured Text (rst) plugin, by Sergio
352     Talens-Oliag. Note that this has many known issues -- see the caveats on
353     the plugin's page.
354   * Credit everyone who wrote a plugin on the plugins' wiki pages.
355   * Fix utf-8 in blog post form.
356
357  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
358
359 ikiwiki (1.20) unstable; urgency=low
360
361   * Relicense the templates and basewiki under the 2-clause BSD license.
362     Since these can easily become part of other people's websites, they
363     should be under as permissive a license as possible.
364   * Add --syslog config option, to log to the syslog.
365   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
366     transient failure to fork (which I've seen happen in the wild).
367   * Fix a bug in the aggregator introduced last version that caused all
368     aggregator state to be lost during a non-aggregating build.
369
370  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
371
372 ikiwiki (1.19) unstable; urgency=low
373
374   * Fix several related bugs in page type determination during online editing.
375   * Add some locking to prevent 2 aggregators from running at once.
376   * Fix an infinite loop in the aggregator when finding a unique filename.
377
378  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
379
380 ikiwiki (1.18) unstable; urgency=low
381
382   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
383   * Add --version.
384   * Man page format fixups.
385   * If the meta plugin overides the page title, set a title_overridden
386     variable in the template to true. This allows doing things with the
387     templates conditional on the title being overriden.
388   * Add a %pagecase which maps lower-case page names to the actual case
389     used in the filename. Use this in bestlinks calculation instead of
390     forcing the link to lowercase.
391   * Also use %pagecase in various other places that want to check if a page
392     with a given name exists.
393   * This means that links to pages with mixed case names will now work,
394     even if the link is in some other case mixture, and mixed case pages
395     should be fully supported throughout ikiwiki.
396   * Recommend rebuilding wikis on upgrade to this version.
397
398  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
399
400 ikiwiki (1.17) unstable; urgency=low
401
402   * Disable tidy generator tag.
403   * Move tidy back to sanitize hook, found out how to only show body.
404   * Turn off tidy indentation too.
405   * Turn on HTML::Template loop_context_vars; not actually used in stock
406     templates but can be useful for things like making comma-delimited lists
407     of tags or what have you.
408   * Remove <br> from end of aggregate preprocessor directive output.
409   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
410     case-sensative filesystems like OSX.
411   * Improve markdown loading. First, try to load it as a proper perl module,
412     in case it was installed as one. Then fall back to trying
413     /usr/bin/markdown.
414   * Document in install page how to install markdown, since it has no
415     installation procedure in the upstream tarball.
416   * Set die_on_bad_params => 0 for all templates, to allow users to modify
417     them without annoyances.
418   * Suck in the page content when generating an inline archive page, to work
419     around the meta plugin's lack of caching of title metadata across runs.
420
421  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
422
423 ikiwiki (1.16) unstable; urgency=low
424
425   * Try to handle relative links in aggregated feeds. However,
426     the current support is a crude hack due to limitations of XML::Feed:
427     xml:base is not supported, neither is Content-Location. And of course,
428     relative links in RSS feeds are ill-undefined..
429   * Make aggregator save permalinks and author name to pages as metadata.
430   * Add permalink and author support to meta plugin, affecting RSS feeds
431     and blog pages.
432   * Various CSS and formatting changes.
433   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
434   * Add xhtml files to the default prune regexp.
435   * Also generate rel=bookmark links for permalinks.
436   * Fix the htmltidy plugin, which wasn't working due my breaking it when
437     I added it..
438   * Don't run tidy with -xml as that fails if the input is not well-formed.
439     Run it with -asxhtml instead, so it will output well-formed xhtml no
440     matter what the input.
441   * Disable tidy warnings too.
442   * Add a new format hook, and make tidy use it, since tidy can really only
443     operate on and output complete html documents, not the body chunks
444     that sanitise gets.
445   * Fix dates in rss feeds if running localised, so they're still rfc 822.
446
447  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
448
449 ikiwiki (1.15) unstable; urgency=low
450
451   * Remove CDPATH and other env vars perl taint checking doesn't like.
452     Closes: #381279
453   * Added created_before and created_after PageSpec limits.
454
455  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
456
457 ikiwiki (1.14) unstable; urgency=low
458
459   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
460     by 10% or so.
461   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
462   * Added many unit tests for pagespec_match.
463
464  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
465
466 ikiwiki (1.13) unstable; urgency=low
467
468   * ikiwiki can now download and aggregate feeds with its new aggregate
469     plugin, so it's possible to implement a Planet using ikiwiki!
470   * Add a run_hooks function for the common task of running all hooks of a
471     given type.
472   * Add a savestate hook.
473   * Don't put blog post forms on pages if there's no cgiurl set.
474   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
475     --wrappers to do that.
476   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
477     to update pages that haven't changed on disk.
478   * Change meta tags to use html entity-escaped text for values, so that
479     quotes and such can be represented in title tags.
480   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
481     for the above.
482   * Make --rebuild also cause --aggregate to re-download and write aggregated
483     pages.
484   * Avoid outputting duplicate meta info.
485   * Include title metadata on aggregated posts for capitalised and un-munged
486     titles.
487   * Title metadata of inlined pages now shows up in blogs and rss feeds.
488   * Fix issue with unicode filenames and updating the hyper estradier search
489     index. (Aka Please Please Please, let that be the last one.)
490   * Patch from Roland Mas to support an rss=no parameter to inline directives.
491     Closes: #380743
492   * Renamed GlobLists to PageSpecs.
493   * PageSpecs can now include nested parens, "and", and "or". This remains
494     backwards compatible to the old GlobList format. It's implemented by
495     treating the GlobList as a very limited microlanguage that is transformed
496     to perl code that does the matching.
497   * The old GlobList format is deprecated, and I encourage users to switch to
498     using the new PageSpec format. Compatability with the old format will be
499     removed at some point, possibly by 2.0.
500   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
501   * Add support for creation_month and creation_year to PageSpec.
502     Closes: #380680
503   * Changes to index file encoding.
504
505  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
506
507 ikiwiki (1.12) unstable; urgency=low
508
509   "Viva l'Italia!"
510   * New pagestats plugin from Enrico, which can generate a table counting
511     the backlinks for each page, or a del.icio.us style cloud.
512   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
513     the wikiformat plugin works. Thanks, Emanuele Aina.
514   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
515     display, running them through pagetitle. This removes ugly underscores and
516     other gunk from the display, much nicer. You may want to rebuild your wiki
517     when upgrading to get the cleanup globally.
518   * Polygen plugin from Enrico.
519   * htmltidy plugin from Faidon.
520   * Locale patch from Faidon:
521     - Adds a locale setting to setup files.
522     - Proper local time, if the locale configuration option is used.
523     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
524       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
525       impossible.
526   * Add getopt hook type, this allows plugins to add new command-line options.
527   * Add --tagbase option to tag plugin.
528   * Add exclude option in setup files, works same as --exclude.
529   * Put categories in rss feeds for tagged items.
530   * Allow preprocessor directives to be expanded in inlined blog pages.
531     However, to avoid inlining loops etc, don't expand inline directives in
532     inlined pages.
533   * fortune plugin (trivial)
534   * Tag plugins according to type.
535
536  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
537
538 ikiwiki (1.11) unstable; urgency=low
539
540   * Patch from Enrico that
541     - Adds a tag plugin that allows more easily tagging pages.
542       The meta plugin can also still be used for that, but the tag plugin
543       also lists a page's tags at the bottom of the page.
544     - Allows preprocessor directives to have parameters with no specified
545       value.
546     - Fixes preprocessor directive parameter parsing so that
547       foo=bar baz now means "foo=bar" and a "baz" with no value.
548   * Run pagetemplate hooks when inlining pages so that inlined pages also
549     list their tags.
550   * Make all plugins with pagetemplate hooks check that variables exist
551     on the template before setting them, for robustness.
552   * Switch pagetemplate hooks to using named parameters.
553   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
554     This will be the page that a source page will be part of, which is
555     different than the source page for inlined pages.
556   * Audited all plugins to endure they pass (page, destpage) to htmllink
557     appropriatly. This means inlining of various plugins will not work
558     properly, with correct links generated.
559
560  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
561
562 ikiwiki (1.10) unstable; urgency=low
563
564   * Run page through any relevant filters when generating a page preview.
565   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
566     default throughout the wiki, not only on wikitext pages. Decided to call
567     this a feature, and split the camelcase support out into a separate plugin
568     that is independant of wikitext.
569   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
570
571  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
572
573 ikiwiki (1.9) unstable; urgency=low
574
575   * Improve display of parentlinks and page title of toplevel index page.
576   * Patch from Faidon to use svn --limit when possible for recentchanges,
577     speeds up recentchanges a lot for wikis with more history.
578   * Patch from Recai to fix utf8 issues in git backend.
579   * Add wikitext markup plugin, which supports ".wiki" pages written in the
580     original wiki syntax, CamelCase links and all.
581   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
582     support, to edit pages etc without a web server.
583   * Display CGI processing errors if present.
584   * Fix from Faidon for a XML parser issue that breaks utf-8 for
585     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
586     area, and also way slow.
587   * Match 'web commit from' in SVN and git, these are web commits too.
588     (Faidon)
589   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
590     readable and avoid future mistakes. The patch seems to work and for the
591     first time I have a UTF-8 username ;-) (Faidon)
592   * Use form->field consistently, not form->param.
593   * Patch from Recai to allow selection of page type when creating a new page.
594     Default page type is inherited from the link clicked on to create the new
595     page.
596
597  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
598
599 ikiwiki (1.8) unstable; urgency=low
600
601   * Fix orphans plugin to not count a link to a nonexistant page as a reason
602     for a page not being an orphan.
603   * Support pinging services such as Technorati using XML-RPC to notify them
604     about changes to rss feeds.
605   * Parse svn log as xml for improved utf8 and security. Note that this makes
606     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
607   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
608     flagged string even if the locale causes it to generate utf8 output,
609     so make sure to let perl know it should be handled as utf8. Also,
610     the optimised version used for standard time formats won't work if the
611     user has changed locale, so drop it. Thanks, Faidon Liambotis.
612   * Fix re-encoding of the comments field to utf8 if a commit fails
613     due to a conflict. Thanks, Faidon Liambotis.
614   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
615     Liambotis.
616   * Add insane double encode/decode to utf8 around call to markdown.
617     This works around a truely strange bug, which is apparently a bug in
618     perl, #376329. Also added a test case for it.
619   * Improve layout of edit page so formatting help link is always visible w/o
620     getting in the way of the preview.
621   * Centralised all calls to HTML::Template and force all the templates
622     to be read as utf8.
623   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
624   * Introduce add_plugins and disable_plugins config options in setup files.
625     This allows adding or removing plugins w/o overriding the whole list of
626     default plugins, which makes it easier to upgrade when new default plugins
627     are added.
628   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
629     default (of course!). Based on a patch by Faidon Liambotis.
630   * Add a html plugin, which can be used to write wikis in raw html,
631     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
632     defaults to not processing .html files, since w/o this plugin they would
633     be copied unsanitised. With this plugin, it will process and html
634     sanitise them, like any other page type.
635   * Rebuilding wrappers is necessary on upgrade to this version.
636   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
637     will be automatically done on all upgrades.
638   * Don't send pings if the wiki is being rebuilt.
639   * Work around very innefficient behavior in File::Spec::abs2rel. Result
640     is a savings of 2 pointless fork/execs per link calculation, which
641     results in ~25% speedup of ikiwiki building its own doc wiki, and
642     about 35% speedup displaying RecentChanges!
643   * Make RecentChanges use a table and some CSS, should be much more readable.
644     No code changes involved.
645   * Encode & in diffurl in examples, to conform to pedantic rules.
646   * Speed up RecentChanges by another 40% or so with some memoization.
647   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
648     in time to build the doc wiki.
649
650  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
651
652 ikiwiki (1.7) unstable; urgency=low
653
654   * Updated logo from Recai with some kerning and alingment tuning.
655   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
656     changed some output.
657   * Copyright update.
658
659  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
660
661 ikiwiki (1.6) unstable; urgency=low
662
663   * YA utf-8 patch from Recai, this time to fix previewing a page so that
664     the text in the input box is re-encoded back to utf-8.
665   * -CSD does not affect modules, so readfile() was not using the utf-8 input
666     layer, which led to lots of problems; make it force read files as utf-8.
667     Closes: #373203
668   * Note that as a consequence, this version of ikiwiki will actually try to
669     parse utf8 in source files for the first time, which may expose broken
670     utf8 in wiki sources that was hidden before. Most common will be
671     perl warnings like "utf8 "\xE9" does not map to Unicode"
672   * writefile() likewise needs to use the utf8 output layer.
673   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
674     there.
675   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
676     given the readfile fix.
677   * Add utf-8 testcases for readfile and htmlize.
678   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
679     safe.
680   * More utf-8 fixes from Recai, partly to things I broke above:
681     - The serious problem is that writefile() saves the content in undecoded
682       format in CGI, hence all (non-ascii) chars are corrupted permanently.
683     - Comment field in edit page is not decoded and all the non-ascii chars in
684       this field are corrupted as the result.  We should decode it as we do it
685       for the content.
686     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
687       character in print.
688   * New SVG logo from Recai.
689
690  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
691
692 ikiwiki (1.5) unstable; urgency=low
693
694   * Add --timeformat config option to allow changing how dates are displayed.
695     Note that as a side effect, dates will now be displayed using the local
696     timezone, not as GMT.
697   * More security review.
698   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
699     for some handy stuff like:
700     - Using links as a kind of tag; creating blog pages that list all pages
701       containing a given tag/link or not containing some other tag.
702     - Subscribing to mail notifications whenever a change is made to a page
703       that is a backlink of page foo. Ie, "Please notify me of changes in all
704       pages that link to my home page in the wiki"
705     - Locking any pages that are linked to from a particular page, so that
706       lists of locks can be exposed in the wiki.
707   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
708     when a todo item is done, instead of the previous moving it to a different
709     subdir.
710   * Allow pagetemplate plugins to override *anything* in the template.
711   * Add a meta plugin, which allows specifying various metadata about pages,
712     like license and author. It also allows for inserting html link and meta
713     tags into html, overriding the title, and adding hidden WikiLinks, which
714     can be useful when using link-based globbing for page categorisation.
715   * Remove preprocessor directives from inlined pages.
716   * Allow simple preprocessor directive values to be specified w/o quotes.
717   * Add support for using git instead of subversion as the RCS backend,
718     tremendous thanks to Recai Oktaş for this.
719   * Doc updates for git.
720   * Fix absolute url munging in rss generation to support https, ftp, etc urls
721     not just http urls.
722   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
723     utf-8 for edit and other fields, and for recentchanges. There may still
724     be utf-8 issues with the preferences page though.
725
726  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
727
728 ikiwiki (1.4) unstable; urgency=low
729
730   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
731     very strange way of enabling proper XHTML <br /> type tags. Output html
732     should be always valid again now.
733   * The page name and parent links has switched from using a <h1> to a styled
734     <span>, so pages can use <h1> internally instead of needing to use <h2>.
735   * Updated all of ikiwiki's own wiki pages for that.
736   * Add pagetemplate hook, which can be used by plugins that want to mess
737     around with adding new stuff to the page template.
738   * Remove headercontent; the search plugin now adds the search box to the
739     header by registering a pagetemplate hook, and other plugins should do
740     similarly.
741   * Rebuilding on upgrade to this version is recommended.
742   * Add a html validity check to the test suite, using the wdg-html-validator,
743     if available.
744   * Make the html valid when there is nothing in the actions list.
745   * Reordered some function call parameters for consistency.
746   * Enable full utf-8 support for page input and output.
747   * Add a workaround for markdown, which does not work well with utf-8
748     strings.
749   * --getctime had bitrotted (well I only ever used it the once so far..),
750     fix and make it a bit more flexible
751   * rcs_getctime is changed, now rather than needing to loop over all pages,
752     it should just use the rcs to get the ctime of the passed file.
753   * When inlining a page in another one, links from the inlined page are now
754     expanded the same as they are when rendering the inlined page as a
755     standalone page. So rather than being expanded from the POV of the
756     inlining page, they are expanded from the POV of the inlined page.
757
758     For example, a link from blog/foo to "bar" will now link to blog/bar
759     if it exists. Previously this needed to be a link explicitly to
760     "blog/bar"; such links will also continue to work.
761
762     (This was slightly complex to do as the link still has to be constructed
763     relative to the inlining page.)
764   * Make page edit textarea resize to fit browser window.
765   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
766     do not need a full rebuild, in order to update any basewiki pages.
767
768  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
769
770 ikiwiki (1.3) unstable; urgency=low
771
772   * Fix the preinst introduced in the last version. Closes: #367458
773
774  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
775
776 ikiwiki (1.2) unstable; urgency=low
777
778   * Remove dups from the brokenlinks list.
779   * Add libc6-dev to dependencies, needed to build wrappers.
780   * Install wikilist in correct location. Closes: #367371
781
782  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
783
784 ikiwiki (1.1) unstable; urgency=low
785
786   * Rename inlinepage to depends, so that it can be used to refer to more
787     dependency relationships than just inlining. This will require a rebuild
788     on upgrade to this version.
789   * Move the rss link, put it in the blogpost form if there is one and at the
790     top if not. This is both nicer because easier to find, and it cleans up
791     the code which had used inlinepage as a flag for adding the link later.
792   * Allow the depends GlobList to be built up from multiple sources (such as
793     plugins) during a page render.
794   * Which means that more than one blog is now supported to appear on a
795     single page. (With some limitations, like only the last one getting an
796     rss file.)
797   * Added a plugin system.
798   * Added a pagecount plugin, enabled by default.
799   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
800   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
801     backlinks when the backlinks hadn't really changed.
802   * Moved inline page support, rss generation etc into the inline plugin,
803     enabled by default.
804   * Added brokenlinks plugin, not enabled by default, but rather handy.
805   * Fix several broken links in the doc wiki.
806   * Smarter behavior when creating a page and a page of the same name (but
807     different location) already exists.
808   * Add an orphans plugin for finding pages that nothing links to.
809   * Removed backlinks page, which it turns out nothing used.
810   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
811     it, this will allow for adding a unit test suite.
812   * Add unit tests for several core functions, including globlist_match,
813     dirname, basename, bestlink, linkify, pagetitle, titlepage.
814   * Smart globlist merging.
815   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
816     to pave the way for adding other RCS support. This also changes the
817     setup files, where before they had svn => 1 or svn => 0, now they have
818     rcs => "svn" or rcs => "".
819   * Add a debian/NEWS file with upgrade notes.
820   * Load whatever rcs module is specified, so new ones can be just dropped in
821     as plugins and work. (Well, in theory.)
822   * Add some basic docs about writing RCS modules.
823   * Broke search capability out into a plugin, removed the --hyperestraier
824     switch.
825   * Added smiley plugin, nicely controlled and documented by the smileys page.
826   * Copied in some smileys from Moin Moin.
827   * Allow links of the form [[some page|page]], with whitespace in the link
828     text.
829   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
830     and --disable-plugin htmlscrubber.
831   * Allow discussion links on pages to be turned off with --no-discussion.
832   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
833   * Add some new config items to the estseek.conf template, which are needed
834     by hyperestraier 1.2.3.
835
836  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
837
838 ikiwiki (1.0) unstable; urgency=low
839
840   * First official release.
841
842  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400