]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* Reorganised the doc wiki's todo/* pages, using a link/tag to flag
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.5) UNRELEASED; urgency=low
2
3   * Add --timeformat config option to allow changing how dates are displayed.
4     Note that as a side effect, dates will now be displayed using the local
5     timezone, not as GMT.
6   * More security review.
7   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
8     for some handy stuff like:
9     - Using links as a kind of tag; creating blog pages that list all pages
10       containing a given tag/link or not containing some other tag.
11     - Subscribing to mail notifications whenever a change is made to a page
12       that is a backlink of page foo. Ie, "Please notify me of changes in all
13       pages that link to my home page in the wiki"
14     - Locking any pages that are linked to from a particular page, so that
15       lists of locks can be exposed in the wiki.
16   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
17     when a todo item is done, instead of the previous moving it to a different
18     subdir.
19   * Allow pagetemplate plugins to override *anything* in the template.
20   * Add a meta plugin, which allows specifying various metadata about pages,
21     like license and author. It also allows for inserting html link and meta
22     tags into html, overriding the title, and adding hidden WikiLinks, which
23     can be useful when using link-based globbing for page categorisation.
24   * Remove preprocessor directives from inlined pages.
25   * Allow simple preprocessor directive values to be specified w/o quotes.
26
27  -- Joey Hess <joeyh@debian.org>  Thu,  1 Jun 2006 23:47:43 -0400
28
29 ikiwiki (1.4) unstable; urgency=low
30
31   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
32     very strange way of enabling proper XHTML <br /> type tags. Output html
33     should be always valid again now.
34   * The page name and parent links has switched from using a <h1> to a styled
35     <span>, so pages can use <h1> internally instead of needing to use <h2>.
36   * Updated all of ikiwiki's own wiki pages for that.
37   * Add pagetemplate hook, which can be used by plugins that want to mess
38     around with adding new stuff to the page template.
39   * Remove headercontent; the search plugin now adds the search box to the
40     header by registering a pagetemplate hook, and other plugins should do
41     similarly.
42   * Rebuilding on upgrade to this version is recommended.
43   * Add a html validity check to the test suite, using the wdg-html-validator,
44     if available.
45   * Make the html valid when there is nothing in the actions list.
46   * Reordered some function call parameters for consistency.
47   * Enable full utf-8 support for page input and output.
48   * Add a workaround for markdown, which does not work well with utf-8
49     strings.
50   * --getctime had bitrotted (well I only ever used it the once so far..),
51     fix and make it a bit more flexible
52   * rcs_getctime is changed, now rather than needing to loop over all pages,
53     it should just use the rcs to get the ctime of the passed file.
54   * When inlining a page in another one, links from the inlined page are now
55     expanded the same as they are when rendering the inlined page as a
56     standalone page. So rather than being expanded from the POV of the
57     inlining page, they are expanded from the POV of the inlined page.
58
59     For example, a link from blog/foo to "bar" will now link to blog/bar
60     if it exists. Previously this needed to be a link explicitly to
61     "blog/bar"; such links will also continue to work.
62
63     (This was slightly complex to do as the link still has to be constructed
64     relative to the inlining page.)
65   * Make page edit textarea resize to fit browser window.
66   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
67     do not need a full rebuild, in order to update any basewiki pages.
68
69  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
70
71 ikiwiki (1.3) unstable; urgency=low
72
73   * Fix the preinst introduced in the last version. Closes: #367458
74
75  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
76
77 ikiwiki (1.2) unstable; urgency=low
78
79   * Remove dups from the brokenlinks list.
80   * Add libc6-dev to dependencies, needed to build wrappers.
81   * Install wikilist in correct location. Closes: #367371
82
83  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
84
85 ikiwiki (1.1) unstable; urgency=low
86
87   * Rename inlinepage to depends, so that it can be used to refer to more
88     dependency relationships than just inlining. This will require a rebuild
89     on upgrade to this version.
90   * Move the rss link, put it in the blogpost form if there is one and at the
91     top if not. This is both nicer because easier to find, and it cleans up
92     the code which had used inlinepage as a flag for adding the link later.
93   * Allow the depends GlobList to be built up from multiple sources (such as
94     plugins) during a page render.
95   * Which means that more than one blog is now supported to appear on a
96     single page. (With some limitations, like only the last one getting an
97     rss file.)
98   * Added a plugin system.
99   * Added a pagecount plugin, enabled by default.
100   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
101   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
102     backlinks when the backlinks hadn't really changed.
103   * Moved inline page support, rss generation etc into the inline plugin,
104     enabled by default.
105   * Added brokenlinks plugin, not enabled by default, but rather handy.
106   * Fix several broken links in the doc wiki.
107   * Smarter behavior when creating a page and a page of the same name (but
108     different location) already exists.
109   * Add an orphans plugin for finding pages that nothing links to.
110   * Removed backlinks page, which it turns out nothing used.
111   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
112     it, this will allow for adding a unit test suite.
113   * Add unit tests for several core functions, including globlist_match,
114     dirname, basename, bestlink, linkify, pagetitle, titlepage.
115   * Smart globlist merging.
116   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
117     to pave the way for adding other RCS support. This also changes the
118     setup files, where before they had svn => 1 or svn => 0, now they have
119     rcs => "svn" or rcs => "".
120   * Add a debian/NEWS file with upgrade notes.
121   * Load whatever rcs module is specified, so new ones can be just dropped in
122     as plugins and work. (Well, in theory.)
123   * Add some basic docs about writing RCS modules.
124   * Broke search capability out into a plugin, removed the --hyperestraier
125     switch.
126   * Added smiley plugin, nicely controlled and documented by the smileys page.
127   * Copied in some smileys from Moin Moin.
128   * Allow links of the form [[some page|page]], with whitespace in the link
129     text.
130   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
131     and --disable-plugin htmlscrubber.
132   * Allow discussion links on pages to be turned off with --no-discussion.
133   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
134   * Add some new config items to the estseek.conf template, which are needed
135     by hyperestraier 1.2.3.
136
137  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
138
139 ikiwiki (1.0) unstable; urgency=low
140
141   * First official release.
142
143  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400