]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit by http://joey.kitenet.net/: test commit
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Change how post signin actions are propigated through the signin process;
13     they're now stored in the session.
14   * Add optional "desc" parameter to shortcut definitions.
15   * Avoid locking the wiki at all when handling some basic cgi stuff
16     (searches, recentchanges).
17   * Add "last" parameter to hook function. Very basic ordering, and hopefully
18     nothing more spohisticated will be needed.
19   * Add formbuilder_setup and formbuilder hooks.
20   * Split out a passwordauth module, that holds all the traditional password
21     based authentication etc code. It's enabled by default, but can be disabled
22     if you want only openid or some other auth method.
23   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
24   * Add some code to the build system that tries to determine if the
25     lib installation directory is in @INC. If it's not, munge ikiwiki
26     to hardcode the path to the lib directory. This should allow installing
27     ikiwiki in nonstandard locations, including home directories, by just
28     setting PREFIX at build time.
29   * Fix nested examples directory in deb.
30
31  -- Joey Hess <joeyh@debian.org>  Mon, 20 Nov 2006 16:49:05 -0500
32
33 ikiwiki (1.33) unstable; urgency=low
34
35   * Fix issue with aggregate plugin updating expired pages.
36   * Avoid syntax errors in templates used by the template plugin crashing
37     ikiwiki.
38   * Enable utf8 file IO in aggregate plugin.
39   * Fix some issues with the new registration form.
40   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
41   * Make sure to check for errors from every eval.
42   * Fix img plugin's handling of adding dependencies for images that do not
43     yet exist.
44   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
45     FORM-SUBMIT unusable on customised formbuilder templates. For now,
46     hardcode the submit buttons in editpage.tmpl instead of using the
47     template variable, which is ok, since the buttons are static.
48   * Work with hyperestraier 1.4.9.
49
50  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
51
52 ikiwiki (1.32) unstable; urgency=low
53
54   * Add a separate pass to find page links, and only render each page once,
55     instead of over and over. Typical speedup is ~4x. Max possible speedup:
56     8x.
57   * Add "scan" parameter to hook(), which is used to make the hook be called
58     during the scanning pass, as well as the render pass. The meta and tag
59     plugins need to use the new scan parameter, so will any others that modify
60     %links.
61   * Now that links are calculated in a separate pass, it can also
62     precalculate backlinks in one pass, which is O(N^2) instead of the
63     previous code that was O(N^3). A very nice speedup for wikis with lots
64     (thousands) of pages.
65   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
66     Erdem.
67   * Add a default stylesheet entry for the pagecloud.
68   * Add examples page with some examples of things that can be done using
69     ikiwiki, like a weblog. The examples can be copied into a user's wiki
70     for a quick start, without needing to learn everything about how to put
71     them together.
72   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
73   * Add perlmagick to build-depends so syntax check of img plugin works.
74     Closes: #396702
75   * Improve login/register process, the login dialog has only name and
76     password fields, which allows more web browsers to regognise it as a login
77     field, and is less confusing.
78   * Implemented expiry options for aggregate plugin.
79   * Use precalculated backlinks info when determining if files need an update
80     due to a page they link to being added/removed. Mostly significant if
81     there are lots of pages.
82   * Remove duplicate link info when saving index. In some cases it could
83     pile up rather badly. (Probably not the best way to deal with this
84     problem.)
85   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
86     or what have you, by creating enclosures for non-page items that are
87     included in feeds.
88
89  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
90
91 ikiwiki (1.31) unstable; urgency=low
92
93   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
94   * Change the rss feed title from the wikiname to the page title, with
95     an exception for the wiki's toplevel index page, which will still use the
96     wikiname as the feed title.
97     Overriding the page title with meta title already overrode the rss feed
98     tittle.
99   * Add an img plugin, based on Christian Mock's img plugin, but stripped
100     down to the bare essentials. Useful for handling large images on websites.
101   * Sanitize possibly problimatic characters out of the polygen grammar names,
102     just in case. Should not be exploitable anyway, since it only tries to run
103     polygen after finding the specified grammar file.
104   * Add missing dependency on the URI perl module.
105   * Add basic spam fighting tool for admins: An admin's prefs page now allows
106     editing a list of banned users.
107
108  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
109
110 ikiwiki (1.30) unstable; urgency=low
111
112   * Add no_override parameter to hook().
113   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
114     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
115     can be configured using a page in wiki.
116   * Fix support for --pingurl at the command line.
117   * Fix a subtle bug in will_render that broke some builds, by only clearing
118     items from renderedfiles the first time per build.
119   * Wrap entire technortati ping operation in an eval to catch all possible
120     failure modes, after I observed a simple ->value crashing ikiwiki when
121     a ping failed.
122
123  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
124
125 ikiwiki (1.29) unstable; urgency=low
126
127   * Patch from Paul Tötterman to use CP in the Makefile.
128   * Patch from Alec Berryman adding a http_auth config item that allows
129     using HTTP Authentication instead of ikiwiki's built in authentication.
130     Useful for eg, large sites with their own previously existing user auth
131     setup. Closes: #384534
132   * Change %renderedfiles to store an array of files rendered from a given
133     source file, to allow tracking of extra rendered files like rss feeds.
134   * Note that plugins that accessed this variable will need to be updated!
135     The plugin interface has been increased to version 1.01 for this change.
136     As few plugins use %renderedfiles I haven't done anything else to ensure
137     compatability of old plugins.
138   * Add will_render function to the plugin interface, used to register that a
139     page renders a destination file, and do some security checks. Previously
140     but no longer rendered files will be cleaned up.
141   * Use will_render in the inline and linkmap plugins.
142   * You will need to rebuild your wiki on upgrade to this version.
143   * Atom feed support based on a patch by Clint Adams.
144   * Add feeds=no option to inline preprocessor directive to turn off all types
145     of feeds.
146   * $IkiWiki::version now holds the program version, and is accessible to
147     plugins.
148   * Make the aggregate plugin emphasize error messages.
149   * Patch from Recai to limit recentchanges to displaying max 10 files for a
150     given changeset (to avoid large number of file changes excessively
151     bloating the page).
152
153  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
154
155 ikiwiki (1.28) unstable; urgency=low
156
157   * inline: Add ability to sort by page name, based on a patch from
158     Benjamin A'Lee.
159   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
160     braindead interface. Closes: #389383
161   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
162     and b) those poor Mac OSX users and their case insensative files!
163   * Don't fail syntax check if Text::Typography isn't installed.
164     Closes: #389406
165
166  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
167
168 ikiwiki (1.27) unstable; urgency=low
169
170   * Work on firming up the plugin interface:
171     - Plugins should not need to load IkiWiki::Render to get commonly
172       used functions, so moved some functions from there to IkiWiki.
173     - Picked out the set of functions and variables that most plugins
174       use, documented them, and made IkiWiki export them by default,
175       like a proper perl module should.
176     - Use the other functions at your own risk.
177     - This is not quite complete, I still have to decide whether to
178       export some other things.
179   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
180     referring to stuff now exported by the IkiWiki module.
181   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
182     to declare which version of the interface your plugin needs.
183   * Anyone with a third-party ikiwiki plugin is strongly encouraged
184     to make like changes to it and avoid use of non-exported symbols from
185     "IkiWiki::".
186   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
187   * Support hyperestradier version 1.4.2, which adds a new required phraseform
188     setting.
189   * If an inlined page has a permalink, link the page title to that.
190   * Patch from Recai to use utf8 when reading the setup file, so that
191     utf8 wikinames from there will be used properly.
192   * Patch from Recai to kill utf-8 on the wiki name when generating the
193     session cookie.
194   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
195   * Fix a baseurl problem in hyperestradier search results.
196   * Add a stub local.css to avoid problems with 404's.
197   * Patch from Recai to fix a wide character warning from the search plugin
198     during setup if the wikiname contains utf8.
199   * Yet another fix for those poor case-insensative OS X users.
200   * pagetemplate hooks are now also called when generating cgi pages.
201   * Add a favicon plugin, which simply adds a link tag for an icon to each
202     page (and cgis).
203   * Patch from James Westby to deal with the case where you're editing a
204     new page, hit cancel, and need to be redirected to somewhere sane.
205   * Various documentation improvements by various wiki users.
206   * Support Text::Markdown from CPAN, which has a different interface from
207     the original markdown or the one in Debian.
208   * Version the libcgi-session-perl dependency, some features that need
209     the new version are used in some cases (sslcookie).
210   * Numerous tla fixes from Clint.
211   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
212     a multi-resolution favicon.ico.
213   * README.Debian: typo Closes: #388110
214   * chomp trailing newline at the end of templates read in by the template
215     plugin, to allow use of the template preprocessor directive in
216     whitespace-sensative situations. Closes: #387073
217   * Patch from James Westby to make the location of the estseek.cgi script
218     configurable.
219   * Add typography (SmartyPants) plugin by Recai.
220   * Add --render mode, which can be used to preview an edit at the command
221     line by test rendering a single page.
222   * Add a googlecalendar plugin. A bit special-purpose, but it shows
223     one way to to deal with user-supplied content that could cause XSS
224     issues w/o the htmlscrubber, and won't survive the scrubber.
225
226  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
227
228 ikiwiki (1.26) unstable; urgency=low
229
230   * Add a missing -n to tla undo call.
231   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
232     writes before consuming its whole stdin. Avoid this deadlock.
233   * Fix alt tags for outline checkboxes.
234
235  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
236
237 ikiwiki (1.25) unstable; urgency=low
238
239   * Add proper waitpid calls for open2ed processes throughout to avoid
240     zombies; this hit htmltidy especially badly.
241   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
242     subversion repos and fixing some other issues.
243   * Add support for tla, contributed by Clint Adams. Closes: #385936
244   * Add support for mercurial, contributed by Emanuele Aina.
245   * Include <link rel> tag for RSS feeds, used by some aggregators and
246     firefox to find the feed.
247   * Add a linkmap plugin (requires graphviz).
248
249  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
250
251 ikiwiki (1.24) unstable; urgency=low
252
253   * Simplify the data structure returned by rcs_recentchanges to avoid
254     each rcs plugin needing to form complex strings on its own.
255   * Fix another destpage issue in the inline directive. Closes: #385512
256     again.
257
258  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
259
260 ikiwiki (1.23) unstable; urgency=low
261
262   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
263
264  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
265
266 ikiwiki (1.22) unstable; urgency=low
267
268   * Change how the stylesheet url is determined in the templates: Remove
269     STYLEURL and add BASEURL to all templates (some already had it). This
270     new more general variable can be used to link to other things (eg, images)
271     from the template, as well as stylesheets.
272   * Fix a bug introduced last version to do with nested inlines.
273   * Allow preprocessor directives to span multiple lines, both to make
274     long ones with lots of values easier to write, and to allow for ones with
275     multi-line quoted values.
276   * Allow preprocessor directives to contain python-like triple-quoted
277     text blocks, for easy nesting of quotes inside.
278   * Add a template plugin.
279   * Make pagespec merge code smarter about merging duplicate pagespecs.
280   * Patch from Jordà Polo to make Setup::Standard support hashes in config
281     files.
282   * Change order of linkify and preprocess; first preprocess and then linkify.
283     This allows passing a wikilink inside a parameter to a preprocessor
284     directive without it being expanded to html, and leaking out of the
285     parameter, which had required some non-obvious use of triple-quoting
286     to avoid. Note that any preprocessor plugins that output something
287     that looks like a wikilink will now have it treated as such; AFAIK
288     this doesn't change any behavior though except for the template plugin.
289   * Enable preprocessor directives when previewing an edit.
290   * Make all pages pull in a local.css style sheet, if present. This won't
291     be included in ikiwiki, but can be created to make local styling changes
292     w/o needing to merge in every new change to the distributed style.css.
293   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
294   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
295     from a different directory.
296   * Generalised preprocesser loop protection code.
297   * Patch from James Westby to allow a description to be set for rss feeds.
298   * Patch from James Westby to add a template for the search form.
299   * Added a ddate plugin.
300   * Patch from James Westby to add a --sslcookie switch, which forces
301     cookies to only be sent over ssl connections to avoid interception.
302   * Fix preferences page on anonok wikis; still need to sign in to get
303     to the preferences page.
304   * Add toc (table of contents) plugin.
305   * Change htmlize, format, and sanitize hooks to use named parameters.
306   * Patch from James Westby to add an actions option to inline; this
307     adds Edit and Discussion links at the end of blog entries.
308   * Due to some css changes, you'll want to rebuild your wiki on upgrade
309     to this version. Will be handled automatically by the deb.
310   * Add processed date to aggregate preprocessor directive status output.
311
312  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
313
314 ikiwiki (1.21) unstable; urgency=low
315
316   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
317   * If a page links to itself, mark up the link text in a span with
318     class="selflink" so that it can be styled. I don't have a useful style
319     defined for that though.
320   * Call filter hooks on inlined page content.
321   * Support inlining pages raw, rather than creating a blog.
322   * Clean up yes/no parameter parsing in inline plugin.
323   * Implemented better cycle detection in the inline plugin; nested inlines
324     will now work.
325   * Add a map plugin contributed by Alessandro Dotti Contra.
326   * Add otl format plugin, which handles files as created by vimoutliner.
327   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
328   * Add first draft at a Restructured Text (rst) plugin, by Sergio
329     Talens-Oliag. Note that this has many known issues -- see the caveats on
330     the plugin's page.
331   * Credit everyone who wrote a plugin on the plugins' wiki pages.
332   * Fix utf-8 in blog post form.
333
334  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
335
336 ikiwiki (1.20) unstable; urgency=low
337
338   * Relicense the templates and basewiki under the 2-clause BSD license.
339     Since these can easily become part of other people's websites, they
340     should be under as permissive a license as possible.
341   * Add --syslog config option, to log to the syslog.
342   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
343     transient failure to fork (which I've seen happen in the wild).
344   * Fix a bug in the aggregator introduced last version that caused all
345     aggregator state to be lost during a non-aggregating build.
346
347  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
348
349 ikiwiki (1.19) unstable; urgency=low
350
351   * Fix several related bugs in page type determination during online editing.
352   * Add some locking to prevent 2 aggregators from running at once.
353   * Fix an infinite loop in the aggregator when finding a unique filename.
354
355  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
356
357 ikiwiki (1.18) unstable; urgency=low
358
359   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
360   * Add --version.
361   * Man page format fixups.
362   * If the meta plugin overides the page title, set a title_overridden
363     variable in the template to true. This allows doing things with the
364     templates conditional on the title being overriden.
365   * Add a %pagecase which maps lower-case page names to the actual case
366     used in the filename. Use this in bestlinks calculation instead of
367     forcing the link to lowercase.
368   * Also use %pagecase in various other places that want to check if a page
369     with a given name exists.
370   * This means that links to pages with mixed case names will now work,
371     even if the link is in some other case mixture, and mixed case pages
372     should be fully supported throughout ikiwiki.
373   * Recommend rebuilding wikis on upgrade to this version.
374
375  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
376
377 ikiwiki (1.17) unstable; urgency=low
378
379   * Disable tidy generator tag.
380   * Move tidy back to sanitize hook, found out how to only show body.
381   * Turn off tidy indentation too.
382   * Turn on HTML::Template loop_context_vars; not actually used in stock
383     templates but can be useful for things like making comma-delimited lists
384     of tags or what have you.
385   * Remove <br> from end of aggregate preprocessor directive output.
386   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
387     case-sensative filesystems like OSX.
388   * Improve markdown loading. First, try to load it as a proper perl module,
389     in case it was installed as one. Then fall back to trying
390     /usr/bin/markdown.
391   * Document in install page how to install markdown, since it has no
392     installation procedure in the upstream tarball.
393   * Set die_on_bad_params => 0 for all templates, to allow users to modify
394     them without annoyances.
395   * Suck in the page content when generating an inline archive page, to work
396     around the meta plugin's lack of caching of title metadata across runs.
397
398  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
399
400 ikiwiki (1.16) unstable; urgency=low
401
402   * Try to handle relative links in aggregated feeds. However,
403     the current support is a crude hack due to limitations of XML::Feed:
404     xml:base is not supported, neither is Content-Location. And of course,
405     relative links in RSS feeds are ill-undefined..
406   * Make aggregator save permalinks and author name to pages as metadata.
407   * Add permalink and author support to meta plugin, affecting RSS feeds
408     and blog pages.
409   * Various CSS and formatting changes.
410   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
411   * Add xhtml files to the default prune regexp.
412   * Also generate rel=bookmark links for permalinks.
413   * Fix the htmltidy plugin, which wasn't working due my breaking it when
414     I added it..
415   * Don't run tidy with -xml as that fails if the input is not well-formed.
416     Run it with -asxhtml instead, so it will output well-formed xhtml no
417     matter what the input.
418   * Disable tidy warnings too.
419   * Add a new format hook, and make tidy use it, since tidy can really only
420     operate on and output complete html documents, not the body chunks
421     that sanitise gets.
422   * Fix dates in rss feeds if running localised, so they're still rfc 822.
423
424  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
425
426 ikiwiki (1.15) unstable; urgency=low
427
428   * Remove CDPATH and other env vars perl taint checking doesn't like.
429     Closes: #381279
430   * Added created_before and created_after PageSpec limits.
431
432  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
433
434 ikiwiki (1.14) unstable; urgency=low
435
436   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
437     by 10% or so.
438   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
439   * Added many unit tests for pagespec_match.
440
441  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
442
443 ikiwiki (1.13) unstable; urgency=low
444
445   * ikiwiki can now download and aggregate feeds with its new aggregate
446     plugin, so it's possible to implement a Planet using ikiwiki!
447   * Add a run_hooks function for the common task of running all hooks of a
448     given type.
449   * Add a savestate hook.
450   * Don't put blog post forms on pages if there's no cgiurl set.
451   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
452     --wrappers to do that.
453   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
454     to update pages that haven't changed on disk.
455   * Change meta tags to use html entity-escaped text for values, so that
456     quotes and such can be represented in title tags.
457   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
458     for the above.
459   * Make --rebuild also cause --aggregate to re-download and write aggregated
460     pages.
461   * Avoid outputting duplicate meta info.
462   * Include title metadata on aggregated posts for capitalised and un-munged
463     titles.
464   * Title metadata of inlined pages now shows up in blogs and rss feeds.
465   * Fix issue with unicode filenames and updating the hyper estradier search
466     index. (Aka Please Please Please, let that be the last one.)
467   * Patch from Roland Mas to support an rss=no parameter to inline directives.
468     Closes: #380743
469   * Renamed GlobLists to PageSpecs.
470   * PageSpecs can now include nested parens, "and", and "or". This remains
471     backwards compatible to the old GlobList format. It's implemented by
472     treating the GlobList as a very limited microlanguage that is transformed
473     to perl code that does the matching.
474   * The old GlobList format is deprecated, and I encourage users to switch to
475     using the new PageSpec format. Compatability with the old format will be
476     removed at some point, possibly by 2.0.
477   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
478   * Add support for creation_month and creation_year to PageSpec.
479     Closes: #380680
480   * Changes to index file encoding.
481
482  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
483
484 ikiwiki (1.12) unstable; urgency=low
485
486   "Viva l'Italia!"
487   * New pagestats plugin from Enrico, which can generate a table counting
488     the backlinks for each page, or a del.icio.us style cloud.
489   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
490     the wikiformat plugin works. Thanks, Emanuele Aina.
491   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
492     display, running them through pagetitle. This removes ugly underscores and
493     other gunk from the display, much nicer. You may want to rebuild your wiki
494     when upgrading to get the cleanup globally.
495   * Polygen plugin from Enrico.
496   * htmltidy plugin from Faidon.
497   * Locale patch from Faidon:
498     - Adds a locale setting to setup files.
499     - Proper local time, if the locale configuration option is used.
500     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
501       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
502       impossible.
503   * Add getopt hook type, this allows plugins to add new command-line options.
504   * Add --tagbase option to tag plugin.
505   * Add exclude option in setup files, works same as --exclude.
506   * Put categories in rss feeds for tagged items.
507   * Allow preprocessor directives to be expanded in inlined blog pages.
508     However, to avoid inlining loops etc, don't expand inline directives in
509     inlined pages.
510   * fortune plugin (trivial)
511   * Tag plugins according to type.
512
513  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
514
515 ikiwiki (1.11) unstable; urgency=low
516
517   * Patch from Enrico that
518     - Adds a tag plugin that allows more easily tagging pages.
519       The meta plugin can also still be used for that, but the tag plugin
520       also lists a page's tags at the bottom of the page.
521     - Allows preprocessor directives to have parameters with no specified
522       value.
523     - Fixes preprocessor directive parameter parsing so that
524       foo=bar baz now means "foo=bar" and a "baz" with no value.
525   * Run pagetemplate hooks when inlining pages so that inlined pages also
526     list their tags.
527   * Make all plugins with pagetemplate hooks check that variables exist
528     on the template before setting them, for robustness.
529   * Switch pagetemplate hooks to using named parameters.
530   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
531     This will be the page that a source page will be part of, which is
532     different than the source page for inlined pages.
533   * Audited all plugins to endure they pass (page, destpage) to htmllink
534     appropriatly. This means inlining of various plugins will not work
535     properly, with correct links generated.
536
537  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
538
539 ikiwiki (1.10) unstable; urgency=low
540
541   * Run page through any relevant filters when generating a page preview.
542   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
543     default throughout the wiki, not only on wikitext pages. Decided to call
544     this a feature, and split the camelcase support out into a separate plugin
545     that is independant of wikitext.
546   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
547
548  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
549
550 ikiwiki (1.9) unstable; urgency=low
551
552   * Improve display of parentlinks and page title of toplevel index page.
553   * Patch from Faidon to use svn --limit when possible for recentchanges,
554     speeds up recentchanges a lot for wikis with more history.
555   * Patch from Recai to fix utf8 issues in git backend.
556   * Add wikitext markup plugin, which supports ".wiki" pages written in the
557     original wiki syntax, CamelCase links and all.
558   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
559     support, to edit pages etc without a web server.
560   * Display CGI processing errors if present.
561   * Fix from Faidon for a XML parser issue that breaks utf-8 for
562     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
563     area, and also way slow.
564   * Match 'web commit from' in SVN and git, these are web commits too.
565     (Faidon)
566   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
567     readable and avoid future mistakes. The patch seems to work and for the
568     first time I have a UTF-8 username ;-) (Faidon)
569   * Use form->field consistently, not form->param.
570   * Patch from Recai to allow selection of page type when creating a new page.
571     Default page type is inherited from the link clicked on to create the new
572     page.
573
574  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
575
576 ikiwiki (1.8) unstable; urgency=low
577
578   * Fix orphans plugin to not count a link to a nonexistant page as a reason
579     for a page not being an orphan.
580   * Support pinging services such as Technorati using XML-RPC to notify them
581     about changes to rss feeds.
582   * Parse svn log as xml for improved utf8 and security. Note that this makes
583     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
584   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
585     flagged string even if the locale causes it to generate utf8 output,
586     so make sure to let perl know it should be handled as utf8. Also,
587     the optimised version used for standard time formats won't work if the
588     user has changed locale, so drop it. Thanks, Faidon Liambotis.
589   * Fix re-encoding of the comments field to utf8 if a commit fails
590     due to a conflict. Thanks, Faidon Liambotis.
591   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
592     Liambotis.
593   * Add insane double encode/decode to utf8 around call to markdown.
594     This works around a truely strange bug, which is apparently a bug in
595     perl, #376329. Also added a test case for it.
596   * Improve layout of edit page so formatting help link is always visible w/o
597     getting in the way of the preview.
598   * Centralised all calls to HTML::Template and force all the templates
599     to be read as utf8.
600   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
601   * Introduce add_plugins and disable_plugins config options in setup files.
602     This allows adding or removing plugins w/o overriding the whole list of
603     default plugins, which makes it easier to upgrade when new default plugins
604     are added.
605   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
606     default (of course!). Based on a patch by Faidon Liambotis.
607   * Add a html plugin, which can be used to write wikis in raw html,
608     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
609     defaults to not processing .html files, since w/o this plugin they would
610     be copied unsanitised. With this plugin, it will process and html
611     sanitise them, like any other page type.
612   * Rebuilding wrappers is necessary on upgrade to this version.
613   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
614     will be automatically done on all upgrades.
615   * Don't send pings if the wiki is being rebuilt.
616   * Work around very innefficient behavior in File::Spec::abs2rel. Result
617     is a savings of 2 pointless fork/execs per link calculation, which
618     results in ~25% speedup of ikiwiki building its own doc wiki, and
619     about 35% speedup displaying RecentChanges!
620   * Make RecentChanges use a table and some CSS, should be much more readable.
621     No code changes involved.
622   * Encode & in diffurl in examples, to conform to pedantic rules.
623   * Speed up RecentChanges by another 40% or so with some memoization.
624   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
625     in time to build the doc wiki.
626
627  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
628
629 ikiwiki (1.7) unstable; urgency=low
630
631   * Updated logo from Recai with some kerning and alingment tuning.
632   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
633     changed some output.
634   * Copyright update.
635
636  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
637
638 ikiwiki (1.6) unstable; urgency=low
639
640   * YA utf-8 patch from Recai, this time to fix previewing a page so that
641     the text in the input box is re-encoded back to utf-8.
642   * -CSD does not affect modules, so readfile() was not using the utf-8 input
643     layer, which led to lots of problems; make it force read files as utf-8.
644     Closes: #373203
645   * Note that as a consequence, this version of ikiwiki will actually try to
646     parse utf8 in source files for the first time, which may expose broken
647     utf8 in wiki sources that was hidden before. Most common will be
648     perl warnings like "utf8 "\xE9" does not map to Unicode"
649   * writefile() likewise needs to use the utf8 output layer.
650   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
651     there.
652   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
653     given the readfile fix.
654   * Add utf-8 testcases for readfile and htmlize.
655   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
656     safe.
657   * More utf-8 fixes from Recai, partly to things I broke above:
658     - The serious problem is that writefile() saves the content in undecoded
659       format in CGI, hence all (non-ascii) chars are corrupted permanently.
660     - Comment field in edit page is not decoded and all the non-ascii chars in
661       this field are corrupted as the result.  We should decode it as we do it
662       for the content.
663     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
664       character in print.
665   * New SVG logo from Recai.
666
667  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
668
669 ikiwiki (1.5) unstable; urgency=low
670
671   * Add --timeformat config option to allow changing how dates are displayed.
672     Note that as a side effect, dates will now be displayed using the local
673     timezone, not as GMT.
674   * More security review.
675   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
676     for some handy stuff like:
677     - Using links as a kind of tag; creating blog pages that list all pages
678       containing a given tag/link or not containing some other tag.
679     - Subscribing to mail notifications whenever a change is made to a page
680       that is a backlink of page foo. Ie, "Please notify me of changes in all
681       pages that link to my home page in the wiki"
682     - Locking any pages that are linked to from a particular page, so that
683       lists of locks can be exposed in the wiki.
684   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
685     when a todo item is done, instead of the previous moving it to a different
686     subdir.
687   * Allow pagetemplate plugins to override *anything* in the template.
688   * Add a meta plugin, which allows specifying various metadata about pages,
689     like license and author. It also allows for inserting html link and meta
690     tags into html, overriding the title, and adding hidden WikiLinks, which
691     can be useful when using link-based globbing for page categorisation.
692   * Remove preprocessor directives from inlined pages.
693   * Allow simple preprocessor directive values to be specified w/o quotes.
694   * Add support for using git instead of subversion as the RCS backend,
695     tremendous thanks to Recai Oktaş for this.
696   * Doc updates for git.
697   * Fix absolute url munging in rss generation to support https, ftp, etc urls
698     not just http urls.
699   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
700     utf-8 for edit and other fields, and for recentchanges. There may still
701     be utf-8 issues with the preferences page though.
702
703  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
704
705 ikiwiki (1.4) unstable; urgency=low
706
707   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
708     very strange way of enabling proper XHTML <br /> type tags. Output html
709     should be always valid again now.
710   * The page name and parent links has switched from using a <h1> to a styled
711     <span>, so pages can use <h1> internally instead of needing to use <h2>.
712   * Updated all of ikiwiki's own wiki pages for that.
713   * Add pagetemplate hook, which can be used by plugins that want to mess
714     around with adding new stuff to the page template.
715   * Remove headercontent; the search plugin now adds the search box to the
716     header by registering a pagetemplate hook, and other plugins should do
717     similarly.
718   * Rebuilding on upgrade to this version is recommended.
719   * Add a html validity check to the test suite, using the wdg-html-validator,
720     if available.
721   * Make the html valid when there is nothing in the actions list.
722   * Reordered some function call parameters for consistency.
723   * Enable full utf-8 support for page input and output.
724   * Add a workaround for markdown, which does not work well with utf-8
725     strings.
726   * --getctime had bitrotted (well I only ever used it the once so far..),
727     fix and make it a bit more flexible
728   * rcs_getctime is changed, now rather than needing to loop over all pages,
729     it should just use the rcs to get the ctime of the passed file.
730   * When inlining a page in another one, links from the inlined page are now
731     expanded the same as they are when rendering the inlined page as a
732     standalone page. So rather than being expanded from the POV of the
733     inlining page, they are expanded from the POV of the inlined page.
734
735     For example, a link from blog/foo to "bar" will now link to blog/bar
736     if it exists. Previously this needed to be a link explicitly to
737     "blog/bar"; such links will also continue to work.
738
739     (This was slightly complex to do as the link still has to be constructed
740     relative to the inlining page.)
741   * Make page edit textarea resize to fit browser window.
742   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
743     do not need a full rebuild, in order to update any basewiki pages.
744
745  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
746
747 ikiwiki (1.3) unstable; urgency=low
748
749   * Fix the preinst introduced in the last version. Closes: #367458
750
751  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
752
753 ikiwiki (1.2) unstable; urgency=low
754
755   * Remove dups from the brokenlinks list.
756   * Add libc6-dev to dependencies, needed to build wrappers.
757   * Install wikilist in correct location. Closes: #367371
758
759  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
760
761 ikiwiki (1.1) unstable; urgency=low
762
763   * Rename inlinepage to depends, so that it can be used to refer to more
764     dependency relationships than just inlining. This will require a rebuild
765     on upgrade to this version.
766   * Move the rss link, put it in the blogpost form if there is one and at the
767     top if not. This is both nicer because easier to find, and it cleans up
768     the code which had used inlinepage as a flag for adding the link later.
769   * Allow the depends GlobList to be built up from multiple sources (such as
770     plugins) during a page render.
771   * Which means that more than one blog is now supported to appear on a
772     single page. (With some limitations, like only the last one getting an
773     rss file.)
774   * Added a plugin system.
775   * Added a pagecount plugin, enabled by default.
776   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
777   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
778     backlinks when the backlinks hadn't really changed.
779   * Moved inline page support, rss generation etc into the inline plugin,
780     enabled by default.
781   * Added brokenlinks plugin, not enabled by default, but rather handy.
782   * Fix several broken links in the doc wiki.
783   * Smarter behavior when creating a page and a page of the same name (but
784     different location) already exists.
785   * Add an orphans plugin for finding pages that nothing links to.
786   * Removed backlinks page, which it turns out nothing used.
787   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
788     it, this will allow for adding a unit test suite.
789   * Add unit tests for several core functions, including globlist_match,
790     dirname, basename, bestlink, linkify, pagetitle, titlepage.
791   * Smart globlist merging.
792   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
793     to pave the way for adding other RCS support. This also changes the
794     setup files, where before they had svn => 1 or svn => 0, now they have
795     rcs => "svn" or rcs => "".
796   * Add a debian/NEWS file with upgrade notes.
797   * Load whatever rcs module is specified, so new ones can be just dropped in
798     as plugins and work. (Well, in theory.)
799   * Add some basic docs about writing RCS modules.
800   * Broke search capability out into a plugin, removed the --hyperestraier
801     switch.
802   * Added smiley plugin, nicely controlled and documented by the smileys page.
803   * Copied in some smileys from Moin Moin.
804   * Allow links of the form [[some page|page]], with whitespace in the link
805     text.
806   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
807     and --disable-plugin htmlscrubber.
808   * Allow discussion links on pages to be turned off with --no-discussion.
809   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
810   * Add some new config items to the estseek.conf template, which are needed
811     by hyperestraier 1.2.3.
812
813  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
814
815 ikiwiki (1.0) unstable; urgency=low
816
817   * First official release.
818
819  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400