]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* Run page through any relevant filters when generating a page preview.
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.10) UNRELEASED; urgency=low
2
3   * Run page through any relevant filters when generating a page preview.
4   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
5     default throughout the wiki, not only on wikitext pages. Decided to call
6     this a feature, and split the camelcase support out into a separate plugin
7     that is independant of wikitext.
8
9  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:44:25 -0400
10
11 ikiwiki (1.9) unstable; urgency=low
12
13   * Improve display of parentlinks and page title of toplevel index page.
14   * Patch from Faidon to use svn --limit when possible for recentchanges,
15     speeds up recentchanges a lot for wikis with more history.
16   * Patch from Recai to fix utf8 issues in git backend.
17   * Add wikitext markup plugin, which supports ".wiki" pages written in the
18     original wiki syntax, CamelCase links and all.
19   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
20     support, to edit pages etc without a web server.
21   * Display CGI processing errors if present.
22   * Fix from Faidon for a XML parser issue that breaks utf-8 for
23     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
24     area, and also way slow.
25   * Match 'web commit from' in SVN and git, these are web commits too.
26     (Faidon)
27   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
28     readable and avoid future mistakes. The patch seems to work and for the
29     first time I have a UTF-8 username ;-) (Faidon)
30   * Use form->field consistently, not form->param.
31   * Patch from Recai to allow selection of page type when creating a new page.
32     Default page type is inherited from the link clicked on to create the new
33     page.
34
35  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
36
37 ikiwiki (1.8) unstable; urgency=low
38
39   * Fix orphans plugin to not count a link to a nonexistant page as a reason
40     for a page not being an orphan.
41   * Support pinging services such as Technorati using XML-RPC to notify them
42     about changes to rss feeds.
43   * Parse svn log as xml for improved utf8 and security. Note that this makes
44     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
45   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
46     flagged string even if the locale causes it to generate utf8 output,
47     so make sure to let perl know it should be handled as utf8. Also,
48     the optimised version used for standard time formats won't work if the
49     user has changed locale, so drop it. Thanks, Faidon Liambotis.
50   * Fix re-encoding of the comments field to utf8 if a commit fails
51     due to a conflict. Thanks, Faidon Liambotis.
52   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
53     Liambotis.
54   * Add insane double encode/decode to utf8 around call to markdown.
55     This works around a truely strange bug, which is apparently a bug in
56     perl, #376329. Also added a test case for it.
57   * Improve layout of edit page so formatting help link is always visible w/o
58     getting in the way of the preview.
59   * Centralised all calls to HTML::Template and force all the templates
60     to be read as utf8.
61   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
62   * Introduce add_plugins and disable_plugins config options in setup files.
63     This allows adding or removing plugins w/o overriding the whole list of
64     default plugins, which makes it easier to upgrade when new default plugins
65     are added.
66   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
67     default (of course!). Based on a patch by Faidon Liambotis.
68   * Add a html plugin, which can be used to write wikis in raw html,
69     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
70     defaults to not processing .html files, since w/o this plugin they would
71     be copied unsanitised. With this plugin, it will process and html
72     sanitise them, like any other page type.
73   * Rebuilding wrappers is necessary on upgrade to this version.
74   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
75     will be automatically done on all upgrades.
76   * Don't send pings if the wiki is being rebuilt.
77   * Work around very innefficient behavior in File::Spec::abs2rel. Result
78     is a savings of 2 pointless fork/execs per link calculation, which
79     results in ~25% speedup of ikiwiki building its own doc wiki, and
80     about 35% speedup displaying RecentChanges!
81   * Make RecentChanges use a table and some CSS, should be much more readable.
82     No code changes involved.
83   * Encode & in diffurl in examples, to conform to pedantic rules.
84   * Speed up RecentChanges by another 40% or so with some memoization.
85   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
86     in time to build the doc wiki.
87
88  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
89
90 ikiwiki (1.7) unstable; urgency=low
91
92   * Updated logo from Recai with some kerning and alingment tuning.
93   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
94     changed some output.
95   * Copyright update.
96
97  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
98
99 ikiwiki (1.6) unstable; urgency=low
100
101   * YA utf-8 patch from Recai, this time to fix previewing a page so that
102     the text in the input box is re-encoded back to utf-8.
103   * -CSD does not affect modules, so readfile() was not using the utf-8 input
104     layer, which led to lots of problems; make it force read files as utf-8.
105     Closes: #373203
106   * Note that as a consequence, this version of ikiwiki will actually try to
107     parse utf8 in source files for the first time, which may expose broken
108     utf8 in wiki sources that was hidden before. Most common will be
109     perl warnings like "utf8 "\xE9" does not map to Unicode"
110   * writefile() likewise needs to use the utf8 output layer.
111   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
112     there.
113   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
114     given the readfile fix.
115   * Add utf-8 testcases for readfile and htmlize.
116   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
117     safe.
118   * More utf-8 fixes from Recai, partly to things I broke above:
119     - The serious problem is that writefile() saves the content in undecoded
120       format in CGI, hence all (non-ascii) chars are corrupted permanently.
121     - Comment field in edit page is not decoded and all the non-ascii chars in
122       this field are corrupted as the result.  We should decode it as we do it
123       for the content.
124     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
125       character in print.
126   * New SVG logo from Recai.
127
128  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
129
130 ikiwiki (1.5) unstable; urgency=low
131
132   * Add --timeformat config option to allow changing how dates are displayed.
133     Note that as a side effect, dates will now be displayed using the local
134     timezone, not as GMT.
135   * More security review.
136   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
137     for some handy stuff like:
138     - Using links as a kind of tag; creating blog pages that list all pages
139       containing a given tag/link or not containing some other tag.
140     - Subscribing to mail notifications whenever a change is made to a page
141       that is a backlink of page foo. Ie, "Please notify me of changes in all
142       pages that link to my home page in the wiki"
143     - Locking any pages that are linked to from a particular page, so that
144       lists of locks can be exposed in the wiki.
145   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
146     when a todo item is done, instead of the previous moving it to a different
147     subdir.
148   * Allow pagetemplate plugins to override *anything* in the template.
149   * Add a meta plugin, which allows specifying various metadata about pages,
150     like license and author. It also allows for inserting html link and meta
151     tags into html, overriding the title, and adding hidden WikiLinks, which
152     can be useful when using link-based globbing for page categorisation.
153   * Remove preprocessor directives from inlined pages.
154   * Allow simple preprocessor directive values to be specified w/o quotes.
155   * Add support for using git instead of subversion as the RCS backend,
156     tremendous thanks to Recai Oktaş for this.
157   * Doc updates for git.
158   * Fix absolute url munging in rss generation to support https, ftp, etc urls
159     not just http urls.
160   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
161     utf-8 for edit and other fields, and for recentchanges. There may still
162     be utf-8 issues with the preferences page though.
163
164  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
165
166 ikiwiki (1.4) unstable; urgency=low
167
168   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
169     very strange way of enabling proper XHTML <br /> type tags. Output html
170     should be always valid again now.
171   * The page name and parent links has switched from using a <h1> to a styled
172     <span>, so pages can use <h1> internally instead of needing to use <h2>.
173   * Updated all of ikiwiki's own wiki pages for that.
174   * Add pagetemplate hook, which can be used by plugins that want to mess
175     around with adding new stuff to the page template.
176   * Remove headercontent; the search plugin now adds the search box to the
177     header by registering a pagetemplate hook, and other plugins should do
178     similarly.
179   * Rebuilding on upgrade to this version is recommended.
180   * Add a html validity check to the test suite, using the wdg-html-validator,
181     if available.
182   * Make the html valid when there is nothing in the actions list.
183   * Reordered some function call parameters for consistency.
184   * Enable full utf-8 support for page input and output.
185   * Add a workaround for markdown, which does not work well with utf-8
186     strings.
187   * --getctime had bitrotted (well I only ever used it the once so far..),
188     fix and make it a bit more flexible
189   * rcs_getctime is changed, now rather than needing to loop over all pages,
190     it should just use the rcs to get the ctime of the passed file.
191   * When inlining a page in another one, links from the inlined page are now
192     expanded the same as they are when rendering the inlined page as a
193     standalone page. So rather than being expanded from the POV of the
194     inlining page, they are expanded from the POV of the inlined page.
195
196     For example, a link from blog/foo to "bar" will now link to blog/bar
197     if it exists. Previously this needed to be a link explicitly to
198     "blog/bar"; such links will also continue to work.
199
200     (This was slightly complex to do as the link still has to be constructed
201     relative to the inlining page.)
202   * Make page edit textarea resize to fit browser window.
203   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
204     do not need a full rebuild, in order to update any basewiki pages.
205
206  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
207
208 ikiwiki (1.3) unstable; urgency=low
209
210   * Fix the preinst introduced in the last version. Closes: #367458
211
212  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
213
214 ikiwiki (1.2) unstable; urgency=low
215
216   * Remove dups from the brokenlinks list.
217   * Add libc6-dev to dependencies, needed to build wrappers.
218   * Install wikilist in correct location. Closes: #367371
219
220  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
221
222 ikiwiki (1.1) unstable; urgency=low
223
224   * Rename inlinepage to depends, so that it can be used to refer to more
225     dependency relationships than just inlining. This will require a rebuild
226     on upgrade to this version.
227   * Move the rss link, put it in the blogpost form if there is one and at the
228     top if not. This is both nicer because easier to find, and it cleans up
229     the code which had used inlinepage as a flag for adding the link later.
230   * Allow the depends GlobList to be built up from multiple sources (such as
231     plugins) during a page render.
232   * Which means that more than one blog is now supported to appear on a
233     single page. (With some limitations, like only the last one getting an
234     rss file.)
235   * Added a plugin system.
236   * Added a pagecount plugin, enabled by default.
237   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
238   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
239     backlinks when the backlinks hadn't really changed.
240   * Moved inline page support, rss generation etc into the inline plugin,
241     enabled by default.
242   * Added brokenlinks plugin, not enabled by default, but rather handy.
243   * Fix several broken links in the doc wiki.
244   * Smarter behavior when creating a page and a page of the same name (but
245     different location) already exists.
246   * Add an orphans plugin for finding pages that nothing links to.
247   * Removed backlinks page, which it turns out nothing used.
248   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
249     it, this will allow for adding a unit test suite.
250   * Add unit tests for several core functions, including globlist_match,
251     dirname, basename, bestlink, linkify, pagetitle, titlepage.
252   * Smart globlist merging.
253   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
254     to pave the way for adding other RCS support. This also changes the
255     setup files, where before they had svn => 1 or svn => 0, now they have
256     rcs => "svn" or rcs => "".
257   * Add a debian/NEWS file with upgrade notes.
258   * Load whatever rcs module is specified, so new ones can be just dropped in
259     as plugins and work. (Well, in theory.)
260   * Add some basic docs about writing RCS modules.
261   * Broke search capability out into a plugin, removed the --hyperestraier
262     switch.
263   * Added smiley plugin, nicely controlled and documented by the smileys page.
264   * Copied in some smileys from Moin Moin.
265   * Allow links of the form [[some page|page]], with whitespace in the link
266     text.
267   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
268     and --disable-plugin htmlscrubber.
269   * Allow discussion links on pages to be turned off with --no-discussion.
270   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
271   * Add some new config items to the estseek.conf template, which are needed
272     by hyperestraier 1.2.3.
273
274  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
275
276 ikiwiki (1.0) unstable; urgency=low
277
278   * First official release.
279
280  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400