inline: Call indexhtml when inlining internal pages, so their text can be indexed...
[ikiwiki.git] / debian / NEWS
1 ikiwiki (3.20100505) UNRELEASED; urgency=low
2
3   There is a significant change to the page.tmpl template in this version.
4   If you have locally modified versions of that template, you will need
5   to update it to contain the following in the HTML <head>:
6
7     <TMPL_IF DYNAMIC>
8     <TMPL_IF FORCEBASEURL><base href="<TMPL_VAR FORCEBASEURL>" /><TMPL_ELSE>
9     <TMPL_IF BASEURL><base href="<TMPL_VAR BASEURL>" /></TMPL_IF>
10     </TMPL_IF>
11
12  -- Joey Hess <joeyh@debian.org>  Wed, 05 May 2010 21:47:08 -0400
13
14 ikiwiki (3.20100427) unstable; urgency=low
15
16   This version of ikiwiki has a lot of changes that you need to know about.
17
18   Now you can include customised versions of templates in the source
19   of your wiki. (For example, templates/page.tmpl.) When these templates
20   are changed, ikiwiki will automatically rebuild pages that use them.
21
22   Allowing untrusted users to upload attachments with the ".tmpl"
23   extension is not recommended, as that allows anyone to change
24   a wiki's templates.
25
26   The --getctime switch is renamed to --gettime, and it also gets the 
27   file modification time. And it's a lot faster (when using git). But
28   the really important change is, you don't have to remember to use this
29   switch. Now ikiwiki will do it when it needs to.
30
31   At last, the "tagged()" pagespec only matches tags, not regular wikilinks.
32   If your wiki accidentially relied on the old, buggy behavior, you might
33   need to change its pagespecs to use "link()".
34
35   Many of your wishes have been answered: Now tag pages can automatically be
36   created when new tags are used. This feature is enabled by default if you
37   have configured a tagbase. It can be turned on or off using the
38   tag_autocreate setting.
39
40   These changes may also affect some users:
41
42   * The title_natural sort method (as used by the inline directive, etc)
43     has been moved to the new sortnaturally plugin, which is not enabled
44     by default since it requires the Sort::Naturally perl module.
45
46   * The add_templates option has been removed from the underlay plugin.
47     If you used this option, you can instead use templates/ subdirectories
48     inside underlay directories added by the add_underlays option.
49
50   Due to the above and other changes, all wikis need to be rebuilt on
51   upgrade to this version. If you listed your wiki in /etc/ikiwiki/wikilist
52   this will be done automatically when the Debian package is upgraded. Or
53   use ikiwiki-mass-rebuild to force a rebuild.
54
55  -- Joey Hess <joeyh@debian.org>  Tue, 27 Apr 2010 00:00:00 -0400
56
57 ikiwiki (3.20091017) unstable; urgency=low
58
59   To take advantage of significant performance improvements, all
60   wikis need to be rebuilt on upgrade to this version. If you
61   listed your wiki in /etc/ikiwiki/wikilist this will be done
62   automatically when the Debian package is upgraded. Or use
63   ikiwiki-mass-rebuild to force a rebuild.
64
65  -- Joey Hess <joeyh@debian.org>  Mon, 05 Oct 2009 16:48:59 -0400
66
67 ikiwiki (3.1415926) unstable; urgency=low
68
69   In order to fix a performance bug, all wikis need to be rebuilt on
70   upgrade to this version. If you listed your wiki in
71   /etc/ikiwiki/wikilist this will be done automatically when the
72   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force
73   a rebuild.
74
75  -- Joey Hess <joeyh@debian.org>  Tue, 25 Aug 2009 17:24:43 -0400
76
77 ikiwiki (3.13) unstable; urgency=low
78
79   The `ikiwiki-transition deduplinks` command introduced in the
80   last release was buggy. If you followed the NEWS file instructions
81   and ran it, you should run `ikiwiki -setup` to rebuild your wiki
82   to fix the problem.
83
84  -- Joey Hess <joeyh@debian.org>  Fri, 22 May 2009 13:04:02 -0400
85
86 ikiwiki (3.12) unstable; urgency=low
87
88   You may want to run `ikiwiki-transition deduplinks your.setup`
89   after upgrading to this version of ikiwiki. This command will
90   optimise your wiki's saved state, removing duplicate information
91   that can slow ikiwiki down.
92
93  -- Joey Hess <joeyh@debian.org>  Wed, 06 May 2009 00:25:06 -0400
94
95 ikiwiki (3.01) unstable; urgency=low
96
97   If your wiki uses git, and you have a `diffurl` configured in
98   its setup file, you should be aware that gitweb has stopped
99   supporting the url form commonly used for the `diffurl`.
100
101   You can change your setup to use the newer gitweb url form:
102
103     http://git.example.com/gitweb.cgi?p=wiki.git;a=blobdiff;f=[[file]];h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_commit]];hpb=[[sha1_parent]]
104
105   The changes from the old form are the addition of the `hpb` parameter,
106   and the change to the value used for the `hb` parameter.
107
108  -- Joey Hess <joeyh@debian.org>  Mon, 05 Jan 2009 18:18:05 -0500
109
110 ikiwiki (3.00) unstable; urgency=low
111
112   The 3.0 release of ikiwiki changes several defaults and finishes
113   some transitions. You will need to modify your wikis to work with
114   ikiwiki 3.0. A document explaining the process is available
115   in </usr/share/doc/ikiwiki/html/tips/upgrade_to_3.0.html>
116
117  -- Joey Hess <joeyh@debian.org>  Tue, 23 Dec 2008 16:14:18 -0500
118
119 ikiwiki (2.62) unstable; urgency=low
120
121   TexImg standard preamble changed
122
123   The teximg plugin now has a configurable LaTeX preamble.
124   As part of this change the `mchem` LaTeX package has been removed from
125   the default LaTeX preamble as it wasn't included in many TeX installations.
126
127   The previous behaviour can be restored by adding the following to your
128   ikiwiki setup:
129
130         teximg_prefix => '\documentclass{scrartcl}
131                 \usepackage[version=3]{mhchem}
132                 \usepackage{amsmath}
133                 \usepackage{amsfonts}
134                 \usepackage{amssymb}
135                 \pagestyle{empty}
136                 \begin{document}',
137
138   In addition, the rendering mechanism has been changed to use `dvipng` by
139   default, if available.
140
141  -- Joey Hess <joeyh@debian.org>  Sun, 24 Aug 2008 15:00:40 -0400
142
143 ikiwiki (2.60) unstable; urgency=low
144
145   Admin preferences are moving from the web interface to the setup file.
146   There are three new options in the setup file: `locked_pages`, `banned_users`,
147   and `allowed_attachments`. The admin prefs page can still be used, but
148   that's deprecated, and the prefs will be hidden if a value is not already
149   set. If a value is set in the web interface, you're encouraged to move that
150   setting to your setup file now, since version 3.0 will remove the deprecated
151   admin prefs web interface.
152
153   Also, the layout of the setup file has changed in a significant way in this
154   release. Old setup files will continue to work, but new features, like the
155   new websetup interface, require a new format setup file. You can convert
156   old setup files into the new format by running 
157   `ikiwiki-transition setupformat ikiwiki.setup`
158
159  -- Joey Hess <joeyh@debian.org>  Fri, 01 Aug 2008 17:02:14 -0400
160
161 ikiwiki (2.52) unstable; urgency=low
162
163   All wikis need to be rebuilt on upgrade to this version. If you listed your
164   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
165   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
166
167  -- Joey Hess <joeyh@debian.org>  Sun, 06 Jul 2008 15:10:05 -0400
168
169 ikiwiki (2.49) unstable; urgency=low
170
171   The search plugin no longer uses hyperestraier. Instead, to use it you
172   will now need to install xapian-omega, and the Search::Xapian,
173   HTML::Scrubber, and Digest::SHA1 perl modules. Ie,
174   `apt-get install xapian-omega libsearch-xapian-perl libhtml-scrubber-perl libdigest-sha1-perl`
175
176   Also, wikis that use the search plugin will need to be rebuilt,
177   since the search form has changed. This will not be done automatically,
178   but can be done by running `ikiwiki-mass-upgrade` as root, or
179   running `ikiwiki -setup` on individual setup files.
180
181  -- Joey Hess <joeyh@debian.org>  Wed, 04 Jun 2008 00:29:28 -0400
182
183 ikiwiki (2.48) unstable; urgency=high
184
185   If you allowed password based logins to your wiki, those passwords were
186   stored in cleartext in the userdb. To guard against exposing users'
187   passwords, I recommend you install the Authen::Passphrase perl module, and
188   then run `ikiwiki-transition hashpassword /path/to/srcdir` to replace all
189   existing cleartext passwords with strong (blowfish) hashes.
190
191  -- Joey Hess <joeyh@debian.org>  Thu, 29 May 2008 14:39:34 -0400
192
193 ikiwiki (2.46) unstable; urgency=low
194  
195   There were some significant template changes in ikiwiki 2.42 (and 1.33.5).
196   If you have locally modified versions of the templates, they need to be
197   updated. Most notably, the editpage.tmpl has a new FIELD-SID added to it,
198   without which web editing will fail.
199  
200  -- Joey Hess <joeyh@debian.org>  Tue, 06 May 2008 14:30:14 -0400
201
202 ikiwiki (2.40) unstable; urgency=low
203
204   ikiwiki now has an new syntax for preprocessor directives, using the
205   prefix '!':
206
207   [[!directive ...]]
208
209   This new syntax no longer relies on spaces to distinguish between
210   wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
211   in their link text, and preprocessor directives without arguments (such
212   as "toc") need not use a trailing space.
213
214   To enable the new syntax, set prefix_directives to true in your ikiwiki
215   config.  For backward compatibility with existing wikis,
216   prefix_directives currently defaults to false.  In ikiwiki 3.0,
217   prefix_directives will default to true, and wikis which have not yet
218   converted to the new syntax will need to set prefix_directives to false
219   in their setup files.
220
221   To convert your wiki to the new syntax, ikiwiki provides a new script
222   ikiwiki-transition.
223
224   Even with prefix_directives disabled, ikiwiki now allows an optional '!'
225   prefix on preprocessor directives (but still requires a space).  Thus, a
226   directive which uses a '!' prefix and contains a space will work with
227   ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
228   This allows the underlay to work with all ikiwikis.
229
230  -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
231
232 ikiwiki (2.30) unstable; urgency=low
233
234   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
235   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
236   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
237   Custom RecentChanges pages can be easily set up that display only changes
238   to a subset of pages, or only changes by a subset of users.
239   
240   All wikis need to be rebuilt on upgrade to this version. If you listed your
241   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
242   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
243
244   With this excellent new RecentChanges support, the mail notification system
245   is its age (and known to be variously buggy and underimplemented for
246   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
247   from this version. If you were subscribed to commit mails, you should be
248   able to accomplish the same thing by subscribing to a RecentChanges feed.
249
250   The "notify" field in setup files is no longer used, and
251   silently ignored. You may want to remove it from your setup file.
252
253  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
254
255 ikiwiki (2.20) unstable; urgency=low
256
257   The template plugin has begin to htmlize the variables passed to templates.
258   This is normally what you want, but to get the old behavior and get at the
259   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
260  
261  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
262
263 ikiwiki (2.16) unstable; urgency=low
264
265   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
266   release, to avoid the basewiki including pages with names like "blog".
267   Redirection pages have been left behind for these moved pages temporarily,
268   and will be removed later.
269
270   If you use the calendar plugin, ikiwiki is now smarter and your nightly
271   cron job to update the wiki doesn't need to rebuild everything. Just pass
272   --refresh to ikiwiki in the cron job and it will update only pages that
273   contain out of date calendars.
274
275  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
276
277 ikiwiki (2.14) unstable; urgency=low
278
279   This version of ikiwiki is more picky about symlinks in the path leading
280   to the srcdir, and will refuse to use a srcdir specified by such a path.
281   This was necessary to avoid some potential exploits, but could potentially
282   break (semi-)working wikis. If your wiki has a srcdir path containing a
283   symlink, you should change it to use a path that does not.
284
285  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
286
287 ikiwiki (2.9) unstable; urgency=low
288
289   Since ikiwiki 2.0 was released, some limitiations have been added to what
290   ikiwiki considers a WikiLink. In short, if there are any spaces in between
291   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
292   contains things meant to be WikiLinks that contain spaces, you will need to
293   fix them, by replacing the spaces with underscores.
294   
295   WikiLink have always been documented to not contain spaces, but bugs in
296   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
297   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
298   release. These fixes are necessary to avoid ambiguity between
299   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
300   these bugs (and their fixes) may have caused.
301
302  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
303
304 ikiwiki (2.6) unstable; urgency=low
305
306   In this version the rst plugin allows raw html to be embedded in rst files.
307   As long as the htmlscrubber is enabled, this should be safe. If you are
308   using the rst plugin without the htmlscrubber in a publically writable wiki,
309   you should turn on the htmlscrubber.
310
311  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
312
313 ikiwiki (2.5) unstable; urgency=low
314
315   Due to some config changes in this version, wrappers need to be rebuilt on
316   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
317   one automatically when the Debian package is upgraded.
318
319  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
320
321 ikiwiki (2.1) unstable; urgency=low
322
323   Some wikis need to be rebuilt on upgrade to this version, due to changes to
324   page templates and the style sheet. If you listed your wiki in
325   /etc/ikiwiki/wikilist this will be done automatically when the Debian
326   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
327
328  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
329
330 ikiwiki (2.00) unstable; urgency=low
331
332   With the 2.0 release of ikiwiki, some major changes have been made to the
333   default configuration:
334
335   * The 'usedirs' setting is enabled by default. This *will* break all URLs
336     to wikis that did not have 'usedirs' turned on before, unless you follow
337     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
338     or edit your setup file to turn usedirs off:
339        usedirs => 0,
340
341   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
342     perl module is available. Password logins are also still enabled
343     by default. If you like, you can turn either OpenID or password logins
344     off via the 'disable_plugins' setting.
345
346  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
347
348 ikiwiki (1.51) unstable; urgency=low
349
350   Some wikis need to be rebuilt on upgrade to this version, due to changes to
351   page layout and the style sheet. If you listed your wiki in
352   /etc/ikiwiki/wikilist this will be done automatically when the Debian
353   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
354
355  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
356
357 ikiwiki (1.50) unstable; urgency=low
358
359   Permalinks and guids in rss and atom feeds for wikis using the usedirs
360   options will change in this release. If you have already enabled usedirs,
361   you may need to take steps to avoid flooding aggregators.
362
363  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
364
365 ikiwiki (1.49) unstable; urgency=low
366
367   Third-party plugins that use htmlpage() or abs2rel() to generate links
368   may need changes to support the new "usedirs" option.
369
370  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
371
372 ikiwiki (1.47) unstable; urgency=low
373  
374   Due to a security fix, wikis that have the htmlscrubber enabled can no
375   longer use the meta plugin to insert html link and meta tags.
376
377   Some special case methods have been added for safely including stylesheets,
378   and for doing openid delegation. See the meta plugin docs for details.
379  
380  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
381
382 ikiwiki (1.45) unstable; urgency=low
383
384   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
385   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
386   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
387
388  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
389
390 ikiwiki (1.44) unstable; urgency=low
391
392   The htmllink() function has changed slightly and plugins that use it may
393   need to change how they call it. This function's first three parameters
394   are unchanged, but additional options are now passed using named
395   parameters. If you used htmllink with more than 3 parameters, you will
396   need to change it. The plugin interface version has been increased to 1.02
397   to reflect this change.
398
399  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
400
401 ikiwiki (1.42) unstable; urgency=low
402
403   The anonok setting in config files has been removed. To enable
404   httpauth support on your wiki, you should now enable the anonok plugin,
405   instead.
406
407   Third-party plugins that use pagespec_match() should be updated to pass
408   the new third parameter (from) to that function. This is needed for the
409   new relative glob matching to work.
410
411  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
412
413 ikiwiki (1.34) unstable; urgency=low
414
415   The httpauth setting in config files has been removed. To enable
416   httpauth support on your wiki, you should now enable the httpauth plugin,
417   instead.
418
419   This release includes OpenID support that is enabled through the openid
420   plugin. I recommend turning this on to make it easier for users to sign
421   in to your wiki.
422
423  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
424
425 ikiwiki (1.32) unstable; urgency=low
426
427   There is a change to the plugin interface in this version. Any plugins that
428   modify data in %links should pass scan => 1 when registering the hook that
429   does so.
430
431  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
432
433 ikiwiki (1.29) unstable; urgency=low
434
435   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
436   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
437   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
438
439   There is a change to the plugin interface in this version. Plugins that use
440   %renderedfiles will need to be updated, as the hash's values are now arrays
441   of rendered files. Plugins that cause a page to render additional files
442   should use the new will_render function to register the files.
443
444  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
445
446 ikiwiki (1.22) unstable; urgency=low
447   
448   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
449   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
450   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
451   to force a rebuild.
452
453   If you have modified versions of ikiwiki's html templates, you will need
454   to update your templates to link to the stylesheet file using
455   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
456   STYLEURL.
457
458   There have also been some changes to the plugin interface:
459   Any plugins that use santize, htmlize, or format hooks will need to be
460   updated for this version of ikiwiki since these hooks have been changed
461   to use named parameters.
462
463  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
464
465 ikiwiki (1.13) unstable; urgency=low
466
467   The GlobList format which was used for specifiying sets of pages, has been
468   replaced with a new, more expressive PageSpec format. While GlobLists will
469   continue to work, that format is deprecated, and you are encouraged to use
470   PageSpecs from now on, and also to change any GlobLists in your wiki to
471   PageSpecs. See the new PageSpec page for details.
472   
473   You will need to rebuild your wiki when upgrading to this version. If you
474   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
475   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
476   rebuild.
477
478  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
479
480 ikiwiki (1.11) unstable; urgency=low
481
482   Some changes to tags in this release, due to a new tag plugin. If you have
483   been using the meta plugin to tag pages, you'll want to enable the tag
484   plugin too, and change things like this:
485
486   [[meta link="foobar"]]
487
488   To this:
489
490   [[tag foobar]]
491
492   The new tags will appear at page footers, and are also easier to type.
493
494   There have also been some changes to the plugin interface, particularly the
495   interface of pagetemplate hooks has changed. See the changelog for details.
496
497  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
498
499 ikiwiki (1.8) unstable; urgency=low
500
501   If your wiki is configured with a setup file, you should modify it to
502   stop setting the "plugin" list directly, and instead add or remove plugins
503   via the add_plugins and disable_plugins lines. For example, if you had:
504
505         plugin => [qw{inline smiley search}],
506
507   Change it to these lines, which disables the default htmlscrubber plugin
508   and adds the two additional plugins:
509
510         add_plugins => [qw{smiley search}],
511         disable_plugins => [qw{htmlscrubber}],
512
513   Making this change makes your ikiwiki setup file more future-proof since
514   new default plugins will be automatically used.
515   
516   You will need to rebuild your ikiwiki wrappers when upgrading to this
517   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
518   done automatically when the Debian package is upgraded. Or use
519   ikiiki-mass-rebuild --refresh to force a refresh.
520
521  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
522
523 ikiwiki (1.1) unstable; urgency=low
524
525   There have been several configuration changes in this release of ikiwiki:
526
527   The --svn and --no-svn switches are removed, instead you should use
528    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
529   be changed to set rcs => "svn"; if your setup file sets svn => 0
530   then change it to use rcs => "" to disable svn.
531
532   The --hyperestraier switch is gone too. To enable searching, turn on the
533   search plugin, by passing --plugin=search or through the plugin setting in
534   the setup file.
535
536   The --sanitize and --no-sanitize switches are also gone, replaced with the
537   htmlscrubber plugin. This plugin is enabled by default, to disable it,
538   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
539   setup file.
540
541   Discussion pages are enabled by default, but if your wiki is configured
542   with a setup file, you need to edit it to keep them enabled on upgrade
543   to this version. Add a line reading:
544   discussion => 1,
545
546   You will need to rebuild your wiki when upgrading to this version.
547   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
548   automatically when the Debian package is upgraded. Or use
549   ikiiki-mass-rebuild to force a rebuild.
550
551  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400