]> sipb.mit.edu Git - ikiwiki.git/blob - doc/forum/Can_OpenID_users_be_adminusers__63__.mdwn
response
[ikiwiki.git] / doc / forum / Can_OpenID_users_be_adminusers__63__.mdwn
1 I've just finished an upgrade to 3.141 and am trying to give myself admin rights to play with the new webadmin features.  My login is via OpenID but from reading on the wiki I believe that OpenID users should be able to be granted admin rights.  However I'm obviously doing something wrong as when I click on the "Preferences" link at the top of the page I don't see any admin features.
2
3 My login is: http://adam.shand.net/
4
5 In .ikiwiki/userdb I see:
6
7 > adam@shand.net
8 > email <br>
9 > password <br>
10 > locked_pages <br>
11 > banned <br>
12 > 1229722296 <br>
13 > regdate <br>
14 > http://adam.shand.net/ <br>
15
16 And in my config file I have:
17
18 > adminuser => [qw{http://adam.shand.net/}],
19
20 Any pointers to what I'm doing wrong would be much appreciated.
21
22 Thanks,
23 Adam.
24
25 > This is certianly supposed to work. For example, the admin
26 > user on my ikiwikis is `http://joey.kitenet.net/`
27
28 > The only caveat I know of to make it work is that the 
29 > adminuser openid url has to exactly match the openid url that
30 > ikiwiki sees when you log in. Including any trailing slash,
31 > and the `http://`.
32
33 > Hmm, it's possible that the new version of the openid library
34 > has broken it. I also no longer show up as admin. There's a related
35 > bug [[bugs/openid_no_longer_pretty-prints_OpenIDs]]. --[[Joey]]