]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* If a userdir is configured, links to pages in it can be made without
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.37) UNRELEASED; urgency=low
2
3   * Add mirrorlist plugin.
4   * Fixed permissions of some files that were 600 in the tarball. (Did not
5     affect the deb).
6   * Avoid creating edit links when the cgi url is not known.
7   * Avoid displaying discussion links at all, if there's not a discussion
8     page, when the cgi url isn't known.
9   * Before, svn was used as the RCS by default unless configured otherwise,
10     now it defaults to using no RCS unless configured to do so, to avoid some
11     suprising behavior when using a setup file and not uncommenting any RCS
12     options.
13   * Fix some bugs in the commit email sending code.
14   * Improve code that ignores files in the underlaydir if the srcdir has a
15     file building the same page. Now it will work even if the extensions of
16     the source files differ.
17   * Initial work on internationalization of the program code. po/ikiwiki.pot
18     is available for translation.
19   * Export gettext() from IkiWiki module.
20   * Don't put discussion links on discussion pages.
21   * Allow disabling of plugins included in goodstuff.
22   * Add a textile format plugin contributed by mazirian.
23   * If a userdir is configured, links to pages in it can be made without
24     specifying the path. This allows for easy signing of comments by linking
25     to your page in the userdir.
26
27  -- Joey Hess <joeyh@debian.org>  Fri, 29 Dec 2006 00:26:47 -0500
28
29 ikiwiki (1.36) unstable; urgency=low
30
31   * Fix various links on the hyperestraier pages.
32   * Use POST for poll to avoid some robots.
33   * Fix sometimes broken links to Discussion pages from blog pages.
34   * Add userdir config setting.
35   * Fix man page perms in install.
36   * Fix an issue with inlining a page with a rss feed inside another
37     page with an rss feed.
38   * Turn $config{wiki_file_prune_regexps} into an array that is easier to
39     manipulate.
40   * Only exclude rss and atom files from processing if the inline plugin
41     is enabled and that feed type is enabled. Else it's just a copyable file
42     type.
43   * Move rss and atom option handling code into the inline plugin.
44   * Applied a rather old patch from Recai to fix the "pruning is too strict"
45     issue. Now you can have wiki source directories inside dotdirs and the
46     like, if you want.
47   * Patch from Emanuele Aina to fix modification time code in mercurual
48     backend.
49   * Add support for links of the form [[/foo]]
50   * Fix code to make absolute urls for rss feeds, was missing some urls.
51   * Fix double-escaping of html entities in titles etc in rss feeds
52     that occured if escaped characters were present in the page filename.
53
54  -- Joey Hess <joeyh@debian.org>  Fri, 22 Dec 2006 15:55:05 -0500
55
56 ikiwiki (1.35) unstable; urgency=low
57
58   * Fix daemonisation code to only do daemon setup things after forking the
59     child process.
60   * The hack used to make the pagetemplate hook have access to the editpage
61     template won't work with CGI::FormBuilder 3.0401, so disable it for now.
62   * CGI::FormBuilder 3.0401 seems to work ok now with ikiwiki, although
63     there might still be bugs lurking..
64
65  -- Joey Hess <joeyh@debian.org>  Fri,  1 Dec 2006 19:14:36 -0500
66
67 ikiwiki (1.34.2) unstable; urgency=low
68
69   * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
70     ~user/.ikiwiki/wikilist will be read.
71   * Fix url absolution code in inline plugin to support class and id fields in
72     links and imgs, and to support anchor urls.
73   * More build deps updates.
74   * /dev/null fortune failures
75
76  -- Joey Hess <joeyh@debian.org>  Tue, 28 Nov 2006 12:58:47 -0500
77
78 ikiwiki (1.34.1) unstable; urgency=low
79
80   * Add libtime-duration-perl to build deps, as it's used by the svn module
81     which is now tested at build.
82
83  -- Joey Hess <joeyh@debian.org>  Mon, 27 Nov 2006 12:26:12 -0500
84
85 ikiwiki (1.34) unstable; urgency=low
86
87   * Add an openid plugin to support logging in using OpenID.
88   * Web commits by OpenID users will record the full OpenID url for the user,
89     but in recentchanges, these urls will be converted to a simplified display
90     form+link.
91   * Modified svn, git, tla backends to recognise such web commits.
92   * Move httpauth support to a plugin.
93   * Add openidsignup config option.
94   * Make the openid plugin support the callbacks from myopenid.com via its
95     affiliate program.
96   * Add toggle plugin.
97   * Add a poll plugin.
98   * Add quick mode for archive page generation.
99   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
100     many other plugins. It's an easy way to boost ikiwiki from its default,
101     basic wiki, to a full-featured wiki, without manually picking the right
102     set of plugins. New plugins will be added to goodstuff from time to
103     time.
104   * Change how post signin actions are propigated through the signin process;
105     they're now stored in the session.
106   * Add optional "desc" parameter to shortcut definitions.
107   * Avoid locking the wiki at all when handling some basic cgi stuff
108     (searches, recentchanges).
109   * Add "last" parameter to hook function. Very basic ordering, and hopefully
110     nothing more spohisticated will be needed.
111   * Add formbuilder_setup and formbuilder hooks.
112   * Split out a passwordauth module, that holds all the traditional password
113     based authentication etc code. It's enabled by default, but can be disabled
114     if you want only openid or some other auth method.
115   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
116   * Add some code to the build system that tries to determine if the
117     lib installation directory is in @INC. If it's not, munge ikiwiki
118     to hardcode the path to the lib directory. This should allow installing
119     ikiwiki in nonstandard locations, including home directories, by just
120     setting PREFIX at build time.
121   * Fix nested examples directory in deb.
122   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
123   * Add a test suite for the svn backend.
124   * Add a test suite for the git backend, from Recai
125   * Daemonize before sending RPC pings, since that can take a while
126     and/or hang.
127   * Daemonize before sending commit mails, as that can also take a long
128     time/hang if the mail server is unhappy.
129   * Factor out commit mail sending code into new function.
130   * Change rcs_commit, it is now passed the name of the user doing the commit
131     and their IP address, and needs to construct its own commit message
132     containing them, or do something more appropriate for the given RCS.
133   * Add softwaresite example.
134   * Mercurial backend improvements, including --get-ctime support. (Emanuele
135     Aina)
136   * Git backend improvements, including bug fixes and better robustness,
137     from Recai.
138
139  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 20:46:56 -0500
140
141 ikiwiki (1.33) unstable; urgency=low
142
143   * Fix issue with aggregate plugin updating expired pages.
144   * Avoid syntax errors in templates used by the template plugin crashing
145     ikiwiki.
146   * Enable utf8 file IO in aggregate plugin.
147   * Fix some issues with the new registration form.
148   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
149   * Make sure to check for errors from every eval.
150   * Fix img plugin's handling of adding dependencies for images that do not
151     yet exist.
152   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
153     FORM-SUBMIT unusable on customised formbuilder templates. For now,
154     hardcode the submit buttons in editpage.tmpl instead of using the
155     template variable, which is ok, since the buttons are static.
156   * Work with hyperestraier 1.4.9.
157
158  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
159
160 ikiwiki (1.32) unstable; urgency=low
161
162   * Add a separate pass to find page links, and only render each page once,
163     instead of over and over. Typical speedup is ~4x. Max possible speedup:
164     8x.
165   * Add "scan" parameter to hook(), which is used to make the hook be called
166     during the scanning pass, as well as the render pass. The meta and tag
167     plugins need to use the new scan parameter, so will any others that modify
168     %links.
169   * Now that links are calculated in a separate pass, it can also
170     precalculate backlinks in one pass, which is O(N^2) instead of the
171     previous code that was O(N^3). A very nice speedup for wikis with lots
172     (thousands) of pages.
173   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
174     Erdem.
175   * Add a default stylesheet entry for the pagecloud.
176   * Add examples page with some examples of things that can be done using
177     ikiwiki, like a weblog. The examples can be copied into a user's wiki
178     for a quick start, without needing to learn everything about how to put
179     them together.
180   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
181   * Add perlmagick to build-depends so syntax check of img plugin works.
182     Closes: #396702
183   * Improve login/register process, the login dialog has only name and
184     password fields, which allows more web browsers to regognise it as a login
185     field, and is less confusing.
186   * Implemented expiry options for aggregate plugin.
187   * Use precalculated backlinks info when determining if files need an update
188     due to a page they link to being added/removed. Mostly significant if
189     there are lots of pages.
190   * Remove duplicate link info when saving index. In some cases it could
191     pile up rather badly. (Probably not the best way to deal with this
192     problem.)
193   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
194     or what have you, by creating enclosures for non-page items that are
195     included in feeds.
196
197  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
198
199 ikiwiki (1.31) unstable; urgency=low
200
201   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
202   * Change the rss feed title from the wikiname to the page title, with
203     an exception for the wiki's toplevel index page, which will still use the
204     wikiname as the feed title.
205     Overriding the page title with meta title already overrode the rss feed
206     tittle.
207   * Add an img plugin, based on Christian Mock's img plugin, but stripped
208     down to the bare essentials. Useful for handling large images on websites.
209   * Sanitize possibly problimatic characters out of the polygen grammar names,
210     just in case. Should not be exploitable anyway, since it only tries to run
211     polygen after finding the specified grammar file.
212   * Add missing dependency on the URI perl module.
213   * Add basic spam fighting tool for admins: An admin's prefs page now allows
214     editing a list of banned users.
215
216  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
217
218 ikiwiki (1.30) unstable; urgency=low
219
220   * Add no_override parameter to hook().
221   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
222     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
223     can be configured using a page in wiki.
224   * Fix support for --pingurl at the command line.
225   * Fix a subtle bug in will_render that broke some builds, by only clearing
226     items from renderedfiles the first time per build.
227   * Wrap entire technortati ping operation in an eval to catch all possible
228     failure modes, after I observed a simple ->value crashing ikiwiki when
229     a ping failed.
230
231  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
232
233 ikiwiki (1.29) unstable; urgency=low
234
235   * Patch from Paul Tötterman to use CP in the Makefile.
236   * Patch from Alec Berryman adding a http_auth config item that allows
237     using HTTP Authentication instead of ikiwiki's built in authentication.
238     Useful for eg, large sites with their own previously existing user auth
239     setup. Closes: #384534
240   * Change %renderedfiles to store an array of files rendered from a given
241     source file, to allow tracking of extra rendered files like rss feeds.
242   * Note that plugins that accessed this variable will need to be updated!
243     The plugin interface has been increased to version 1.01 for this change.
244     As few plugins use %renderedfiles I haven't done anything else to ensure
245     compatability of old plugins.
246   * Add will_render function to the plugin interface, used to register that a
247     page renders a destination file, and do some security checks. Previously
248     but no longer rendered files will be cleaned up.
249   * Use will_render in the inline and linkmap plugins.
250   * You will need to rebuild your wiki on upgrade to this version.
251   * Atom feed support based on a patch by Clint Adams.
252   * Add feeds=no option to inline preprocessor directive to turn off all types
253     of feeds.
254   * $IkiWiki::version now holds the program version, and is accessible to
255     plugins.
256   * Make the aggregate plugin emphasize error messages.
257   * Patch from Recai to limit recentchanges to displaying max 10 files for a
258     given changeset (to avoid large number of file changes excessively
259     bloating the page).
260
261  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
262
263 ikiwiki (1.28) unstable; urgency=low
264
265   * inline: Add ability to sort by page name, based on a patch from
266     Benjamin A'Lee.
267   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
268     braindead interface. Closes: #389383
269   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
270     and b) those poor Mac OSX users and their case insensative files!
271   * Don't fail syntax check if Text::Typography isn't installed.
272     Closes: #389406
273
274  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
275
276 ikiwiki (1.27) unstable; urgency=low
277
278   * Work on firming up the plugin interface:
279     - Plugins should not need to load IkiWiki::Render to get commonly
280       used functions, so moved some functions from there to IkiWiki.
281     - Picked out the set of functions and variables that most plugins
282       use, documented them, and made IkiWiki export them by default,
283       like a proper perl module should.
284     - Use the other functions at your own risk.
285     - This is not quite complete, I still have to decide whether to
286       export some other things.
287   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
288     referring to stuff now exported by the IkiWiki module.
289   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
290     to declare which version of the interface your plugin needs.
291   * Anyone with a third-party ikiwiki plugin is strongly encouraged
292     to make like changes to it and avoid use of non-exported symbols from
293     "IkiWiki::".
294   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
295   * Support hyperestradier version 1.4.2, which adds a new required phraseform
296     setting.
297   * If an inlined page has a permalink, link the page title to that.
298   * Patch from Recai to use utf8 when reading the setup file, so that
299     utf8 wikinames from there will be used properly.
300   * Patch from Recai to kill utf-8 on the wiki name when generating the
301     session cookie.
302   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
303   * Fix a baseurl problem in hyperestradier search results.
304   * Add a stub local.css to avoid problems with 404's.
305   * Patch from Recai to fix a wide character warning from the search plugin
306     during setup if the wikiname contains utf8.
307   * Yet another fix for those poor case-insensative OS X users.
308   * pagetemplate hooks are now also called when generating cgi pages.
309   * Add a favicon plugin, which simply adds a link tag for an icon to each
310     page (and cgis).
311   * Patch from James Westby to deal with the case where you're editing a
312     new page, hit cancel, and need to be redirected to somewhere sane.
313   * Various documentation improvements by various wiki users.
314   * Support Text::Markdown from CPAN, which has a different interface from
315     the original markdown or the one in Debian.
316   * Version the libcgi-session-perl dependency, some features that need
317     the new version are used in some cases (sslcookie).
318   * Numerous tla fixes from Clint.
319   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
320     a multi-resolution favicon.ico.
321   * README.Debian: typo Closes: #388110
322   * chomp trailing newline at the end of templates read in by the template
323     plugin, to allow use of the template preprocessor directive in
324     whitespace-sensative situations. Closes: #387073
325   * Patch from James Westby to make the location of the estseek.cgi script
326     configurable.
327   * Add typography (SmartyPants) plugin by Recai.
328   * Add --render mode, which can be used to preview an edit at the command
329     line by test rendering a single page.
330   * Add a googlecalendar plugin. A bit special-purpose, but it shows
331     one way to to deal with user-supplied content that could cause XSS
332     issues w/o the htmlscrubber, and won't survive the scrubber.
333
334  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
335
336 ikiwiki (1.26) unstable; urgency=low
337
338   * Add a missing -n to tla undo call.
339   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
340     writes before consuming its whole stdin. Avoid this deadlock.
341   * Fix alt tags for outline checkboxes.
342
343  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
344
345 ikiwiki (1.25) unstable; urgency=low
346
347   * Add proper waitpid calls for open2ed processes throughout to avoid
348     zombies; this hit htmltidy especially badly.
349   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
350     subversion repos and fixing some other issues.
351   * Add support for tla, contributed by Clint Adams. Closes: #385936
352   * Add support for mercurial, contributed by Emanuele Aina.
353   * Include <link rel> tag for RSS feeds, used by some aggregators and
354     firefox to find the feed.
355   * Add a linkmap plugin (requires graphviz).
356
357  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
358
359 ikiwiki (1.24) unstable; urgency=low
360
361   * Simplify the data structure returned by rcs_recentchanges to avoid
362     each rcs plugin needing to form complex strings on its own.
363   * Fix another destpage issue in the inline directive. Closes: #385512
364     again.
365
366  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
367
368 ikiwiki (1.23) unstable; urgency=low
369
370   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
371
372  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
373
374 ikiwiki (1.22) unstable; urgency=low
375
376   * Change how the stylesheet url is determined in the templates: Remove
377     STYLEURL and add BASEURL to all templates (some already had it). This
378     new more general variable can be used to link to other things (eg, images)
379     from the template, as well as stylesheets.
380   * Fix a bug introduced last version to do with nested inlines.
381   * Allow preprocessor directives to span multiple lines, both to make
382     long ones with lots of values easier to write, and to allow for ones with
383     multi-line quoted values.
384   * Allow preprocessor directives to contain python-like triple-quoted
385     text blocks, for easy nesting of quotes inside.
386   * Add a template plugin.
387   * Make pagespec merge code smarter about merging duplicate pagespecs.
388   * Patch from Jordà Polo to make Setup::Standard support hashes in config
389     files.
390   * Change order of linkify and preprocess; first preprocess and then linkify.
391     This allows passing a wikilink inside a parameter to a preprocessor
392     directive without it being expanded to html, and leaking out of the
393     parameter, which had required some non-obvious use of triple-quoting
394     to avoid. Note that any preprocessor plugins that output something
395     that looks like a wikilink will now have it treated as such; AFAIK
396     this doesn't change any behavior though except for the template plugin.
397   * Enable preprocessor directives when previewing an edit.
398   * Make all pages pull in a local.css style sheet, if present. This won't
399     be included in ikiwiki, but can be created to make local styling changes
400     w/o needing to merge in every new change to the distributed style.css.
401   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
402   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
403     from a different directory.
404   * Generalised preprocesser loop protection code.
405   * Patch from James Westby to allow a description to be set for rss feeds.
406   * Patch from James Westby to add a template for the search form.
407   * Added a ddate plugin.
408   * Patch from James Westby to add a --sslcookie switch, which forces
409     cookies to only be sent over ssl connections to avoid interception.
410   * Fix preferences page on anonok wikis; still need to sign in to get
411     to the preferences page.
412   * Add toc (table of contents) plugin.
413   * Change htmlize, format, and sanitize hooks to use named parameters.
414   * Patch from James Westby to add an actions option to inline; this
415     adds Edit and Discussion links at the end of blog entries.
416   * Due to some css changes, you'll want to rebuild your wiki on upgrade
417     to this version. Will be handled automatically by the deb.
418   * Add processed date to aggregate preprocessor directive status output.
419
420  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
421
422 ikiwiki (1.21) unstable; urgency=low
423
424   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
425   * If a page links to itself, mark up the link text in a span with
426     class="selflink" so that it can be styled. I don't have a useful style
427     defined for that though.
428   * Call filter hooks on inlined page content.
429   * Support inlining pages raw, rather than creating a blog.
430   * Clean up yes/no parameter parsing in inline plugin.
431   * Implemented better cycle detection in the inline plugin; nested inlines
432     will now work.
433   * Add a map plugin contributed by Alessandro Dotti Contra.
434   * Add otl format plugin, which handles files as created by vimoutliner.
435   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
436   * Add first draft at a Restructured Text (rst) plugin, by Sergio
437     Talens-Oliag. Note that this has many known issues -- see the caveats on
438     the plugin's page.
439   * Credit everyone who wrote a plugin on the plugins' wiki pages.
440   * Fix utf-8 in blog post form.
441
442  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
443
444 ikiwiki (1.20) unstable; urgency=low
445
446   * Relicense the templates and basewiki under the 2-clause BSD license.
447     Since these can easily become part of other people's websites, they
448     should be under as permissive a license as possible.
449   * Add --syslog config option, to log to the syslog.
450   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
451     transient failure to fork (which I've seen happen in the wild).
452   * Fix a bug in the aggregator introduced last version that caused all
453     aggregator state to be lost during a non-aggregating build.
454
455  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
456
457 ikiwiki (1.19) unstable; urgency=low
458
459   * Fix several related bugs in page type determination during online editing.
460   * Add some locking to prevent 2 aggregators from running at once.
461   * Fix an infinite loop in the aggregator when finding a unique filename.
462
463  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
464
465 ikiwiki (1.18) unstable; urgency=low
466
467   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
468   * Add --version.
469   * Man page format fixups.
470   * If the meta plugin overides the page title, set a title_overridden
471     variable in the template to true. This allows doing things with the
472     templates conditional on the title being overriden.
473   * Add a %pagecase which maps lower-case page names to the actual case
474     used in the filename. Use this in bestlinks calculation instead of
475     forcing the link to lowercase.
476   * Also use %pagecase in various other places that want to check if a page
477     with a given name exists.
478   * This means that links to pages with mixed case names will now work,
479     even if the link is in some other case mixture, and mixed case pages
480     should be fully supported throughout ikiwiki.
481   * Recommend rebuilding wikis on upgrade to this version.
482
483  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
484
485 ikiwiki (1.17) unstable; urgency=low
486
487   * Disable tidy generator tag.
488   * Move tidy back to sanitize hook, found out how to only show body.
489   * Turn off tidy indentation too.
490   * Turn on HTML::Template loop_context_vars; not actually used in stock
491     templates but can be useful for things like making comma-delimited lists
492     of tags or what have you.
493   * Remove <br> from end of aggregate preprocessor directive output.
494   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
495     case-sensative filesystems like OSX.
496   * Improve markdown loading. First, try to load it as a proper perl module,
497     in case it was installed as one. Then fall back to trying
498     /usr/bin/markdown.
499   * Document in install page how to install markdown, since it has no
500     installation procedure in the upstream tarball.
501   * Set die_on_bad_params => 0 for all templates, to allow users to modify
502     them without annoyances.
503   * Suck in the page content when generating an inline archive page, to work
504     around the meta plugin's lack of caching of title metadata across runs.
505
506  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
507
508 ikiwiki (1.16) unstable; urgency=low
509
510   * Try to handle relative links in aggregated feeds. However,
511     the current support is a crude hack due to limitations of XML::Feed:
512     xml:base is not supported, neither is Content-Location. And of course,
513     relative links in RSS feeds are ill-undefined..
514   * Make aggregator save permalinks and author name to pages as metadata.
515   * Add permalink and author support to meta plugin, affecting RSS feeds
516     and blog pages.
517   * Various CSS and formatting changes.
518   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
519   * Add xhtml files to the default prune regexp.
520   * Also generate rel=bookmark links for permalinks.
521   * Fix the htmltidy plugin, which wasn't working due my breaking it when
522     I added it..
523   * Don't run tidy with -xml as that fails if the input is not well-formed.
524     Run it with -asxhtml instead, so it will output well-formed xhtml no
525     matter what the input.
526   * Disable tidy warnings too.
527   * Add a new format hook, and make tidy use it, since tidy can really only
528     operate on and output complete html documents, not the body chunks
529     that sanitise gets.
530   * Fix dates in rss feeds if running localised, so they're still rfc 822.
531
532  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
533
534 ikiwiki (1.15) unstable; urgency=low
535
536   * Remove CDPATH and other env vars perl taint checking doesn't like.
537     Closes: #381279
538   * Added created_before and created_after PageSpec limits.
539
540  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
541
542 ikiwiki (1.14) unstable; urgency=low
543
544   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
545     by 10% or so.
546   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
547   * Added many unit tests for pagespec_match.
548
549  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
550
551 ikiwiki (1.13) unstable; urgency=low
552
553   * ikiwiki can now download and aggregate feeds with its new aggregate
554     plugin, so it's possible to implement a Planet using ikiwiki!
555   * Add a run_hooks function for the common task of running all hooks of a
556     given type.
557   * Add a savestate hook.
558   * Don't put blog post forms on pages if there's no cgiurl set.
559   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
560     --wrappers to do that.
561   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
562     to update pages that haven't changed on disk.
563   * Change meta tags to use html entity-escaped text for values, so that
564     quotes and such can be represented in title tags.
565   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
566     for the above.
567   * Make --rebuild also cause --aggregate to re-download and write aggregated
568     pages.
569   * Avoid outputting duplicate meta info.
570   * Include title metadata on aggregated posts for capitalised and un-munged
571     titles.
572   * Title metadata of inlined pages now shows up in blogs and rss feeds.
573   * Fix issue with unicode filenames and updating the hyper estradier search
574     index. (Aka Please Please Please, let that be the last one.)
575   * Patch from Roland Mas to support an rss=no parameter to inline directives.
576     Closes: #380743
577   * Renamed GlobLists to PageSpecs.
578   * PageSpecs can now include nested parens, "and", and "or". This remains
579     backwards compatible to the old GlobList format. It's implemented by
580     treating the GlobList as a very limited microlanguage that is transformed
581     to perl code that does the matching.
582   * The old GlobList format is deprecated, and I encourage users to switch to
583     using the new PageSpec format. Compatability with the old format will be
584     removed at some point, possibly by 2.0.
585   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
586   * Add support for creation_month and creation_year to PageSpec.
587     Closes: #380680
588   * Changes to index file encoding.
589
590  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
591
592 ikiwiki (1.12) unstable; urgency=low
593
594   "Viva l'Italia!"
595   * New pagestats plugin from Enrico, which can generate a table counting
596     the backlinks for each page, or a del.icio.us style cloud.
597   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
598     the wikiformat plugin works. Thanks, Emanuele Aina.
599   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
600     display, running them through pagetitle. This removes ugly underscores and
601     other gunk from the display, much nicer. You may want to rebuild your wiki
602     when upgrading to get the cleanup globally.
603   * Polygen plugin from Enrico.
604   * htmltidy plugin from Faidon.
605   * Locale patch from Faidon:
606     - Adds a locale setting to setup files.
607     - Proper local time, if the locale configuration option is used.
608     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
609       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
610       impossible.
611   * Add getopt hook type, this allows plugins to add new command-line options.
612   * Add --tagbase option to tag plugin.
613   * Add exclude option in setup files, works same as --exclude.
614   * Put categories in rss feeds for tagged items.
615   * Allow preprocessor directives to be expanded in inlined blog pages.
616     However, to avoid inlining loops etc, don't expand inline directives in
617     inlined pages.
618   * fortune plugin (trivial)
619   * Tag plugins according to type.
620
621  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
622
623 ikiwiki (1.11) unstable; urgency=low
624
625   * Patch from Enrico that
626     - Adds a tag plugin that allows more easily tagging pages.
627       The meta plugin can also still be used for that, but the tag plugin
628       also lists a page's tags at the bottom of the page.
629     - Allows preprocessor directives to have parameters with no specified
630       value.
631     - Fixes preprocessor directive parameter parsing so that
632       foo=bar baz now means "foo=bar" and a "baz" with no value.
633   * Run pagetemplate hooks when inlining pages so that inlined pages also
634     list their tags.
635   * Make all plugins with pagetemplate hooks check that variables exist
636     on the template before setting them, for robustness.
637   * Switch pagetemplate hooks to using named parameters.
638   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
639     This will be the page that a source page will be part of, which is
640     different than the source page for inlined pages.
641   * Audited all plugins to endure they pass (page, destpage) to htmllink
642     appropriatly. This means inlining of various plugins will not work
643     properly, with correct links generated.
644
645  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
646
647 ikiwiki (1.10) unstable; urgency=low
648
649   * Run page through any relevant filters when generating a page preview.
650   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
651     default throughout the wiki, not only on wikitext pages. Decided to call
652     this a feature, and split the camelcase support out into a separate plugin
653     that is independant of wikitext.
654   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
655
656  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
657
658 ikiwiki (1.9) unstable; urgency=low
659
660   * Improve display of parentlinks and page title of toplevel index page.
661   * Patch from Faidon to use svn --limit when possible for recentchanges,
662     speeds up recentchanges a lot for wikis with more history.
663   * Patch from Recai to fix utf8 issues in git backend.
664   * Add wikitext markup plugin, which supports ".wiki" pages written in the
665     original wiki syntax, CamelCase links and all.
666   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
667     support, to edit pages etc without a web server.
668   * Display CGI processing errors if present.
669   * Fix from Faidon for a XML parser issue that breaks utf-8 for
670     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
671     area, and also way slow.
672   * Match 'web commit from' in SVN and git, these are web commits too.
673     (Faidon)
674   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
675     readable and avoid future mistakes. The patch seems to work and for the
676     first time I have a UTF-8 username ;-) (Faidon)
677   * Use form->field consistently, not form->param.
678   * Patch from Recai to allow selection of page type when creating a new page.
679     Default page type is inherited from the link clicked on to create the new
680     page.
681
682  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
683
684 ikiwiki (1.8) unstable; urgency=low
685
686   * Fix orphans plugin to not count a link to a nonexistant page as a reason
687     for a page not being an orphan.
688   * Support pinging services such as Technorati using XML-RPC to notify them
689     about changes to rss feeds.
690   * Parse svn log as xml for improved utf8 and security. Note that this makes
691     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
692   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
693     flagged string even if the locale causes it to generate utf8 output,
694     so make sure to let perl know it should be handled as utf8. Also,
695     the optimised version used for standard time formats won't work if the
696     user has changed locale, so drop it. Thanks, Faidon Liambotis.
697   * Fix re-encoding of the comments field to utf8 if a commit fails
698     due to a conflict. Thanks, Faidon Liambotis.
699   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
700     Liambotis.
701   * Add insane double encode/decode to utf8 around call to markdown.
702     This works around a truely strange bug, which is apparently a bug in
703     perl, #376329. Also added a test case for it.
704   * Improve layout of edit page so formatting help link is always visible w/o
705     getting in the way of the preview.
706   * Centralised all calls to HTML::Template and force all the templates
707     to be read as utf8.
708   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
709   * Introduce add_plugins and disable_plugins config options in setup files.
710     This allows adding or removing plugins w/o overriding the whole list of
711     default plugins, which makes it easier to upgrade when new default plugins
712     are added.
713   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
714     default (of course!). Based on a patch by Faidon Liambotis.
715   * Add a html plugin, which can be used to write wikis in raw html,
716     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
717     defaults to not processing .html files, since w/o this plugin they would
718     be copied unsanitised. With this plugin, it will process and html
719     sanitise them, like any other page type.
720   * Rebuilding wrappers is necessary on upgrade to this version.
721   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
722     will be automatically done on all upgrades.
723   * Don't send pings if the wiki is being rebuilt.
724   * Work around very innefficient behavior in File::Spec::abs2rel. Result
725     is a savings of 2 pointless fork/execs per link calculation, which
726     results in ~25% speedup of ikiwiki building its own doc wiki, and
727     about 35% speedup displaying RecentChanges!
728   * Make RecentChanges use a table and some CSS, should be much more readable.
729     No code changes involved.
730   * Encode & in diffurl in examples, to conform to pedantic rules.
731   * Speed up RecentChanges by another 40% or so with some memoization.
732   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
733     in time to build the doc wiki.
734
735  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
736
737 ikiwiki (1.7) unstable; urgency=low
738
739   * Updated logo from Recai with some kerning and alingment tuning.
740   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
741     changed some output.
742   * Copyright update.
743
744  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
745
746 ikiwiki (1.6) unstable; urgency=low
747
748   * YA utf-8 patch from Recai, this time to fix previewing a page so that
749     the text in the input box is re-encoded back to utf-8.
750   * -CSD does not affect modules, so readfile() was not using the utf-8 input
751     layer, which led to lots of problems; make it force read files as utf-8.
752     Closes: #373203
753   * Note that as a consequence, this version of ikiwiki will actually try to
754     parse utf8 in source files for the first time, which may expose broken
755     utf8 in wiki sources that was hidden before. Most common will be
756     perl warnings like "utf8 "\xE9" does not map to Unicode"
757   * writefile() likewise needs to use the utf8 output layer.
758   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
759     there.
760   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
761     given the readfile fix.
762   * Add utf-8 testcases for readfile and htmlize.
763   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
764     safe.
765   * More utf-8 fixes from Recai, partly to things I broke above:
766     - The serious problem is that writefile() saves the content in undecoded
767       format in CGI, hence all (non-ascii) chars are corrupted permanently.
768     - Comment field in edit page is not decoded and all the non-ascii chars in
769       this field are corrupted as the result.  We should decode it as we do it
770       for the content.
771     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
772       character in print.
773   * New SVG logo from Recai.
774
775  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
776
777 ikiwiki (1.5) unstable; urgency=low
778
779   * Add --timeformat config option to allow changing how dates are displayed.
780     Note that as a side effect, dates will now be displayed using the local
781     timezone, not as GMT.
782   * More security review.
783   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
784     for some handy stuff like:
785     - Using links as a kind of tag; creating blog pages that list all pages
786       containing a given tag/link or not containing some other tag.
787     - Subscribing to mail notifications whenever a change is made to a page
788       that is a backlink of page foo. Ie, "Please notify me of changes in all
789       pages that link to my home page in the wiki"
790     - Locking any pages that are linked to from a particular page, so that
791       lists of locks can be exposed in the wiki.
792   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
793     when a todo item is done, instead of the previous moving it to a different
794     subdir.
795   * Allow pagetemplate plugins to override *anything* in the template.
796   * Add a meta plugin, which allows specifying various metadata about pages,
797     like license and author. It also allows for inserting html link and meta
798     tags into html, overriding the title, and adding hidden WikiLinks, which
799     can be useful when using link-based globbing for page categorisation.
800   * Remove preprocessor directives from inlined pages.
801   * Allow simple preprocessor directive values to be specified w/o quotes.
802   * Add support for using git instead of subversion as the RCS backend,
803     tremendous thanks to Recai Oktaş for this.
804   * Doc updates for git.
805   * Fix absolute url munging in rss generation to support https, ftp, etc urls
806     not just http urls.
807   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
808     utf-8 for edit and other fields, and for recentchanges. There may still
809     be utf-8 issues with the preferences page though.
810
811  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
812
813 ikiwiki (1.4) unstable; urgency=low
814
815   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
816     very strange way of enabling proper XHTML <br /> type tags. Output html
817     should be always valid again now.
818   * The page name and parent links has switched from using a <h1> to a styled
819     <span>, so pages can use <h1> internally instead of needing to use <h2>.
820   * Updated all of ikiwiki's own wiki pages for that.
821   * Add pagetemplate hook, which can be used by plugins that want to mess
822     around with adding new stuff to the page template.
823   * Remove headercontent; the search plugin now adds the search box to the
824     header by registering a pagetemplate hook, and other plugins should do
825     similarly.
826   * Rebuilding on upgrade to this version is recommended.
827   * Add a html validity check to the test suite, using the wdg-html-validator,
828     if available.
829   * Make the html valid when there is nothing in the actions list.
830   * Reordered some function call parameters for consistency.
831   * Enable full utf-8 support for page input and output.
832   * Add a workaround for markdown, which does not work well with utf-8
833     strings.
834   * --getctime had bitrotted (well I only ever used it the once so far..),
835     fix and make it a bit more flexible
836   * rcs_getctime is changed, now rather than needing to loop over all pages,
837     it should just use the rcs to get the ctime of the passed file.
838   * When inlining a page in another one, links from the inlined page are now
839     expanded the same as they are when rendering the inlined page as a
840     standalone page. So rather than being expanded from the POV of the
841     inlining page, they are expanded from the POV of the inlined page.
842
843     For example, a link from blog/foo to "bar" will now link to blog/bar
844     if it exists. Previously this needed to be a link explicitly to
845     "blog/bar"; such links will also continue to work.
846
847     (This was slightly complex to do as the link still has to be constructed
848     relative to the inlining page.)
849   * Make page edit textarea resize to fit browser window.
850   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
851     do not need a full rebuild, in order to update any basewiki pages.
852
853  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
854
855 ikiwiki (1.3) unstable; urgency=low
856
857   * Fix the preinst introduced in the last version. Closes: #367458
858
859  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
860
861 ikiwiki (1.2) unstable; urgency=low
862
863   * Remove dups from the brokenlinks list.
864   * Add libc6-dev to dependencies, needed to build wrappers.
865   * Install wikilist in correct location. Closes: #367371
866
867  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
868
869 ikiwiki (1.1) unstable; urgency=low
870
871   * Rename inlinepage to depends, so that it can be used to refer to more
872     dependency relationships than just inlining. This will require a rebuild
873     on upgrade to this version.
874   * Move the rss link, put it in the blogpost form if there is one and at the
875     top if not. This is both nicer because easier to find, and it cleans up
876     the code which had used inlinepage as a flag for adding the link later.
877   * Allow the depends GlobList to be built up from multiple sources (such as
878     plugins) during a page render.
879   * Which means that more than one blog is now supported to appear on a
880     single page. (With some limitations, like only the last one getting an
881     rss file.)
882   * Added a plugin system.
883   * Added a pagecount plugin, enabled by default.
884   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
885   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
886     backlinks when the backlinks hadn't really changed.
887   * Moved inline page support, rss generation etc into the inline plugin,
888     enabled by default.
889   * Added brokenlinks plugin, not enabled by default, but rather handy.
890   * Fix several broken links in the doc wiki.
891   * Smarter behavior when creating a page and a page of the same name (but
892     different location) already exists.
893   * Add an orphans plugin for finding pages that nothing links to.
894   * Removed backlinks page, which it turns out nothing used.
895   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
896     it, this will allow for adding a unit test suite.
897   * Add unit tests for several core functions, including globlist_match,
898     dirname, basename, bestlink, linkify, pagetitle, titlepage.
899   * Smart globlist merging.
900   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
901     to pave the way for adding other RCS support. This also changes the
902     setup files, where before they had svn => 1 or svn => 0, now they have
903     rcs => "svn" or rcs => "".
904   * Add a debian/NEWS file with upgrade notes.
905   * Load whatever rcs module is specified, so new ones can be just dropped in
906     as plugins and work. (Well, in theory.)
907   * Add some basic docs about writing RCS modules.
908   * Broke search capability out into a plugin, removed the --hyperestraier
909     switch.
910   * Added smiley plugin, nicely controlled and documented by the smileys page.
911   * Copied in some smileys from Moin Moin.
912   * Allow links of the form [[some page|page]], with whitespace in the link
913     text.
914   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
915     and --disable-plugin htmlscrubber.
916   * Allow discussion links on pages to be turned off with --no-discussion.
917   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
918   * Add some new config items to the estseek.conf template, which are needed
919     by hyperestraier 1.2.3.
920
921  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
922
923 ikiwiki (1.0) unstable; urgency=low
924
925   * First official release.
926
927  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400