Added a comment
[ikiwiki.git] / doc / forum / Problems_with_img_directive_on_nearly_free_speech / comment_1_c66ef7bcfd45cab29453cd0a17d71ea1._comment
1 [[!comment format=mdwn
2  username="openmedi"
3  ip="91.65.196.164"
4  subject="comment 1"
5  date="2014-10-22T22:01:41Z"
6  content="""
7 Okay. I figured it out with help from the nearlyfreespeech forum. It had nothing to do with ikiwiki. Nonetheless here's the solution, for posterity: You can check, if PerlMagick is installed by running ```perl -MImage::Magick -e \"print $Image::Magick::VERSION\"```.  If it isn't, you will get an error that looks like this:
8
9 >```Can't locate Image/Magick.pm in @INC (@INC contains: /usr/local/lib/perl5/5.16/BSDPAN /usr/local/lib/perl5/site_perl/5.16/mach /usr/local/lib/perl5/site_perl/5.16 /usr/local/lib/perl5/5.16/mach /usr/local/lib/perl5/5.16 .). 
10 BEGIN failed--compilation aborted. ```
11
12 If that's the case, you might have to upgrade/switch to a new \"realm\". As of the time of this writing PerlMagick is installed in the realms \"indigo\" and \"white\". How this is done, is described in the members only FAQ of nfs.
13 """]]