]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/changelog
hnb: Fixed broken use of mkstemp that had caused dangling temp files, and prevented...
[ikiwiki.git] / debian / changelog
index 31d64e2372b24854a3837cd47ced8cecfb529ada..15ae21a55c729179623c13b21d31e11464daef7e 100644 (file)
-ikiwiki (3.20100505) UNRELEASED; urgency=low
+ikiwiki (3.20100624) UNRELEASED; urgency=low
+
+  * Changes to avoid display of ugly google openids, by displaying
+    a username taken from openid.
+  * API: Add new optional field nickname to rcs_recentchanges.
+  * API: rcs_commit and rcs_commit_staged are now passed named
+    parameters.
+  * openid: Store nickname based on username or email provided from
+    openid provider.
+  * git: Record the nickname from openid in the git author email.
+  * comment: Record the username from openid in the comment page.
+  * Fixed some confusion and bugginess about whether
+    rcs_getctime/rcs_getmtime were passed absolute or relative filenames.
+    (Make it relative like everything else.)
+  * hnb: Fixed broken use of mkstemp that had caused dangling temp files,
+    and prevented actually rendering hnb files.
+
+ -- Joey Hess <joeyh@debian.org>  Wed, 23 Jun 2010 15:30:04 -0400
+
+ikiwiki (3.20100623) unstable; urgency=low
+
+  * openid: Add openid_realm and openid_cgiurl configuration options,
+    useful in a few edge case setups.
+  * attachment: Show files from underlay in attachments list.
+  * img: Support hspace and vspace attributes.
+  * editpage: Rename "comments" field to avoid CSS conflict with the
+    comments div.
+  * edittemplate: Make silent mode not disable display when the template
+    page does not exist, so it can be easily created.
+  * edittemplate: Look for template pages under templates/ like everything
+    else (still looks in old location for backwards compatibility).
+  * attachment: When inserting links, insert img directives for images,
+    if that plugin is enabled.
+  * websetup: Allow enabling plugins listed in disable_plugins.
+  * editpage, comments: Fix broken links in sidebar (due to forcebaseurl).
+    (Thanks, privat)
+  * calendar: Tune archive_pagespec to only match pages, not other files.
+  * Fix issues with combining unicode srcdirs and source files.
+    (Workaround bug #586045)
+  * Make --gettime be honored after initial setup.
+  * git: Fix --gettime to properly support utf8 filenames.
+  * attachment: Support Windows paths when taking basename of client-supplied
+    file name.
+  * theme: New plugin, allows easily themeing a site via the underlay.
+  * Added actiontabs theme by Svend Sorensen.
+  * Added blueview theme by Bernd Zeimetz.
+  * mercurial: Fix buggy getctime code. Closes: #586279
+  * link: Enhanced to handle URLs and email addresses. (Bernd Zeimetz)
+
+ -- Joey Hess <joeyh@debian.org>  Wed, 23 Jun 2010 14:10:26 -0400
+
+ikiwiki (3.20100610) unstable; urgency=low
+
+  * creation_day() etc use local time, not gmtime. To match calendars, which
+    use local time.
+  * img: Fill in missing height or width when scaling image.
+  * Remove example blog tag pages; allow autotag creation to create them
+    when used.
+  * Fix support for globbing in tagged() pagespecs.
+  * Fix display of sidebar when previewing page edit. (Thanks, privat)
+  * relativedate: Fix problem with localised dates not working.
+  * editpage: Avoid storing accidental state changes when previewing pages.
+  * page.tmpl: Add a div around the page content, and comments, to aide in
+    sidebar styling.
+  * style.css: Improvements to make floating sidebar fit much better on
+    pages with inlines.
+  * calendar: Shorten day names, and improve styling of month calendar.
+  * style.css: Reduced sidebar width back to 20ex from 30; the month calendar
+    will now fit in the smaller width, and 30 was feeling too large.
+
+ -- Joey Hess <joeyh@debian.org>  Thu, 10 Jun 2010 14:24:05 -0400
+
+ikiwiki (3.20100518.2) unstable; urgency=low
+
+  * Fix a typo in the last release.
+
+ -- Joey Hess <joeyh@debian.org>  Tue, 18 May 2010 14:17:01 -0400
+
+ikiwiki (3.20100518) unstable; urgency=low
+
+  * page.tmpl: Accidentially broke po plugin's otherlanguages list styling
+    when modifying for html5; now fixed.
+  * Fix a bug that prevented matching deleted comments, and so did not update
+    pages that had contained them.
+
+ -- Joey Hess <joeyh@debian.org>  Tue, 18 May 2010 13:37:39 -0400
+
+ikiwiki (3.20100515) unstable; urgency=low
 
   * Removed misc.tmpl. Now to theme ikiwiki, you only need to customise
     a single template, page.tmpl.
   * If you have a locally customised page.tmpl, it needs to be updated
-    to set <base> when BASEURL or FORCEBAREURL is set.
+    to set <base> when BASEURL or FORCEBASEURL is set.
+  * comments: Comments pending moderation are now stored in the srcdir
+    alongside accepted comments, but with a `._comment_pending` extension.
+    This allows easier byhand moderation, as the "_pending" need
+    only be stripped off and the comment be committed to version control.
+  * The `comment_pending()` pagespec can be used to match such unmoderated
+    comments, which makes it easy to add a feed of them, or a counter
+    indicating how many there are.
+  * Belatedly added a `comment()` pagespec.
   * Gave comment and page editing forms some CSS and accessability love.
   * Renamed postscan hook to indexhtml, to reflect its changed position,
     and typical use.
   * inline: Call indexhtml when inlining internal pages, so their
     text can be indexed for searching.
   * Delete hooks are passed deleted internal pages. 
-
- -- Joey Hess <joeyh@debian.org>  Wed, 05 May 2010 18:07:29 -0400
+  * openid: Incorporated a fancy openid-selector signin form.
+    (Based on http://code.google.com/p/openid-selector/)
+  * openid: Use "openid_identifier" as the form field, as required
+    by OpenID Authentication v2.0 spec.
+  * Removed the openidsignup option. Instead, my recommendation is to
+    leave passwordauth enabled and let people who don't have an openid use it.
+    The openid selector form avoids the UI annoyance of having both openid
+    and passwordauth on one form.
+  * calendar: Allow negative month to be specified. -1 is last month, etc.
+    (And also negative years.)
+  * calendar: Display year in title of month calendar.
+  * Use xhtml friendly pubdate setting.
+  * remove, rename: Add guards against XSRF attacks.
+
+ -- Joey Hess <joeyh@debian.org>  Sat, 15 May 2010 21:00:45 -0400
 
 ikiwiki (3.20100504) unstable; urgency=low