]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/rules
fix clean on clean tree
[ikiwiki.git] / debian / rules
index da8249920a4daa0208c3e9cf7098ba7b1b5a00fa..bdbbf005002492bc5552bbe9135e8e6e5cd911a8 100755 (executable)
@@ -1,13 +1,18 @@
 #!/usr/bin/make -f
+%:
+       dh $@
+
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
 
-binary: binary-indep
-binary-indep:
-       dh $@ --before dh_compress
+override_dh_compress:
+       # avoid compressing files in the doc wiki
        dh_compress -Xhtml
-       dh $@ --after dh_compress
 
-%:
-       dh $@
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       -$(MAKE) realclean
 
 # Not intended for use by anyone except the author.
 announcedir: