]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/rules
comments
[ikiwiki.git] / debian / rules
index da8249920a4daa0208c3e9cf7098ba7b1b5a00fa..0a65715214cf2464dc021bc820de3f5bf049a1f6 100755 (executable)
@@ -1,13 +1,18 @@
 #!/usr/bin/make -f
+%:
+       dh $@
+
+# keeps it out if /usr/local
+override_dh_auto_configure:
+       dh_auto_configure -- PREFIX=/usr
 
-binary: binary-indep
-binary-indep:
-       dh $@ --before dh_compress
+# avoid compressing files in the doc wiki
+override_dh_compress:
        dh_compress -Xhtml
-       dh $@ --after dh_compress
 
-%:
-       dh $@
+# distclean moans about MANIFEST, this is quieter
+override_dh_auto_clean:
+       $(MAKE) realclean
 
 # Not intended for use by anyone except the author.
 announcedir: