]> sipb.mit.edu Git - ikiwiki.git/blobdiff - doc/install.mdwn
web commit by tschwinge: Thanks!, and a bug report.
[ikiwiki.git] / doc / install.mdwn
index b01fcdf6bc6a14ef7532a94cffd8558e4b74064b..6fdc8bb9e14e46ca61c35a964875ad148b8daa37 100644 (file)
@@ -5,19 +5,32 @@ most unix-like systems.
 Ikiwiki is a perl program, and needs a recent version of perl such as
 5.8.8. (5.8.0 has been reported not to work).
 
-Ikiwiki requires the [[cpan Text::Markdown]], [[cpan URI]] and
-[[cpan HTML::Parser]] perl modules be installed, and also uses the
-following perl modules if available: 
-[[cpan CGI::Session]], [[cpan CGI::FormBuilder]] (version 3.02.02 or newer),
-[[cpan HTML::Template]], [[cpan Mail::Sendmail]], [[cpan Time::Duration]]
-[[cpan TimeDate]], [[cpan HTML::Scrubber]], [[cpan RPC::XML]],
-[[cpan XML::Simple]], [[cpan XML::Feed]], [[cpan File::MimeInfo]].
+Ikiwiki requires the [[cpan Text::Markdown]], [[cpan URI]],
+[[cpan HTML::Parser]], and [[cpan HTML::Template]] perl modules be
+installed.
 
-The [[tla]] support also needs the [[cpan MailTools]] perl module.
+It also uses the following perl modules if available: [[cpan
+CGI::Session]], [[cpan CGI::FormBuilder]] (version 3.05 or newer), [[cpan
+Mail::Sendmail]], [[cpan Time::Duration]], [[cpan TimeDate]], [[cpan
+HTML::Scrubber]], [[cpan RPC::XML]], [[cpan XML::Simple]], [[cpan
+XML::Feed]], [[cpan File::MimeInfo]], [[cpan Locale::gettext]] (version
+1.04 or newer).
+
+It's recommended you have a C compiler, as ikiwiki uses one to build
+wrappers.
 
 Various [[plugins]] use other libraries and utlities; see their individual
 documentation for details.
 
+The Debian packages depend on and recommend an appropriate set of packages.
+
+While Fedora 7 doesn't have an ikiwiki package, you can install needed
+perl modules using this command:
+
+       yum install perl-Text-Markdown perl-Mail-Sendmail perl-HTML-Scrubber \
+         perl-XML-Simple perl-TimeDate perl-HTML-Template perl-CGI-FormBuilder \
+         perl-CGI-Session perl-File-MimeInfo perl-gettext
+
 If you want to install from the tarball, you should make sure that the
 required perl modules are installed, then run: