patch plugin documentation to refer to directive pages
[ikiwiki.git] / doc / plugins / graphviz.mdwn
index fb669ae219ceed219c5db318b9ce0efc0b24fc23..51b06ebab341d2c682d8769115ea1e919187563f 100644 (file)
@@ -1,13 +1,8 @@
-[[template id=plugin name=graphviz author="[[JoshTriplett]]"]]
-[[tag type/chrome type/format]]
+[[!template id=plugin name=graphviz author="[[JoshTriplett]]"]]
+[[!tag type/chrome type/format]]
 
 
-This plugin allows embedding [graphviz](http://www.graphviz.org/) graphs in a
-page.  Example usage:
-
-       \[[graph src="a -> b -> c; a -> c;"]]
-
-Note that graphs will only show up in previews if your browser has
-[[wikipedia data: URI]] support, or if the same graph already exists on that
+This plugin implements the [[ikiwiki/directive/graph]] [[ikiwiki/directive]].
+This directive allows embedding [graphviz](http://www.graphviz.org/) graphs in a
 page.
 
 Security implications: graphviz does not seem to have any syntax exploitable to
 page.
 
 Security implications: graphviz does not seem to have any syntax exploitable to
@@ -20,22 +15,4 @@ already do these things with just the core of ikiwiki, but the graphviz plugin
 allows for an amplification attack, since users can send less data to use large
 amounts of processing time and disk usage.
 
 allows for an amplification attack, since users can send less data to use large
 amounts of processing time and disk usage.
 
-The `graph` directive supports the following parameters:
-
-- `src` - The graphviz source to render.
-- `type` - The type of graph to render: `graph` or `digraph`.  Defaults to
-  `digraph`.
-- `prog` - The graphviz program to render with: `dot`, `neato`, `fdp`, `twopi`,
-  or `circo`.  Defaults to `dot`.
-- `height`, `width` - Limit the size of the graph to a given height and width,
-  in inches. You must specify both to limit the size; otherwise, graphviz will
-  choose a size, without any limit.
-
-[[if test="enabled(graphviz)" then="""
-Some example graphs:
-
-[[graph src="a -> b -> c; a -> b;"]]
-[[graph src="a -- b -- c -- a;" prog="circo" type="graph"]]
-"""]]
-
-This plugin uses the [[cpan Digest::SHA1]] perl module.
+This plugin uses the [[!cpan Digest::SHA1]] perl module.