]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/rules
changelog
[ikiwiki.git] / debian / rules
index 0a65715214cf2464dc021bc820de3f5bf049a1f6..0a7ce7a267e43c0999d6e468f7e6844abbc8d660 100755 (executable)
@@ -2,17 +2,17 @@
 %:
        dh $@
 
-# keeps it out if /usr/local
 override_dh_auto_configure:
+       # keeps it out of /usr/local
        dh_auto_configure -- PREFIX=/usr
 
-# avoid compressing files in the doc wiki
 override_dh_compress:
+       # avoid compressing files in the doc wiki
        dh_compress -Xhtml
 
-# distclean moans about MANIFEST, this is quieter
 override_dh_auto_clean:
-       $(MAKE) realclean
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi
 
 # Not intended for use by anyone except the author.
 announcedir: