]> sipb.mit.edu Git - ikiwiki.git/blobdiff - IkiWiki/Plugin/mdwn.pm
Improve error message when postsignin (probably from openid) fails due to
[ikiwiki.git] / IkiWiki / Plugin / mdwn.pm
index 0fc077f5ec1cc1a30eaffba1ce8d323cccf160cf..c087f2b41309f892e52476305bf31ccc48fb7840 100644 (file)
@@ -10,35 +10,41 @@ sub import { #{{{
        hook(type => "htmlize", id => "mdwn", call => \&htmlize);
 } # }}}
 
        hook(type => "htmlize", id => "mdwn", call => \&htmlize);
 } # }}}
 
-my $markdown_loaded=0;
+my $markdown_sub;
 sub htmlize (@) { #{{{
        my %params=@_;
        my $content = $params{content};
 
 sub htmlize (@) { #{{{
        my %params=@_;
        my $content = $params{content};
 
-       if (! $markdown_loaded) {
-               # Note: This hack to make markdown run as a proper perl
-               # module. A proper perl module is available in Debian
-               # for markdown, but not upstream yet.
+       if (! defined $markdown_sub) {
+               # Markdown is forked and splintered upstream and can be
+               # available in a variety of incompatible forms. Support
+               # them all.
                no warnings 'once';
                $blosxom::version="is a proper perl module too much to ask?";
                use warnings 'all';
 
                eval q{use Markdown};
                no warnings 'once';
                $blosxom::version="is a proper perl module too much to ask?";
                use warnings 'all';
 
                eval q{use Markdown};
-               if ($@) {
+               if (! $@) {
+                       $markdown_sub=\&Markdown::Markdown;
+               }
+               else {
                        eval q{use Text::Markdown};
                        eval q{use Text::Markdown};
-                       if ($@) {
+                       if (! $@) {
+                               $markdown_sub=\&Text::Markdown::Markdown;
+                       }
+                       else {
                                do "/usr/bin/markdown" ||
                                do "/usr/bin/markdown" ||
-                                       error("failed to load Markdown.pm perl module ($@) or /usr/bin/markdown ($!)");
+                                       error(sprintf(gettext("failed to load Markdown.pm perl module (%s) or /usr/bin/markdown (%s)"), $@, $!));
+                               $markdown_sub=\&Markdown::Markdown;
                        }
                }
                        }
                }
-               $markdown_loaded=1;
                require Encode;
        }
        
        # Workaround for perl bug (#376329)
        $content=Encode::encode_utf8($content);
        $content=Encode::encode_utf8($content);
                require Encode;
        }
        
        # Workaround for perl bug (#376329)
        $content=Encode::encode_utf8($content);
        $content=Encode::encode_utf8($content);
-       $content=Markdown::Markdown($content);
+       $content=&$markdown_sub($content);
        $content=Encode::decode_utf8($content);
        $content=Encode::decode_utf8($content);
 
        $content=Encode::decode_utf8($content);
        $content=Encode::decode_utf8($content);