]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/changelog
git: Fix parsing of git logs with no commit messages at all.
[ikiwiki.git] / debian / changelog
index 667869064e33555a0fc4a0c40710970b8191f59a..1237217412924901e65cc0b5ab532e147413549b 100644 (file)
@@ -1,10 +1,50 @@
 ikiwiki (2.54) UNRELEASED; urgency=low
 
+  [ Joey Hess ]
   * Make it possible to load setup files w/o running them. Code
-    needing to do so can call IkiWiki::Setup::load, and the values will
-    be loaded into %IkiWiki::Setup::setup.
+    needing to do so can call IkiWiki::Setup::load, which will return
+    a hash of values.
+
+  [ Josh Triplett ]
+  * ikiwiki-transition: Fix command-line processing so the prefix_directives
+    transition works again.
 
- -- Joey Hess <joeyh@debian.org>  Wed, 09 Jul 2008 22:27:19 -0400
+  [ Joey Hess ]
+  * template: Add support for a BASENAME variable.
+  * Fixes creation of pages when clicking on WikiLinks starting with "/".
+  * Change deb dependencies to list Text::Markdown before markdown, since
+    the former, while slower, has a much better html parser that avoids
+    numerous bugs.
+  * Move yesno function out of inline and into IkiWiki core, not exported.
+  * Error handling improvement for preprocess hooks. It's now safe to call
+    error() from such hooks; it will cause a nicely formatted error message
+    to be inserted into the page.
+  * Cut the size of the binary package in half by excluding pages for bugs
+    and todo items from the html shipped in it.
+  * parentlinks: New plugin, split out of ikiwiki core and enabled by default,
+    and several new fields added to allow for advanced styling. (intrigeri)
+  * smileys: Some fixes for escaped smileys.
+  * smileys: Note that smileys need to be double-escaped for the escaping to
+    work. Markdown removes one level of escaping.
+  * Add a postscan hook.
+  * search: Use postscan hook, avoid updating index when previewing.
+  * git: Put web committer name/openid/address in the git author field.
+    The committer's email address is not used (because leaking email addresses
+    is not liked by many users). Closes: #451023
+  * git: Fix parsing of git logs with no commit messages at all.
+
+  [ Simon McVittie ]
+  * meta, inline: Support guid options, to allow forcing a particular url or
+    uuid in feeds.
+  * meta: fix title() PageSpec
+  * Some footer style changes.
+  * aggregate: Add an `aggregateinternal` option, which allows storing
+    aggregated data to internal-use files, rather than wiki pages. This
+    can save disk space, and be faster.
+  * ikiwiki-transition: Add a `aggregateinternal` transition to rename
+    the aggregated files.
+
+ -- Josh Triplett <josh@freedesktop.org>  Wed, 09 Jul 2008 21:30:33 -0700
 
 ikiwiki (2.53) unstable; urgency=low
 
@@ -117,7 +157,7 @@ ikiwiki (2.48) unstable; urgency=high
     pounding on the cgi following edit links.
   * passwordauth: If Authen::Passphrase is installed, use it to store
     password hashes, crypted with Eksblowfish.
-  * `ikiwiki-transiition hashpassword /path/to/srcdir` can be used to
+  * `ikiwiki-transition hashpassword /path/to/srcdir` can be used to
     hash existing plaintext passwords.
   * Passwords will no longer be mailed, but instead a password reset link.
   * The password_cost config setting is provided as a "more security" knob.